A connection could not be established


  • I'm setting up SQL 2005 Reporting Services on a Windows 2003 R2 SP2 machine and trying to configure the Database Setup to a SQL 2005 Virtual Server Instance running on a x64 2-node a/p Cluster.  The virtual server is registered in DNS but when I attempt the 'connect' using Windows Integrated Authentication.  I get the following error:

    "A connection could not be established with the information provided.  Click OK to change your connection settings.

    An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provide: Named Pipes Provider, error: 40 - could not open connection to SQL Server) "


    The SQL cluster is configured to allow Local or Remote connections TCP or Named Pipes. 


    Any suggestions?  

    Friday, March 14, 2008 5:30 PM

All replies

  • I.   Incorrect connection string, such as using SqlExpress.

    Check out:


    The typical error when dealing with Express includes:

    a.  User is not aware of SqlExpress was installed as a named instance, consequently, in his/her connection string, he/she only specify ".","localhost" etc instead of ".\SqlExpress" or "<machinename>\Sqlexpress".

    b. Np was disabld by default after installing SqlExpress.

    c. If Sqlexpress was installed on the remote box, you need to enable remote connection for Express.

    Please read the following blog for best practice of connecting to SqlExpress.


    II. Named Pipes(NP) was not enabled on the SQL instance.

    Check out:

    Oppose to SQL 2000 which turn on all protocols, SQL 2005 SKUs turn off NP by default. So, when you see this error, please check:

    1) Go to SQL Server Configuration Manager, See Server has NP enabled.

    2) %windir%\program files\microsoft sql server\mssql.1\mssql\log, notepad ERRORLOG, see whether Server is listening on NP.  You should see "Server named pipe provider is ready to accept connection on [ \\.\pipe\sql\query ] or [\\.\pipe\mssql$<InstanceName>\sql\query]"

    3) Notice that "sql\query" is the default pipe name, so you need to know server is listening on which pipe name. eg: if you specify server pipe name is "sql\query1", then you would see in the errorlog that server listening on [ \\.\pipe\sql\query1 ], and go to SQL Server Configuration Manager, click client Named Pipe properties, see whether the pipe name is same with the one server listening on.

    4) If you are using SQL Native Client ODBC/OLEDB provider({SQL Native Client} or SQLNCLI), go to SQL Configuration Manager, click client protocols, make sure NP and TCP are both enabled. Right click properties of NP, make sure client is using the same pipe name as server for connection.

    5) If you are using MDAC ODBC/OLEDB({SQL Server} or SQLOLEDB) provider, in command line, launch "cliconfg.exe" and make sure NP enabled and right pipe name specified.


    III. Remote connection was not enabled. 

    Check out: when you right click on the Server in SQL Server Management Studio, in Connections, the Remote server connections part, you have enabled the "Allow remote connections to this server" check box

    If you are making a remote connection, namely, your target SQL Server is on the different box as client application, you might need to check whether:

    a. "File and Printer Sharing" was opened in Firewall exception list.

    b. Please see the blog for enabling remote connection for express and troubleshooting tips of remote connection.


    IV. Server not started, or point to not a real server in your connection string.

    Check out: Open SQL Server Surface Area Configuration and ensure all the required services are started, Remote Connections are configured.

    a. use "sc query mssqlserver" for default instance or "sc query mssql$<instancename>" to make sure SQL Server was started. Sometimes, reseason behind the broken of your client application w/ this error:40 might be SQL server restarted and failed, so, it'd better for you to double check.

    b. User specified wrong server in their connection string, as described in the forum discussion, "MSSQLSERVER" is an invalid instance name. Remember, when you connect to default instance, <machinename> could be best representitive for the instance, when you connect to a named instance such as sqlexpress, you should specify <machinename>\<instancename> as data source in your connection string.


     V. Other reasons such as incorrect security context.

    Check out:

    Such error also occured during user operation such as moving database or db mirroring or cluster, any DB OP that might invovle different sql instances, namely, the destination database is located in another sql instance and user is not aware of the state of the destination. I recommend you first isolate whether this fail is during connection stage or data operation stage.

    a. During data operation, you are normally asked to type in the destination server name whether it is default to "(local)" or another server "<remotemachinename>". So, remember the exact string that represent the target instance, then when the error repros, open command line, use "sqlcmd -S<representitive> -E" ,see what happens, if the connection fail, please follow up above I - IV troubleshooting lists. otherwise continue.

    b. If you can make basic conection, but still face the error, then there must be something that server reject the connection or client close the connection for some reason.


    VI. Please try basic connectivity tests between the two mahcines you are working on. One simple way to verifty connectivity is to use command line tools, such as osql.exe. For example, osql -E -StcpTongue Tiedervername\instancename. If it connects cross-machine successfully, please also verify that your connection string in your scenario is correct.


    Here are some blogs which could be helpful: just follow the basic connectivity troubleshooting guidelines on the SQL Protocols blog, see:

    SQL Server 2005 Connectivity Issue Troubleshoot - Part I


    SQL Server 2005 Connectivity Issue Troubleshoot - Part II


    Hope this helps.


    Tuesday, May 20, 2008 5:52 AM