none
tabular model error : microsoft.ace.oledb.12.0 provider not registered

    Question

  • Hi All,

    while creating tabular model using a SQL Server datatools....i m doing import data from excel....the files are in excel 2010 (.xlsx)

    it throws error "microsoft.ace.oledb.12.0 provider not registered. ...Class not registered....."...

    I installed access database engine ...still the same error....

    plz help...


    Thanks & Regards, Chaitali Thaker

    Thursday, June 14, 2012 5:32 AM

Answers

All replies

  • Are you running on a 64 bit PC?

    Install the 64 bit of Access Database Engine.

    Thursday, June 14, 2012 6:23 AM
  • my OS is 64 bit but whn i try to install 64 but of access database engine..it throws error tht i cannot install this version since  i have 32 bit office tools....

    what should i do now?

    i also tried installing 32 bit version ..it got installed successfully. but while importing data from excel it throws the same error..

    i also tried restarting my machine but still the error..

    plz help


    Thanks & Regards, Chaitali Thaker


    Thursday, June 14, 2012 7:14 AM
  • I have the same issue. I have 64 bit OS and 32 bit Office tools installed already. When i tried import excel data within the SQL Server Data Tools, Tabular model instance, i get the following error "The provider 'Microsoft.ACE.OLEDB.12.0' is not registered." 

    And i tried to install the 32 bit Access database engine even after that i still get the same error.<o:p></o:p>

    And also i looked up over net to fix this issue, some forum says I need to uninstall the 32 bit office tool and install the 64 bit Office tool.<o:p></o:p>

    I am not quite sure will above solution going to work, can somebody please help me to resolve this issue.

    Wednesday, August 28, 2013 7:46 AM
  • Hi,

    To install the Microsoft ACE OLEDB Provider 64-bit on a machine running Office 2010 32-bit use the command line with and run the command with the "passive" option:

    $> AccessDatabaseEngine_64.exe /passive

    otherwise you will get an error message. I found this solution here:

    http://blog.codefluententities.com/2011/01/20/microsoft-access-database-engine-2010-redistributable/

    hope that helps. Kind Regards,

    Monday, January 26, 2015 10:33 AM
  • I had the exact same problem --  it was very frustrating.  But your solution worked!  

    Thanks!

    Monday, April 13, 2015 7:39 PM