locked
Empty Sysperfinfo table and blank sql performance monitor counters RRS feed

All replies

  • hi

    sysperfinfo will be removed feature versions.

    check this link for more info

    http://technet.microsoft.com/en-us/library/ms189806.aspx


    Ramesh S
    www.sequalserver.com
    Saturday, July 31, 2010 6:35 AM
  • Could you please check SQL Error Logs and look for any error related to perfomance counter?

     


    Balmukund Lakhani | Please mark solved if I've answered your question
    --------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
    --------------------------------------------------------------------------------
    My Blog: http://blogs.msdn.com/blakhani
    Team Blog: http://blogs.msdn.com/sqlserverfaq
    Saturday, July 31, 2010 7:01 AM
  • Thanks for your replies.

    I have just run the sql installation disk again to check whether something wasn't installed. The management tools were fully installed so that's not the problem.

    Having checked the log, I can see a few issues that certainly look related:

    Windows kernel object 'Global\SQL_90_MEMOBJ_MSSQLSERVER_0' already exists. It's not owned by the SQL Server service account. SQL Server performance counters are disabled.

    Performance counter shared memory setup failed with error -1. Reinstall sqlctr.ini for this instance, and ensure that the instance login account has correct registry permissions.

    I have just googled these errors and it looks like I need to grant some extra priviledges to the account SQL is running under. I will do so and report back.

    Matt 

    Monday, August 23, 2010 11:12 AM
  • Is there any update on this. I am too facing similar error when tried changing SQL Services to run under domain account.
    Friday, March 30, 2012 2:31 PM
  • Hi Viren. This issue seems related to some sort of User Rights Assignment problem. I am facing it too and on a personal VM I can fix it by loggin-in/loggin-out from the server with the account used to start the service. Then restart MSSQL service and the counter comes back again. But on enterprise servers this may not work, so you would have to check ALL the permissions of the domain account used for MSSQL service.

    see http://msdn.microsoft.com/en-us/library/ms143504(v=sql.105).aspx for more details

    I will post my experiences on the web too: http://thelonelydba.wordpress.com/2012/07/24/missing-performance-counters-on-sqlserver-2008/

    Edit: a logon/logoff followed by a server restart fixed the problem on a enterprise server that is part of a domain.
    • Edited by MauricioRPP Wednesday, July 25, 2012 9:36 PM new information.
    • Proposed as answer by Sethu Srinivasan Thursday, August 30, 2012 5:44 PM
    Tuesday, July 24, 2012 12:02 PM