none
SQL 2005 Standard edition fails during installation

    Question

  • When trying to install SQL 2005, I keep getting the foll. error:

    Error 1706. Setup cannot find the required files. Check your connection to the network or CD-Rom drive. For other potential soltions to this problem, see C:\Program ....\1033\setup.chm

    I have tried using two different DVDs, and also downloaded SQL 2005 from msdn, but none of them work.

    Can some please help.

    Thanks,

    Amir

    acharania@trimontrea.com

     

    Wednesday, January 04, 2006 1:33 PM

Answers

  • After much trial and error I found that if you uninstall Office Web Coponents it works - just did in the add/remove programs part of Windows/Control Panel as it is a stand-alone app.
    Wednesday, April 05, 2006 7:38 AM

All replies

  • Does anyone have any suggestions on this???

    Thanks,

    Amir

    Tuesday, January 10, 2006 1:21 PM
  • Amir,

    Try copying all files from the DVD to a folder on your "hard" disks and install from there.

    MikeC

    Wednesday, January 11, 2006 11:53 PM
  • I am having the same problem as Amir. I am providing as much info as I can, so you all can help me if you all know what seems to be the problem.

    Ok, I am trying to install SQL Server 2005 Developer Edition on (32-bit version) on Windows 2003 Server (SP1). I have SQL Server 2000 (SP4) already installed on the server and I created a new named instance to install SQL Server 2005 as I want to keep SQL Server 2000 also and not upgrade from 2000 to 2005. I am tring to install it remotely to one of our servers in Cincinitti and I am in Houston.  I have copied over the files from the DVD to the Server and have tried installing it and it gives the following error during the install :

    "Setup cannot find the required files. Check your connection to the network, or CD-ROM drive.  For other potential solutions to this problem, see C:\Program Files\Microsoft Office\OFFICE11\1033\SETUP.CHM."

    Also I want to mention that on our windows server has "Internet Explorer Enhanced Security Configuration" I am sure its not the CD-Rom drive issue as the files are read from hard drive and I have double checked all my files are copied over to the hard drive properly. So I guess its the connection to the network, but I am not 100% sure. If its the connection then I am wondering why during setup it needs internet access as all the setup files are sitting on the hard drive. I have installed sql sever 2005 on my cleint machine with windows XP and everything went smooth and I never had this error.

    Please help if you think you know what the issue might be. Thanks in advance.

    Thursday, February 23, 2006 10:28 PM
  • Another possiblity would be to download the 2 CD images and try installing from them instead of the DVD files.

    Also, do you or did you have any pre-release copies of SQL 2005 installed?  If so, you have to make sure you uninstall 2.0 .NET that came with it in addition to uninstalling the CTP of SQL 2005.

     

    Friday, February 24, 2006 4:49 PM
  • I don't have any CD's for SQL2005, our company has msdn subscription and the SQL2005 DVD is the latest (dated dec 05) so from this dvd we copied the files to the server, as the server is in some other state and its no local. Also I need to mention that all files  were copied over to the server expect for the SQL2005 x64 (64-bit) version which we didn't need as we were installing SQL2005 x86(32-bit) version. Do you think this might  be the reason ??? 

    No we just had SQL Server 2000 SP4 already installed on the server and we never did try and install SQL2005 before this.

    Thanks alot :)

    Tuesday, February 28, 2006 4:17 PM
  • A couple of other things you could check.

    Make sure the file exists that is referenced in your error message.  If not, that means it never added the office component that installs with sql.

    That leads to the second thing.  I would verify that you did get all the files pulled over properly to your remote server by checking the properties and the total file size for the folder contents from your local copy and the remote copy.

    If they match, you may want to try mapping a drive to the file location that holds the DVD files and running setup from the mapped drive, although I don't think this will help.  Its looking like the most likely possiblity is a missing or corrupt file.  You may even want to try installing locally to see if you get the same error.  If so, I would redownload the DVD image again.

    Wednesday, March 01, 2006 1:34 PM
  • Take another look at the error message. There is no file referanced in it.

     

     I'm getting the same error trying to install the client tools for SQL 2005.

    Monday, March 06, 2006 7:45 PM
  • Richard, I was referring not to the file that is missing, but the file that it tells you to find help in...  C:\Program Files\Microsoft Office\OFFICE11\1033\SETUP.CHM

    If that file is not there, it didn't even take care of some prerequisites before getting to the error.  Don't know if that helps too much, except to narrow down where the installation process really failed.

    Monday, March 06, 2006 9:59 PM
  • yeah, that help file doesn't actually tell you what is wrong or how to fix it.

     

    This entry in the install log files seems more helpfull. I'm continuing to persue this problem at my end.

    From SQLSetup0003_Machinename_OWC11_1.log

    MSI (s) (64:B4) [13:33:12:070]: Note: 1: 2262 2: CustomAction 3: -2147287038
    MSI (s) (64:B4) [13:33:12:070]: PROPERTY CHANGE: Adding SMARTSOURCEDIR property. Its value is 'C:\DOCUME~1\ADMINI~1.ELL\LOCALS~1\Temp\IXP000.TMP\'.
    Action start 13:33:12: SetSMARTSOURCEDIR_FromReg.

     

    This is the source of my problem as this directory no longer exist and the install program does not as me for an alternate location.

    I think the program is looking for office 2003 feature. So I'll try running  a repair on that.

    Monday, March 06, 2006 10:47 PM
  • After much trial and error I found that if you uninstall Office Web Coponents it works - just did in the add/remove programs part of Windows/Control Panel as it is a stand-alone app.
    Wednesday, April 05, 2006 7:38 AM
  • I had exactly this problem. It was not obvious other than the first error was that OWC failed with the 1706 error. Other modules failed with unable to install on this version of Windows errors.

    Removed the OWC module and install worked without a hitch.

    The install also broke my install of SQL 2000. Running Enterprise Manager would give an MMC error Snap-in failed to initialize. I had to reinstall SQL 2000.

     

     

    Thursday, August 10, 2006 8:25 PM
  • Hi JHD, you're a gem. I had the same problem installing SQL Server 2005 on a new machine with Windows Vista Ultimate and MS Office 2007 installed from the factory. Uninstalling Office Web Components 2003 and the reinstalling SQL Server did it. Where would we be without Google and people like you.

    Saturday, February 10, 2007 5:05 AM
  • JHD, thanks a bunch.  I ran into the same problem when installing SQL Sever 2005 on WinXP Pro.  Your post put an end to my endless search for the solution.   Once again, thank you very much!
    Wednesday, February 14, 2007 5:54 PM
  • KA-Ching! Thanks JHD! That did the trick.
    Friday, February 16, 2007 7:20 PM
  • JHD,

    Thanks so much for taking the time to post this info!  How the failure to install OWC would cause the important parts of SQL server, like the server itself to not install properly is beyond me.

    Removing OWC did the trick.

    For what it's worth: I had Visual studio 2005 and office 2007 installed prior to trying to install SQL 2005 standard on Win XP sp2.  Hindsight says perhaps I should have installed SQL  before office 2007.

     

    Saturday, February 24, 2007 4:21 PM
  • Thanks for posting this information, guys!  I ran into the same problem with a fresh Windows Vista Ultimate from the factory.  I spent countless hours trying to determine the source of the problem.  Once I uninstalled the Microsoft Office Web Components, the SQL Server 2005 Standard Edition installation worked.  I haven't decided whether to reinstall the OWC -- researching it now...
    Sunday, February 25, 2007 2:44 PM
  • Hi TKent,

    I Think you will see that the installation of SQL Server 2005 also installs OWC. I guess that is part of the problem, when OWC is installed already SQL Server has a problem trying to install over it.

    Sunday, February 25, 2007 7:11 PM
  • Hi Gerard,

    Thanks for your reply.  I now understand what you stated: "SQL Server 2005 also installs OWC".  As it turns out, I had previously installed a different version of SQL Server 2005 and then uninstalled it.  It apparently didn't uninstall OWC and that's what put me in the position I was in.  Thanks again for your reply and I hope this will help others as well.

    Sunday, February 25, 2007 8:18 PM
  • Yes yes yes yes yes .. i'm having too much joy .. thanks JHD!! .. i have been screaming for a day and a half now and cursing Vista and giving all the Mac users in the office a good laugh at this marvellous new piece of work from Microsoft. I have been trawling google and ms forums and finding fkkk all to do with the problem. I'm sure this will become a common issue with Vista as I was dealing with an *almost* clean install of Vista. All that had been added was Office 2007 and VS2005 ..

    God knows where Office 2003 Web Components came from in the first place?! Are they installed as part of Office 2007, VS Service Pack 1 for Vista .. or what?!

    Friday, March 02, 2007 5:16 AM
  • JHD, you are the MAN.  THANK you for saving many hours of heartache!
    Friday, March 02, 2007 5:54 AM
  • In my case it probably came from Office 2007. I have a pre-installed machine from DELL with Vista Ultimate and Office 2007 Small Business. Guess what: I find I have an instance of SQL Server (express?) running called MSSMLBIZ. You're allowed only one guess what that acronym stands for. I assume that the Business Contact Manager of Outlook 2007 SML BIZ runs on top of SQL Server and that it gets installed together with Office 2007 Small Business. When you have that, installing SQL Server 2005 Developer Edition as in my case just fails with this obscure error message. Clearly a bug in the installation process. Hopefully one that gets fixed.
    Saturday, March 03, 2007 2:12 AM
  • YOU THE MAN!!!! JHD.... Worked perfectly
    Thursday, March 22, 2007 7:45 PM
  • Also, removed the Office OWC 2003 and the install worked fine. Thanks for the post.
    Sunday, April 29, 2007 12:02 AM
  • JHD

     

    Thanks for the post, your solution worked like a charm.

     

     

    Friday, May 04, 2007 12:08 AM
  • Thanks, Installation worked fine after Removing OWC
    Wednesday, May 16, 2007 2:31 AM
  • Thank you as well... this saved me also
    Tuesday, May 29, 2007 4:44 PM
  • hi JHD, thanks for the post!!.  ....it helped me a lot...



    Saturday, June 09, 2007 9:07 PM
  • Worked for me. Thanks!
    Wednesday, June 27, 2007 12:11 AM
  • JHD - You are the man!  Worked like a charm.  I was ready to throw Vista/SQL Server 2005 and laptop out of the 40th floor!  Thanks for your post!
    Friday, June 29, 2007 9:45 PM
  • Thanks, that solved my problem also.
    Monday, July 02, 2007 6:52 PM
  • hiya

    well i keep getting the error on IIS tools... how do i install IIS?

     

    Tuesday, July 03, 2007 12:06 PM
  • Great!

     

    For Microsoft... try to explain OWC11 = Office Web Component xD

    Wednesday, July 04, 2007 12:53 PM
  • I tried almost 9 hours continuously to install SQL Server 2005 developer edition. But I am getting OWC11 error and I am n't able to install it.

    After reading ur infromation, I removed office web cmponents using add/remove programs then install went thru with out errors.

     

      Thanks
    Tuesday, July 10, 2007 4:07 AM
  • That worked gangsta.  Thanks mang
    Saturday, July 14, 2007 8:17 PM
  • Thank you, this worked for me.
    Tuesday, July 17, 2007 5:54 PM
  • JHD: thanks a lot! I had same problem than the other people (sony vaio with vista business, vstudio 2k5, office xp sp3).

    Tuesday, August 07, 2007 2:41 AM
  • ...Another happy customer  .. Smile

     

    Wednesday, August 08, 2007 7:51 AM
  • JHD, you rock! Thanks a bunch. The help file was useless, and in typical fashion, there was no indication as to what the problem was.

    Thursday, August 09, 2007 8:24 PM
  •  

    JHD - you are the man!

    Thanks a bunch from here - having an installation nightmare.

    I hope in the future (but i doubt it), that Microsoft will provide better information for diagnosticating the problem.

     

    Without Google and you - my hero for the evening, no resolvement would have been found.

    Saturday, September 22, 2007 7:15 PM
  • As simple as it was - you still da man.

     

    Wednesday, October 10, 2007 6:47 PM
  • I also had this problem,  when installing Office 2007 with Outlook Business Contact Manager 2003 Office Web Tools are included.  I installed SQL Client Tools and this error.  Many thanks as I won't sprend the Next day trying to fix it.

     

    Roo
    Tuesday, January 08, 2008 11:58 AM
  • Sunday, June 29, 2008 6:44 PM
  • One more pat on the back!  uninstalled OWC and yes!
    Thursday, July 10, 2008 9:48 PM
  •  

    Great JHD, it helped me

     

    thanks

    Monday, November 10, 2008 7:24 AM
  • After much trial and error I found that if you uninstall Office Web Coponents it works - just did in the add/remove programs part of Windows/Control Panel as it is a stand-alone app.

    worked for me, no trial and error required, thanks much JHD!!!
    Wednesday, July 08, 2009 3:03 PM
  • here it is 7/8/2009 and i see posts on this going back to January of 2006!
    #1) i'm VERY glad i found this source.
    #2) why isn't this bug documented more?
    #3) has it been fixed? or is this more a problem with MS-Office? and if so, why hasn't that been fixed?

    three and a half years, sheesh! i wonder how many man hours in total have been wasted over this problem.

    (do i sound old and grumpy, or what?)

    anyway, thanks for this source.

    Russ
    Wednesday, July 08, 2009 6:36 PM
  • THANK YOU!  That did the trick.
    Wednesday, July 22, 2009 2:44 AM
  • JHD...you are a freaking rockstar...hat off to u man... saved a lot of time. Owe u big time bro
    Friday, September 11, 2009 12:19 PM
  • Thanks a ton...
    • Proposed as answer by 1800bpo Tuesday, December 08, 2009 5:58 AM
    Tuesday, December 08, 2009 5:58 AM
  • Uninstalling Office Web Coponents does work. Thanks
    Wednesday, June 23, 2010 3:49 PM