none
ASP.NET session has expired in SSRS 2005

    Question

  • Hi,

     

    I have a ASP.Net application that uses the SSRS Report Viewer control to display SSRS 2005 reports.

     

    Everything works fine except for one user of the system. When this user logs in the report viewer displays and they can select the parameters for the report that they are trying to run. When they click View Report however they get the following error in the Report Viewer window:

     

    ASP.NET session has expired

     

    If I log in using that users account I dont receive any error and if they log in using my account they get the same error as above (which I dont).

     

    Because of this it leads me to believe that the problem is either somewhere on the clients computer or on their network.

     

    Does anybody have any ideas what the problem might be?

    This is the only user of who is experiencing this problem.

     

    Any help would be greatly appreciated.

     

    Thanks,

    Kieran

    Thursday, October 2, 2008 2:27 PM

Answers

  • Hi,

    I guess the problem is in the session state of reportserver. In the reportsever configuration (or web.config file), change the check whether the sessionstate is turnedon. If not try pointing it as 'SQLSever' or 'InProc'. This might work.

    Thanks,
    Ambe
    Friday, October 3, 2008 6:14 PM

All replies

  • Hi,

     

    Thanks for your response.

     

    I will ask the client to send me their event logs. I dont think that this is a timeout problem in the traditional sense as this error message comes up within a couple of seconds of them attempting to run the report. I reviewed the server logs but I didnt find anything helpful in them.

     

    Friday, October 3, 2008 8:55 AM
  • Hi,

    I guess the problem is in the session state of reportserver. In the reportsever configuration (or web.config file), change the check whether the sessionstate is turnedon. If not try pointing it as 'SQLSever' or 'InProc'. This might work.

    Thanks,
    Ambe
    Friday, October 3, 2008 6:14 PM
  • Thanks Ambe,

     

    I will switch over the session management and see if it resolves the issue.

    Monday, October 6, 2008 8:44 AM
  • Hey,

    Did you ever solve this?

    I'm having the same issue.

    regards,

    Wednesday, July 1, 2009 2:41 PM