none
invalid or missing username or password. To continue, provide valid credentials for the SQL Server Agent Service RRS feed

  • Question

  • Hello:

     

    I've got a problem at Server Configuration, I can't install SQL SERVER 2008 November CTP, because accounts for the SQL Server Agent Service, Database Engine Service and also for Reporting Service (Invalid user credentials for the Reporting Service service account) are invalids or missing. ????

     

    I used the same account for all

     

    Please help me.

     

     

    Excuse me. My english isn't very good.

     

    Thanks

     

    Ralph

    Friday, November 23, 2007 1:54 AM

Answers

  • On the service configuration page, you need to specify a built-in account (NT Authority\System or NT Authority\Network Service) with no password needed, domain account with password, or local user account with a password. In a later CTP release, we will be improving the usability of this dialog. In the Database engine configuration page, you need to specify a strong password for the SA account if you use mixed-mode authentication and you need to provision a user within the database. You don’t need to specify a password for this account.

     

    Thanks,

    Peter Saddow [Microsoft]

     

    Wednesday, January 9, 2008 11:38 PM
    Moderator

All replies

  • Moved to 2008 forum

    Friday, November 23, 2007 2:42 AM
    Moderator
  • I got this error when I provided credentials for my domain-user and the domain controller was not available.
    When I connected my computer to my network again the credentials worked
    Friday, November 23, 2007 10:36 AM
  • Just for note,

    I made my installation while I'm connected to the network and used my domain user for the Agent service and the SQL Engine service accounts.

    And I did not get any problem during the installation. And also after the installation when I'm not connected to the network, CTP5 worked without a problem.

     

    Eralper

    http://www.kodyaz.com

     

    Friday, November 23, 2007 2:27 PM
  •  

    I think the problem is invalid user name and pasword, first enter your domain username and password, then in database engine configuratin screen enter a strong user name and password.

     

     

    Heba El-Desouky

    Saturday, November 24, 2007 8:54 AM
  • hi friend did u find the solution becuse im having the same problem if u have solved it may u plz provide me some information
    thank u

    Monday, November 26, 2007 10:06 AM
  • I'm having the same problem, though it says to provide valid credentials for the "Database Engine Service".  I'm on the SERVICE ACCOUNTS tab of the Sql Server Express 2008 install.  I have tried both individual and same account for all.

     

    Only two services are shown - SQL Server (where I enter a strong id and password) and SQL Server Browser.  The SQL Server Browser is preset to username NT AUTHORITY\LOCAL SERVICE without a password shown.  I cannot edit this line.   I'm running Win XP Professional. 

     

    Anyone have ideas?

    Thanks,

    Molly

     

    Tuesday, November 27, 2007 2:35 AM
  • Man, I have the same issues.  Even if I get past that screen using a combo of NT AUTHORITY accounts I get setup failed errors with the main SQL service and reporting services.  Frankly I really hate that screen and its totally useless.   I tried the good old command line to which works except that the services don't show in the config tool and the tools don't seem to install.  I'm using WinXP SP2.

     

    Tuesday, November 27, 2007 4:50 AM
  • 1081

     

    I used my current windows user id/password and it worked for me.

    Tuesday, November 27, 2007 8:13 AM
  • there are 2 screens, first one asks for your domain/windows username and password; and the next one "Data configuration "asks you to cchoose a user name and strong password for the database which can be any strong password.

    Tuesday, November 27, 2007 8:26 AM
  • EDIT: This is a reply to sm1908 above.

    Didn't work for me.  The first one I tried didn't have a password, and when I changed that it still didn't do it.

     

    Tuesday, November 27, 2007 7:15 PM
  • Fourth screen in SQL Server 2008 installation is "Server Configuration" screen, in which two tabs are there.

    1. Server Accounts

    2. Collation

     

    Under the tab "Service Accounts", There are two services

    1. SQL Server (instance_name)

    2. SQL Server Browser

     

    For service "SQL Server (instance_name)", I entered my current windows UserID/Password. (Its strong)

    For SQL Server Browser , "NT AUTHORITY\SYSTEM" is pre-entered.

     

    I entered different UserID/Password. in the text-boxes below, which are under "Use Same Account for All".

     

    I have done installation successfully second time this way only. Dont select "Apply to All". This changes UserID/Password for "SQL Server" service. which must be your windows User ID/Password.

     

     

    Wednesday, November 28, 2007 3:55 AM
  •  

    Okay here is the solution.  What you will need to do to move on to the next screen will be to utilize your domain name and a user account in the following form: domain name\user.  For example, your domain name could read as: bigbiz and the user account you want to use is the administrator account.  So you will write on the account field, bigbiz\administrator please ensure to utilize the administrator password in the password field.
    Friday, November 30, 2007 3:59 AM
  •  Jesus E Colon wrote:

     

    Okay here is the solution.  What you will need to do to move on to the next screen will be to utilize your domain name and a user account in the following form: domain name\user.  For example, your domain name could read as: bigbiz and the user account you want to use is the administrator account.  So you will write on the account field, bigbiz\administrator please ensure to utilize the administrator password in the password field.


    I had this error too, but solved until I find this post.
    Thanks
    Wednesday, December 5, 2007 4:10 PM
  • Just use the windows account
    Thursday, December 6, 2007 10:26 AM
  • Solution:
          you need use your current windows user id and password.
    Thursday, December 6, 2007 2:43 PM
  • (nogza@discussions.microsoft.com) writes: > Solution: > you need use your current windows user id and password. Or you could create a new Windows account. I would recommend this, as this account would only have the priviledges it needs (SQL Server Setup takes care of that). And you don't run the risk that SQL Server does not start one day because you have changed your password. -- Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se Books Online for SQL Server 2005 at http://www.microsoft.com/technet/prodtechnol/sql/2005/downloads/books.mspx Books Online for SQL Server 2000 at http://www.microsoft.com/sql/prodinfo/previousversions/books.mspx
    Thursday, December 13, 2007 10:21 PM
  • On the service configuration page, you need to specify a built-in account (NT Authority\System or NT Authority\Network Service) with no password needed, domain account with password, or local user account with a password. In a later CTP release, we will be improving the usability of this dialog. In the Database engine configuration page, you need to specify a strong password for the SA account if you use mixed-mode authentication and you need to provision a user within the database. You don’t need to specify a password for this account.

     

    Thanks,

    Peter Saddow [Microsoft]

     

    Wednesday, January 9, 2008 11:38 PM
    Moderator
  • This is absolutley appalling. I've tried everything on here and none theexamples have worked. Doesn't make good reading when your evaluating for a company.

    I'm trying this at home and pulling my hair out over it. 1 day more of this and i'll recommend my company goes to Oracle!!

    Wednesday, January 16, 2008 6:57 AM
  •  

    The explanation is not so clear.

     

    It is great if you can provide real example for all fields (I'm working from user name "chess" no password and win xp sp2)

    What could be the following fields (UserName/Password) in intallation screen "Server Configuration":

    SQL Server Agent:

    Sql Server[MSSQLSERVER]:

    SQL Server Browser:

    SQL Server Analysis Services:

    Sql Server Reporting Services:

    SQL Server Integration Services 10.0...:

     

    Thank you in advance,

    semsl

     

     

    Wednesday, January 16, 2008 1:48 PM
  •  Never OutGunned wrote:

    This is absolutley appalling. I've tried everything on here and none theexamples have worked. Doesn't make good reading when your evaluating for a company.

    I'm trying this at home and pulling my hair out over it. 1 day more of this and i'll recommend my company goes to Oracle!!



    You are making evaluations from beta software? Please keep in mind that CTP5 is first CTP of SQL 2008 which uses the new Setup. It's not surprising if it's not perfect.

    Then again, it's not that difficult at all. You specify a Windows login and a password for the service account. If you
    don't have one handy, you add one. Or, if you are in a corporate environment, you ask your Windows admin to do it.


    Wednesday, January 16, 2008 10:50 PM
  • it works for me too!!

     

    cool!

    Wednesday, January 16, 2008 11:34 PM
  • The same problem, but I can't solve it...

    I've even create a new account with password...

    But SQL have only one answer:

    "Invalid or missing username or password. To continue, provide valid credentials for the SQL Server agent service"

    "Invalid or missing username or password. To continue, provide valid credentials for the Database engine service"

    "Invalid user credentials for the reporting services service account"

    Before, I've always use MySQL server, and everything works excellent.

    In hollywar between Linux and Windows, I always defend the Microsoft System...

    But after installing IIS 7.0 and this problem I have a perfect right to change my mind.

    Wednesday, January 30, 2008 7:45 PM
  • It may seem like a dumb question: but did you check that you typed the password correctly?

    The dialog is not really difficult at all. If you don't have a good Windows user in store, create one. Then enter
    the username and password for that user for all services.
    Wednesday, January 30, 2008 11:18 PM
  • Hey! I am so frustrated. I still cant get the username and password valid.

    Here is an example

    Username: al3x\administrator
    Password: ESKimo666
    Startup Type: Automatic

    I still cant get it! What's wrong?

    Could it be on the step 3 that i have SQLEXPRESS as the "Named Instance" and on "Instance Id"?



    Thanks!!
    Saturday, February 2, 2008 10:11 PM
  • I'm encountering the same problem on a Windows 2008 domain server.  I used the NT AUTHORITY\LOCAL SERVICE account for all services, as opposed to accounts that I created, in order to temporarily work through the problem. 
    Monday, February 4, 2008 5:20 AM
  • Boy, this page was nearly killing me ... "Just enter a username, no password needed."

    Not.

    And all the time, just that stupid error bar at the top!

     

    The real trap is, that keys for NT Autorithy accounts are localized! Thus, the second preset line reads:

     

    SQL Server Browser NT AUTHORITY\LOCAL SERVICE

     

    but first line must be entered by starting typing N and then pick one of three options, say (for Danish):

     

    Sql Server(SQLEXPRESS) NT AUTHORITY\LOKAL TJENESTE

     

    As noted by many, don't click "Apply to all".

     

    The UI of this page really needs to be improved.

     

    /gustav

     

    Saturday, February 9, 2008 10:59 PM
  • Thanks, all.

     

    Between all the answers here, the installation is moving on.

     

    To add my $.02, I added a password to my login account (home pc) and the ID and Password worked ok.

     

    Myst

    Friday, February 29, 2008 8:29 PM
  • hi,man.the same problem occured to me.then i tried my account of my windows 2003 and it worked.i've no idea whether your situation is the same as mine.but i hope it would be  helpful to you.

    Wednesday, March 5, 2008 7:20 AM
  • Danish schools do not need no child left behind.

    Now if only more Microsoft SQL config coders were Danish...

     

    Yeahh, that's the trick; just get into the text entry box and type any case "n", and follow the drop down.

    Sorta dungeons and dragons.

     

    Thanks gustav.

     

    art "honu" scott

     

     

    Thursday, March 20, 2008 10:21 PM
  •  sm1908 wrote:

    1081

    I used my current windows user id/password and it worked for me.

     

    This solution worked fine for me.

    the only condition is that the current user must be set to admin's privilege. 

    Wednesday, March 26, 2008 5:47 AM
  •  Paul P.S. wrote:
     sm1908 wrote:

    1081

    I used my current windows user id/password and it worked for me.

     

    This solution worked fine for me.

    the only condition is that the current user must be set to admin's privilege. 



    I don't know exactly what you mean here, but for the service account you should use a freshly created
    account without any extra privs. The SQL Server setup will add the priviledges needed.

    But of course you need to be logged in as admin to install SQL Server at all.
    Saturday, March 29, 2008 11:51 AM
  •  

    hi you need to specify the curent windows username in first textbox and in password field you need to specify the currrent windows password for the current user. if you dont have any password than leave it blank. nad click continue

     

    it worked for me may be for u it will also work

     

    any way you can also contact on my email address at vikas_nagil@hotmail.com, vikas_nagil@xcreatives.com

    Sunday, April 13, 2008 6:16 AM
  • April-14-2008

    I got this problem when I installed the SQL Server 2008. I tried my administrator ID and password, no matter I use "apply for all" or I typed in every box individually, I just got the invalid message. I am installing the SQL server under the windows user administrator, using XP sp2.
    Monday, April 14, 2008 5:21 PM
  • I just used NT AUTHORITY\LOCAL SERVICE

    no password for both and it let me continue easy fix no problems so far

    Monday, April 14, 2008 7:03 PM
  • ok had some problems using the local service settings if ur haveing problems with useing ur username/password w/out a password then just create one and it should work u might have to restart the installer after adding a password

    Monday, April 14, 2008 8:32 PM
  •  Yamicannon wrote:

    ok had some problems using the local service settings if ur haveing problems with useing ur username/password w/out a password then just create one and it should work u might have to restart the installer after adding a password



    Thank you a lot! I made it! The next question is where I can find a SQL Server Management Studio for 2008?
    Tuesday, April 15, 2008 2:16 PM
  • I installed Visual Studio 2008 with SQL Server 2005 Express checked in order to get the SQL Server Management Studio. Then I installed SQL Server 2008. The service of SQLExpress and MSSQLServer are all started. But when I restarted the computer, I found the MSSQLServer service is stopped and cannot start any more. I reinstall VS and SQL again, still get the same problem. Anyone has idea?
    Wednesday, April 16, 2008 7:19 PM
  • Just press ctrl+alt+del and click change password. The information you find in the first field below your picture is the same you'll enter in the SQL setup followed by your password. If you wish, apply the same to all and click Next.

                                                                                               Be happy. 

    Tuesday, May 13, 2008 7:43 AM
  • I had the same issue during the installation. This post worked for me. THANKS!!!

    Monday, September 1, 2008 9:59 PM
  • I had the same problem in the final release of SQL Server 2008. You can't add the user or groups by browsing your AD. Just add the user or groups manually "by hand". Type in e.g. Domain\GG-SQL-Group.

     

    Greets Tom

     

    Tuesday, December 2, 2008 8:04 AM
  • I had a same and similar issue.

    I finish the installation by providing SQL Agnt and SQL Service by NT AUTHORITY\NETWORK SERVICE and blank password. Once complete the installation I changed the Service Account by services.msc to SQL SA account.
    Reason: Service account is not granted for Log on as Service.
    Solution: Grant the SA to Log on as Service.

    Abu
    Thursday, May 14, 2009 8:26 AM
  • When you get to these options in Server Configuration when setting up SQL Server follow these instructions, changing the details to your own.

    My Windows Server 2008 Domain is called COD4.com
    My user account is called Administrator
    and the password is STAPLESfarm11

    So to get these to work when setting up MS SQL Server i used the Apply to all option with these details:

    Account:      COD4\Administrator

    Password:    STAPLESfarm11

    If you follow this format it should fix your issue and also make sure that your password is upper and lower case with numbers.
    If your Domain or Windows User name hasnt been set to the above type of format, set this first and retry setting up the SQL Server.
    • Proposed as answer by gspot Friday, June 19, 2009 4:31 PM
    • Edited by gspot Friday, June 19, 2009 4:53 PM
    Friday, June 19, 2009 4:31 PM
  • just put current windows user(for eg. Administrator) n password.. it 100% works...
    Monday, December 14, 2009 6:04 PM
  • Thanks for your valuable information Mr.Ralf
    Tuesday, May 4, 2010 9:30 PM
  • Hi,

     

    I have successfully done this by following manner,

    - I had a domain account ("Kasper\svc_sql") for the SQL services

    - Add "Kasper\svc_sql" account in to the local administrators group on Database server PC.

    - login to the database pc to install SQL server 2008 R2 with the "Svc_SQL" account

    - give current account details for this Agent service option.

     

    This will work.

     

    Regards,

    Chamila

    Friday, September 23, 2011 9:42 AM