none
error in Sqlserver ODBC dirver for linux RRS feed

  • Question

  • Hi All,

      I have installed the ODBC Driver manager and Sqlserver ODBC driver in one my RHEL 5.6 machine. got some error while invoking BCP & sqlcmd .. also i tried the connection its throwing error Is there any idea why i am facing this issue ? Installation seems fine ....

    [root@vm-4BD1-4913 sqlncli-11.0.1790.0]# bcp
    bcp: /lib64/libuuid.so.1: no version information available (required by bcp)
    usage: bcp {dbtable | query} {in | out | queryout | format} datafile
      [-m maxerrors]            [-f formatfile]          [-e errfile]
      [-F firstrow]             [-L lastrow]             [-b batchsize]
      [-n native type]          [-c character type]      [-w wide character type]
      [-N keep non-text native] [-q quoted identifier]
      [-t field terminator]     [-r row terminator]
      [-a packetsize]
      [-S server name or DSN if -D provided]             [-D treat -S as DSN]
      [-U username]             [-P password]
      [-T trusted connection]   [-v version]             [-R regional enable]
      [-k keep null values]     [-E keep identity values]
      [-h "load hints"]         [-d database name]

    [root@vm-4BD1-4913 sqlncli-11.0.1790.0]# sqlcmd
    sqlcmd: /lib64/libuuid.so.1: no version information available (required by sqlcmd)
    sqlcmd: symbol lookup error: sqlcmd: undefined symbol: _ZNSbIcSt11char_traitsIcEN16BasicStringUtils21AutoClearingAllocator9AllocatorIcEEE4_Rep20_S_empty_rep_storageE

    [root@vm-4BD1-4913 sqlncli-11.0.1790.0]# cat /etc/redhat-release
    Red Hat Enterprise Linux Server release 5.6 (Tikanga)

    [root@vm-4BD1-4913 sqlncli-11.0.1790.0]# uname -a
    Linux vm-4BD1-4913 2.6.18-238.28.1.el5 #1 SMP Fri Oct 7 14:25:50 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

    [root@vm-4BD1-4913 ~]# bcp master.dbo.sysdatabases out test.out -S VM-1842-7C16 -U test -P test123

    bcp: /lib64/libuuid.so.1: no version information available (required by bcp)
    SQLState = S1T00, NativeError = 0
    Error = [unixODBC][Microsoft][SQL Server Native Client 11.0]Login timeout expired
    SQLState = 08001, NativeError = 10022
    Error = [unixODBC][Microsoft][SQL Server Native Client 11.0]A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online.
    SQLState = 08001, NativeError = 10022
    Error = [unixODBC][Microsoft][SQL Server Native Client 11.0]TCP Provider: Error code 0x2726

    [root@vm-4BD1-4913 ~]# cat .odbc.ini
    [MSSQLTest]
    Driver=SQL Server Native Client 11.0
    Server=VM-1842-7C16,2431

    Regards

    Kamalakkannan

    Friday, July 13, 2012 8:05 AM

Answers

  • Hi Kamalakkannan,

    Something needed to be noticed:

    1. There are some sqlcmd options that are not available, for more information, please refer to: http://msdn.microsoft.com/en-us/library/hh568447.aspx

    2. For specify the instance of SQL Server:
    -S [protocol:] server[\instance_name][,port]
    Specify the instance of SQL Server to which to connect. Or, if -D is used, a DSN. When using the SQL Server ODBC Driver for Linux, -S is required. For the SQL Server ODBC Driver for Linux, tcp is the only valid protocol.

    Please ensure your SQL Server instance is configured to be remote connect, and tcp protocol is not blocked by the firewall. For more information, please refer to: http://blogs.msdn.com/b/walzenbach/archive/2010/04/14/how-to-enable-remote-connections-in-sql-server-2008.aspx

    Please post the statement you used, because it is helpful for us to detect the problem.


    Best Regards,
    Iric
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, July 16, 2012 7:41 AM
    Moderator
  • Hi

    You might want to try chaniging your INI file as:

    [root@vm-4BD1-4913 ~]# cat .odbc.ini
    [MSSQLTest]
    Driver=SQL Server Native Client 11.0
    Server=VM-1842-7C16

    Port=2431

    Let me know if it worked for u...

    Thanks

    uday

    Tuesday, July 17, 2012 6:11 PM

All replies

  • Hi Kamalakkannan,

    Something needed to be noticed:

    1. There are some sqlcmd options that are not available, for more information, please refer to: http://msdn.microsoft.com/en-us/library/hh568447.aspx

    2. For specify the instance of SQL Server:
    -S [protocol:] server[\instance_name][,port]
    Specify the instance of SQL Server to which to connect. Or, if -D is used, a DSN. When using the SQL Server ODBC Driver for Linux, -S is required. For the SQL Server ODBC Driver for Linux, tcp is the only valid protocol.

    Please ensure your SQL Server instance is configured to be remote connect, and tcp protocol is not blocked by the firewall. For more information, please refer to: http://blogs.msdn.com/b/walzenbach/archive/2010/04/14/how-to-enable-remote-connections-in-sql-server-2008.aspx

    Please post the statement you used, because it is helpful for us to detect the problem.


    Best Regards,
    Iric
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, July 16, 2012 7:41 AM
    Moderator
  • Hi Kamalakkannan

    Im having same error in our environment. Did you get the issue resolved?

    Would be very helpful if you could let me know how to make it work!

    Thanks

    Uday

    Tuesday, July 17, 2012 6:07 PM
  • Hi

    You might want to try chaniging your INI file as:

    [root@vm-4BD1-4913 ~]# cat .odbc.ini
    [MSSQLTest]
    Driver=SQL Server Native Client 11.0
    Server=VM-1842-7C16

    Port=2431

    Let me know if it worked for u...

    Thanks

    uday

    Tuesday, July 17, 2012 6:11 PM
  • Hi Kamalakkannan,

    Did you find a solution to your issue? I'm asking because i got the exact same one (well, got the same errors).

    I know for a fact that the issue is not on the database side of things, because i have the same driver (sqlncli-11.0.1790.0/unixODBC-2.3.2 - RHEL 5.7) and connection informations on a vbox machine (running CentOS) and everything works fine.

    In any case, I would be very grateful if you could inform me of the steps you took to fix your issue (if you fixed it).

    Thanks

    Edit: Nevermind the question, i got it working by using Microsoft ODBC Driver 11 for SQL Server - Redhat Linux (ODBC Driver 11 for SQL Server - msodbc) instead of Microsoft SQL Server ODBC Driver 1 for Linux (SQL Server Native Client 11.0 - sqlncli)

    Shadowere


    Wednesday, April 23, 2014 2:37 PM