none
Turn off "dbo." SQL Management Studio 2008, Object Explorer

    Question

  • The most ANNOYING "feature" of SQL Server Management Studio 2008 (we upgraded from SQL 2000) is the "dbo." that prefixes every single table in the Object Explorer window! (Or the owner of the table, if it's not dbo). Is there ANY WAY to turn this off? It's EXTREMELY ANNOYING, since you now cannot start typing in the name of the table to quickly scroll to it.  Now you have to type "dbo.table-name" to get to it. And if you have fat fingers like mine and can't type "dbo." without making a mistake ---- VERY FRUSTRATING. Please tell me I can turn this "feature" off. Please?
    Monday, October 19, 2009 11:48 PM

Answers

  • It's not possible in object explorer window, SSMS is designed like that. I remember some months back it has been updated in Microsoft connect as user suggestion.

    However in Object explorer Details windows, schema name is not prefixed. So just click on tables folder under database and then press F7, in the right hand pane you can see object explorer details window, just use that to search the table.


    Vidhya Sagar. Mark as Answer if it helps!
    • Marked as answer by Owen37 Wednesday, October 21, 2009 6:12 PM
    Wednesday, October 21, 2009 2:34 AM
    Moderator

All replies

  • The objects in SQL databases in SSMS are always referenced with the schema name in front of it.

    However , Everytime you type an object name you dont need to specify anything as a prefic if DBO is the schema \ owner . But for other objects owned by schemas other than dbo , it is mandatory.
    Thanks, Leks
    Tuesday, October 20, 2009 3:48 AM
    Answerer
  • It's not possible in object explorer window, SSMS is designed like that. I remember some months back it has been updated in Microsoft connect as user suggestion.

    However in Object explorer Details windows, schema name is not prefixed. So just click on tables folder under database and then press F7, in the right hand pane you can see object explorer details window, just use that to search the table.


    Vidhya Sagar. Mark as Answer if it helps!
    • Marked as answer by Owen37 Wednesday, October 21, 2009 6:12 PM
    Wednesday, October 21, 2009 2:34 AM
    Moderator
  • THANK YOU! Now I can just type in the database name again. I can understand why it's that way in the Object Explorer, but I'd really like an option to either turn it off or to have the files put in trees by their owner so that I don't have to type the owner while searching.

    Thanks for the work-around.

    -Owen
    Wednesday, October 21, 2009 6:13 PM