none
Infopath: tabbed views with buttons - buttons don't show in display mode RRS feed

  • Question


  • I’m working with SPS2010 and Infopath 2010.

    I’ve implemented the ‘Tabs’ solution (http://blogs.msdn.com/b/infopath/archive/2006/05/01/tabs.aspx )

     

    Unfortunately, only after spending a lot of hours I found out the buttons disappear in Display mode.

    I’ve seen answers on the internet, MSDN blog, etc.   but I still don’t see how I can show the buttons in display mode.

     

    The buttons show fine in edit mode.

     

    Related questions;

    If somehow I can get the buttons to show in Display mode, will they work to change ‘tab’?

    Is there another (read: better) way to achive this ‘tab’ behaviour in Infopath?

     

    Thanks!

    Tuesday, November 16, 2010 9:25 PM

Answers

  • Ok, I think I have an answer for you.  The feature I was talking about does not exist on regular buttons, but rather on PICTURE buttons.  My guess is you used standard buttons and done your own styling/design.  Well, in 2010, we now have Picture Buttons, which allow us to make much nicer-looking buttons.  What they also allow us to do is choose whether or not they show up on Read-Only views.  The Display Form page for an InfoPath-customized list automatically shows a Read-Only view, so if you de-select this checkbox on each Picture button, then they will show up in your display mode without endangering the form.

    This would be a good blog post.  =)


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, November 17, 2010 8:54 AM

All replies

  • Ernst,

    Is this a list form?  If so, then the view on the DispIFS.aspx page is set as a Display form, which automatically sets everything to read-only and removes buttons.  In 2010, buttons have a setting for whether or not they display on a Display form.  My guess is that when SharePoint autoconverts the list form and creates its own IFS pages, it configures all buttons to not display in a display form.  I haven't yet tried to modify that particular setting on an existing display form, but I know that when I add buttons, I can configure this setting.  I recommend checking this setting on your tab buttons.


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Tuesday, November 16, 2010 10:19 PM
  • I'm not sure I follow... (I'm kinda noob...)

    I have a SharePoint list and from the ribbon, I've used "Customize form" which opens Infopath 2010.
    I haven't created a specific display form or edit form.
    But I guess Infopath creates these from the Infopath form I've designed...

    In SPDesigner 2010 I see the displayifs.aspx / newifs.aspx /etc.
    Do you mean I should open and edit 'Displayifs.aspx' in SPDesigner? As far as I know I cannnot open displayifs with Infopath?

    reason I ask: when I add a button in Infopath on the design form, I don't have an option to change the setting for display.
    I've looked under Button properties, maybe it's somewhere else?

    The only place I've seen where you can define display/edit settings is in the views.

    More info on the problem: Like the example in the given URL I've created 6 views which correspond to 6 tabs. But these tabs/views I've created to be switched by the buttons should be editable. And they work fine. Except in de dispifs...

     

    Tuesday, November 16, 2010 11:07 PM
  • It is all done in InfoPath, not in SPD.

    I will have to fire up a form from home in order to point you to this setting.  Why would you want the views to be editable in the display form?  The whole point of the display form is to display the data in read-only form.  YOu don't edit within your display form - you do this within your edit form (view).


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Tuesday, November 16, 2010 11:12 PM
  • I'm afraid I didn't explain my problem well enough... ;-)

    I really don't want the display form to be editable. I just want the buttons back in display mode.

     

    Little recap:

    I need forms to edit a sharepoint list (based on a custom contenttype). But there are so many fields (columns) that I decided to use tabs to group the fields in tabs.
    So I have a form in Infopath with 6 tabs. The user can change tab by pressing the button, used in each tab. The button changes the view. Each view has it's own layout with the active tab in white and inactive tabs in some background color.

    Here's the problem: in Edit en New mode the user can see the tabs en press the buttons to change form tab to tab.
    In Display mode the buttons are not rendered. The tabs are visible but no buttons so the user cannot change tabs.

    So I want to see the buttons in Display mode. The fields don't have to be editable.

    But maybe I've chosen the wrong way to realize this? Any suggestions are welcome :-)

    Thanks!

    Wednesday, November 17, 2010 7:53 AM
  • Yes, that's the same problem we've been talking about - it was very clear.  It's just that you put this statement at the bottom of your previous post:

    "More info on the problem: Like the example in the given URL I've created 6 views which correspond to 6 tabs. But these tabs/views I've created to be switched by the buttons should be editable. And they work fine. Except in de dispifs..."

    That's why I mentioned editing. 

    We know why the buttons aren't showing.  The key is finding the setting I was telling you about so that the buttons DO show.  I'm working on it now.


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, November 17, 2010 8:04 AM
  • Ok, I think I have an answer for you.  The feature I was talking about does not exist on regular buttons, but rather on PICTURE buttons.  My guess is you used standard buttons and done your own styling/design.  Well, in 2010, we now have Picture Buttons, which allow us to make much nicer-looking buttons.  What they also allow us to do is choose whether or not they show up on Read-Only views.  The Display Form page for an InfoPath-customized list automatically shows a Read-Only view, so if you de-select this checkbox on each Picture button, then they will show up in your display mode without endangering the form.

    This would be a good blog post.  =)


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, November 17, 2010 8:54 AM
  • Thanks very much! This is exactly what I need!!! 
    Tuesday, December 14, 2010 2:53 PM
  • Well that solve my problem too.

    Thanks Clayton!

    Tuesday, February 1, 2011 3:43 PM
  • I've found that picture buttons do show in read-only mode, but they only work for simple rules, such as switching views. If you want to use a button to set a field's value or run a query, then it will only run in edit mode.


    Phil Childs http://get-spscripts.com
    Thursday, February 24, 2011 7:22 PM
  • Thanks for the info - I was pulling my hair out.
    Thursday, May 23, 2013 3:28 PM
  • Argh!

    Why would this functionality (or lack of) exist on buttons but not Picture Buttons?

    I have the same situation where I have tabs that use buttons to switch views. I do, however, have a requirement that means the picture buttons option is no use... I think.

    I have formatting rules that are changing the colours of the buttons depending on the state of completeness that that tab is at i.e. Red = not started, amber = started and green = complete.

    I have yet to really dive into picture buttons but I'm going to hazard a guess that this sort of formatting will be useless with picture buttons. I'll have a look tomorrow to try anyway but am not hopeful.

    Anybody got alternative ways of keeping buttons visible on display forms?

    Thursday, October 31, 2013 3:58 PM
  • I concur... just hit this problem as well.

    my forms have to be used in both display and edit views.   need the buttons to flip to other views while just displaying the form.

    why they don't have the switch on the non-picture buttons makes no sense.

    guess i'm using the trick someone else mentioned about taking screenshots of the buttons and putting them back in as picture buttons from there.

    and....crap.  the buttons appear, but won't switch views

    and another edit:   must be that buttons with certain rules applied won't function at all... but a button with a simple view change will work.    



    Friday, October 2, 2015 3:36 PM