none
Getting dreadfull "Unable to find the requested .Net Framework Data Provider. It may not be installed." RRS feed

  • Question

  • Hi,

    I have Windows 7 RTM, x64. VS 2008 with SP1. Installed both x86 and x64 SQL CE 3.5 SP1. Machine.config for both x32 and x64 are having entries below. Yet when I run my sample page I get that error in subject line. Connection strings reads as follows

    <

     

    add name="ConnectionString" connectionString="Data Source=C:\Users\files.sdf" providerName="Microsoft.SqlServerCe.Client.3.5" />



    What do I need to do to fix this?

    <add name="Microsoft SQL Server Compact Data Provider" invariant="System.Data.SqlServerCe.3.5" description=".NET Framework Data Provider for Microsoft SQL Server Compact" type="System.Data.SqlServerCe.SqlCeProviderFactory, System.Data.SqlServerCe, Version=3.5.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91"/>
    
    <add name="Microsoft SQL Server Compact Data Provider" invariant="System.Data.SqlServerCe.3.5" description=".NET Framework Data Provider for Microsoft SQL Server Compact" type="System.Data.SqlServerCe.SqlCeProviderFactory, System.Data.SqlServerCe, Version=3.5.1.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91"/></DbProviderFactories>
    Tuesday, August 25, 2009 9:49 PM

Answers

  • If anybody has the same issue. I found easy and fast solution. After installing/reinstalling/dealing with other oddities for last 5 hours I found a solution!
    It's called SQLite. After 15 mins of setup time I'm up and running and don't have to deal with this ____ anymore.

    http://sqlite.phxsoftware.com/
    • Marked as answer by artisticcheese Wednesday, August 26, 2009 6:06 PM
    Wednesday, August 26, 2009 6:06 PM

All replies

  • Not sure whta you mean by "sample page" - asp.net ?? SQL Copact is not supported under ASP.NET.

    I would remove the entry with Version=3.5.0.0 from the machine.config files.


    Erik Ejlskov Jensen, MCTS: WM App, MCITP: SQL 2008 Dev - http://erikej.blogspot.com Please mark as answer, if this was it.
    Wednesday, August 26, 2009 4:55 AM
    Moderator
  • Removing 3.5.0.0 line from machine.config (x86) folder did not fix the issue. I wrote simple page which just using dataset and connects to database. I know SQL Compact is not supported under ASP.NET but I put required (AppDomain.CurrentDomain.SetData("SQLServerCompactEditionUnderWebHosting", true);) in global.asax already.
    Is there any option to make it actually work?

    Wednesday, August 26, 2009 1:35 PM
  • Are you sure your asp.net process is running under x86. It would default to x64 on a x64 system...

    Try to modify your web.config as described here: http://blogs.msdn.com/stevelasker/archive/2008/10/22/privately-deploying-sql-server-compact-with-the-ado-net-entity-provider.aspx
    Erik Ejlskov Jensen, MCTS: WM App, MCITP: SQL 2008 Dev - http://erikej.blogspot.com Please mark as answer, if this was it.
    Wednesday, August 26, 2009 1:54 PM
    Moderator
  • I'm running development server under Visual Studio 2008, will that be x86 or x64 by default? Application will be deployed to x64 system once done.
    Wednesday, August 26, 2009 1:57 PM
  • I wonder if SQL Compact works at all with the development server, try using IIS instead.
    Erik Ejlskov Jensen, MCTS: WM App, MCITP: SQL 2008 Dev - http://erikej.blogspot.com Please mark as answer, if this was it.
    Wednesday, August 26, 2009 2:49 PM
    Moderator
  • If anybody has the same issue. I found easy and fast solution. After installing/reinstalling/dealing with other oddities for last 5 hours I found a solution!
    It's called SQLite. After 15 mins of setup time I'm up and running and don't have to deal with this ____ anymore.

    http://sqlite.phxsoftware.com/
    • Marked as answer by artisticcheese Wednesday, August 26, 2009 6:06 PM
    Wednesday, August 26, 2009 6:06 PM