none
SQL Server 2012 Management Studio Error

    Question

  • Hi all. I have installed SQL server 2012 express on windows 8. When i open management studio and i write ".\SQLEXPRESS" in server name i get this error:

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 53)

    i use windows authentication :/

    Sunday, April 01, 2012 9:48 PM

Answers

  • Hello, This solution works 100%. finally got solutions after a months.

    Goto the Command Prompt and Write below command in it.

    1) sqlLocaldb info

    RESULT : v11.0 (According to version of SQL server. Here i am using SQLserver 2012 Express).

    2)sqlLocaldb create "DBNAME" -s     // Here you simply write your database server name as u want instead DBNAME.

    then exit from CMD.

    and goto your SQLServer MANAGEMENT STUDIO TOOLS.

    in which write (localdb)\DBNAME in the field of Server Name. then click connect. // DBNAME is your database name that you created using command prompt.

    Please don't forgot to Mark as Answered

     

    • Proposed as answer by user crowbar Sunday, September 22, 2013 11:13 PM
    • Marked as answer by Naomi NModerator Wednesday, September 02, 2015 6:22 PM
    Thursday, September 19, 2013 6:45 AM
  • Hi Mirko,

    Winerr 53 means "The network path was not found". If you got this message, it means the client stack cannot find the target machine.
    If you installed a default instance, you could use ComputerName to login the instance. If you installed a named instance, you could use ComputerName\InstanceName to login the instance.

     Here are possible reasons for this failure:
    1. Name resolution to the server name is not correct, "ping -a yourserver" would tell if that's the case
    2. The server machine is firewall'ed and file sharing is not in the exception list. You need put "File and Printer Sharing" in exception.

    Thanks,
    Maggie


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. This can be beneficial to other community members reading the thread.

    Tuesday, April 03, 2012 9:29 AM
    Moderator

All replies

  • Hi all. I have installed SQL server 2012 express on windows 8. When i open management studio and i write ".\SQLEXPRESS" in server name i get this error:

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 53)

    i use windows authentication :/

    I think ".\" is no longer supported on Windows 8 - try to use your computername instead of "."

    Monday, April 02, 2012 9:17 AM
  • I write .MIRKO-PC\SQLEXPRESS but i received same error :(
    Monday, April 02, 2012 2:43 PM
  • I write .MIRKO-PC\SQLEXPRESS but i received same error :(
    no leading dot therefore try MIRKO-PC\SQLEXPRESS
    Monday, April 02, 2012 5:00 PM
  • Hi Mirko,

    Winerr 53 means "The network path was not found". If you got this message, it means the client stack cannot find the target machine.
    If you installed a default instance, you could use ComputerName to login the instance. If you installed a named instance, you could use ComputerName\InstanceName to login the instance.

     Here are possible reasons for this failure:
    1. Name resolution to the server name is not correct, "ping -a yourserver" would tell if that's the case
    2. The server machine is firewall'ed and file sharing is not in the exception list. You need put "File and Printer Sharing" in exception.

    Thanks,
    Maggie


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. This can be beneficial to other community members reading the thread.

    Tuesday, April 03, 2012 9:29 AM
    Moderator
  •  I also got the same error Mikro.. How did you resolve it?
    • Proposed as answer by Raja KPV Friday, May 18, 2012 7:38 PM
    • Unproposed as answer by Raja KPV Friday, May 18, 2012 7:48 PM
    Tuesday, April 17, 2012 7:49 AM
  • Hi

    Open SQL Server Configuration Manager and select SQL Server Services and check is there any list of services is listing. If there is no list then you need to reinstall complete package.

    Friday, May 18, 2012 7:48 PM
  • Hi

    download the software from the link

    https://www.microsoft.com/betaexperience/pd/SQLEXPNOCTAV2/enus/default.aspx

    select the appropriate version 32 bit or 64 bit Express(Database Only) and download

    after installing check SQL Server Configuration Manager it should show a list of services (SQL Server Browser Running)

    • Proposed as answer by Raja KPV Tuesday, May 22, 2012 2:00 PM
    Friday, May 18, 2012 8:42 PM
  • This worked on SQL 2008 express.

     1.Run SQL Server Configuration Manager.
     2.Go to SQL Server Network Configuration > Protocols for SQLEXPRESS.
     3.Make sure TCP/IP is enabled.
     4.Right-click on TCP/IP and select Properties.
     5.Verify that, under IP2, the IP Address is set to the computer's IP address on the local subnet.
     6.Scroll down to IPAll.
     7.Make sure that TCP Dynamic Ports is blank. 
     8.Make sure that TCP Port is set to 1433. 


    R, J

    Sunday, July 01, 2012 6:59 PM
  • try to use  your computer name  instead of the  "."

    you can know it  by 

    your computer proprieties > change settings  

    Wednesday, October 24, 2012 12:43 AM
  • Hello, This solution works 100%. finally got solutions after a months.

    Goto the Command Prompt and Write below command in it.

    1) sqlLocaldb info

    RESULT : v11.0 (According to version of SQL server. Here i am using SQLserver 2012 Express).

    2)sqlLocaldb create "DBNAME" -s     // Here you simply write your database server name as u want instead DBNAME.

    then exit from CMD.

    and goto your SQLServer MANAGEMENT STUDIO TOOLS.

    in which write (localdb)\DBNAME in the field of Server Name. then click connect. // DBNAME is your database name that you created using command prompt.

    Please don't forgot to Mark as Answered

     

    • Proposed as answer by user crowbar Sunday, September 22, 2013 11:13 PM
    • Marked as answer by Naomi NModerator Wednesday, September 02, 2015 6:22 PM
    Thursday, September 19, 2013 6:45 AM
  • Здравствуйте, это решение работает на 100%. наконец, получил после решения месяцев.

    На Команда Promp Tи запись ниже командой в нем.

    1) sqlLocaldb информация

    РЕЗУЛЬТАТ: v11.0 (по версии сервера SQL Здесь я использую SQLserver 2012 Express.).

    2) sqlLocaldb создать "DBNAME"-S     / / Здесь вы просто написать имя сервера базы данных, как и хотят вместо DBNAME.

    Затем выйти из CMD.

    и переходим в вашем SQLServer ИНСТРУМЕНТЫ Management Studio.

    , в котором записи (LocalDB) \ DBNAMEв области имя сервера. нажмите кнопку Подключить. / / DBNAME ваше имя базы данных, созданной с помощью командной строки.

    Пожалуйста, не забыли пометить как Ответил

     

    It realy works. Thank you, dude!
    Sunday, September 22, 2013 11:18 PM
  • thank u soo much sir....

    that really worked for me...

    i've tried many things to connect but ur suggetions helped me a lot...

    thanx

    Tuesday, September 24, 2013 5:53 PM
  • Thanks buddy. It also solved my problem as well.
    Friday, September 27, 2013 9:07 AM
  • Perfect!! Thank u soo much...
    Friday, November 01, 2013 12:56 AM
  • Have you started the server? Start from Control Pane | ..|Services window.

    mysorian

    Monday, November 11, 2013 1:57 AM
  • Can u explain every steps clearly or upload pictures of every step u did?, because when I open command prompt and type sqlLocaldb info it show "sqlLocaldb' is not recognized as an internal or external command,operable program or batch file."

    Sunday, December 01, 2013 6:13 AM
  • Install SQL Server 2012 Express ADV

    The version info of LocalDB

    You can find some more info on LocalDB on Windows 7 (x64) here:

    http://hodentek.blogspot.com/search?q=localdb


    mysorian

    Sunday, December 01, 2013 8:57 AM
  • This worked fine as compare to other.

    Thank You :)

    Thursday, January 23, 2014 5:54 AM
  • This solution worked for me. Thank you!
    Friday, March 07, 2014 9:04 PM
  • Fine, It works for me......

    Nice to put your effort!

    Wednesday, April 02, 2014 5:53 PM
  • Thanks
    Wednesday, April 02, 2014 5:56 PM
  • Super and Cool solution..
    Wednesday, September 02, 2015 6:21 PM
  • Thansk a lot, man!!! Helped me a lot! My set up didn't show any options about creating instances!!!

    i realized that is a rare bug and was almost impossible to find someone talking about it!

    so simple to solve and so hard to find.

    no i m ready to begin my sql studies.

    thank you!

    Monday, August 29, 2016 3:35 AM
  • Outstanding!
    Wednesday, February 01, 2017 12:12 AM
  • Thanks man that soloution works like a charm 
    Saturday, February 24, 2018 2:53 PM