Help with Microsoft SQL Server, Error: 10060


  • I keep receiving the error (see details below), I configure the firewall to allow exception sqlserver , allow remote connection thru tcp/ Ip.I still cannot connect to the remote server.

    I try from 2 different computers with Microsoft SQL Server Management Studio Express.

    It does not let me add a connection to th e remote database with the Visual Web Express thru the database explorer.

    I will appreciate any workaround or link to a knowledge base.

    Thank you



    An error has occurred while establishing a connection to the server.
     When connecting to SQL Server 2005, this failure may be
    caused by the fact that under the default settings SQL Server does not allow remote connections.
    (provider: TCP Provider, error: 0 - A connection attempt failed because the connected party did not properly respond after a period of time,
     or established connection failed because connected host has failed to respond.) (Microsoft SQL Server, Error: 10060)

    Monday, June 09, 2008 6:25 AM


All replies

  • Follow the directions in this post and see if that resolves the issue.



    Monday, June 09, 2008 7:37 AM
  • I have the same error.  I am running a virtual server with SQL 2005 standard SP3, I have installed .NET 3.5.  I am trying to communicate via service broker with a SQL cluster running SQL 2008 Enterprize.  Yes the broker is routed to the cluster IP, not the IP of the SQL server within the cluster.

    This is a lab environment and the firewalls are completely disabled.  Both servers are configured to allow remote connections.  The cluster and the virtual machines are on different domains.  Putting them on the same domain didn't fix it either.

    I have checked the switch between them by removing it and using an open linksys switch to verify that it is not a switch-level application block.  I can query the databases from each other, and I can connect to either through ODBC.  I can telnet from one box to the other in both directions.

    Even wierder, when I telnet to that port service broker picks up the connection on both sides.  Wierder still; I tried standing up a physical box to eliminate any potential issues caused my Hyper-v, and still got the same error.

    I have checked the enpoints, the routes, and the service addresses.  I have triple checked the certificates, and I have completely unistalled everything and built it back up from the domain level.

    I have a microsoft team onsite, who say that if someone had called them with this problem, they would have said there is no way you are having this issue.  Yet they are onsite, can see it with thier eyes, and are completely baffled.

    Anyone with more valid input than "Check endpoints, certs, routes, and allow remote connections." out there please?  Because I think I may hunt down the next person who insults me by sending me to the service broker teams blog on endpoints.  I know how to search MSDN, and team blogs, thank you.

    Yes, I also know what wire shark is and how to use it; the packets load up on the 2005 side, but never get to the cluster.
    Thursday, November 05, 2009 3:47 PM
  • Tiberius,  Sorry to be jumping on a nearly 3 year old thread. Did you ever resolve this problem? Thanks!
    Wednesday, May 23, 2012 6:47 PM