none
Database Project Builds in Visual Studio But Not with MSBuild Command Line RRS feed

Answers

  • Hi Janet. Thanks for the reply. I'm no longer actively working on this particular problem so I don't have the test project set up anymore. If we revisit it and encounter the problem again, I'll provide the info requested.

    I did post another question just today, coincidentally. I'm having a problem resolving references to a linked server in an SSDT project, and the documentation I find about referencing linked servers on MSDN still seems to refer to the old VS db project settings. If you could take a look at that I'd greatly appreciate it!

    Friday, June 8, 2012 5:41 PM

All replies

  • Sorry that you're experiencing this issue, and thanks for letting us know.  I created a project that references two .dacpacs and I'm unable to reproduce the behavior you're describing.  So that we can better investigate, will you please gather the following info and pass it onto me at janety at microsoft dot com?

    - Run the build with the verbose option on.  It will look something like 

    msbuild /t:rebuild /v:diag myproject.sqlproj > output.txt

    - Gather an event log by following these steps

    1. Open a new command prompt as Administrator.
    1. Run the following command

    logman create trace -n JuneauDebug -p "Microsoft-SQLServerDataTools" 0x800 -o "%LOCALAPPDATA%\SSDTDebug.etl" -ets

    1. Run whatever the target/issue scenario is
    1. Go back to the command prompt and run the following command

    logman stop JuneauDebug -ets

    1. The resulting ETL file will be located at %LOCALAPPDATA\SSDTDebug.etl and can be navigated to using Windows Explorer.
    1. Please attach this file to an email and send it to me

    Thanks,

    Janet Yeilding

    Friday, June 8, 2012 5:19 PM
  • Hi Janet. Thanks for the reply. I'm no longer actively working on this particular problem so I don't have the test project set up anymore. If we revisit it and encounter the problem again, I'll provide the info requested.

    I did post another question just today, coincidentally. I'm having a problem resolving references to a linked server in an SSDT project, and the documentation I find about referencing linked servers on MSDN still seems to refer to the old VS db project settings. If you could take a look at that I'd greatly appreciate it!

    Friday, June 8, 2012 5:41 PM
  • Thanks for the response, please do let us know if you run into the issue again.  

    I'll take a look at the linked servers post, too.

    -Janet Yeilding

    Friday, June 8, 2012 5:57 PM
  • I face the same issue..

    My build succeeds in SSDT but fails with MSBuild.exe command line, Below is log of both..

    Also the step "Validating the project model..." takes very long to complete in both cases.

    SSDT:

    ------ Rebuild All started: Project: Servicer, Configuration: Release Any CPU ------
    Loading project references...
    Loading project files...
    Building the project model and resolving object interdependencies...
    Validating the project model...
    Writing model to C:\main\dev\OrionDBServer\Servicer\obj\Release\Model.xml...
    Servicer -> C:\main\dev\OrionDBServer\Servicer\bin\Release\Servicer.dll
    Servicer -> C:\main\dev\OrionDBServer\Servicer\bin\Release\Servicer.dacpac
    ========== Rebuild All: 1 succeeded, 0 failed, 0 skipped ==========


    MSBUild.exe:

    C:\Windows\Microsoft.NET\Framework64\v4.0.30319\MSBuild !SourceSoln! /t:Rebuild 

         2>SqlBuild:
             Loading project files...
             Building the project model and resolving object interdependencies...
             Validating the project model...
         2>c:\Main\Dev\OrionDBServer\DAC Packages\EINV.dacpac : Build error SQL72025: Failed to load C:\MAIN\DEV\ORIONDBSERVER\DAC PACKAGES\EINV.DACPAC.
         2>Done Building Project "c:\Main\Dev\OrionDBServer\Servicer\Servicer.sqlproj" (Rebuild target(s)) -- FAILED.
         1>Done Building Project "c:\Main\Dev\OrionDBServer\OrionServer.sln" (Rebuild target(s)) -- FAILED.

    Build FAILED.

           "c:\Main\Dev\OrionDBServer\OrionServer.sln" (Rebuild target) (1) ->
           "c:\Main\Dev\OrionDBServer\Servicer\Servicer.sqlproj" (Rebuild target) (2) ->
           (SqlBuild target) -> 
             c:\Main\Dev\OrionDBServer\DAC Packages\EINV.dacpac : Build error SQL72025: Failed to load C:\MAIN\DEV\ORIONDBSERVER\DAC PACKAGES\EINV.DACPAC.

        0 Warning(s)
        1 Error(s)

    Time Elapsed 00:20:30.28


    Mahesh

    Sunday, November 2, 2014 3:37 PM
  • Hi Janet,

    I have uploaded the SSDT Debug file at below link if you could diagnose.

    https://onedrive.live.com/redir?resid=25E9697055FF94A0%212849

    Appreciate your help..

    Thanks


    Mahesh

    Sunday, November 2, 2014 4:20 PM