none
codedUI error RRS feed

  • Question

  • Whenever I try to Generate Code, I get the following error: "Value does not fall within the expected range."  Have not found any posts here or elsewhere that proved to be helpful. Thanks!
    Friday, January 24, 2020 7:02 PM

Answers

  • Hi markysdad,

    Welcome to MSDN forum.

    Could you please share us with some more detailed information about which kind of project do you use? Which version of VS do you use? And maybe you could share us with some related codes(replace your private information with XXXX). It is helpful for us to check if you could share us with a simple sample which could reproduce your issue, you could upload it to OneDrive or GitHub and post the link here, I will then go to download and test on my side.

    In addition, I consider this issue is more related to the codes from program, but maybe this issue is caused by VS, please try below steps to troubleshoot.

    #1. Disable/stop any third-party extension that may affect the test temporarily, and test again.

    #2. Please try to delete the obj and bin folder as well as the hidden .vs folder in your solution project and find the VS cache under this path -> C:\Users\username\AppData\Local\Microsoft\VisualStudio\XX.XX\ComponentModelCache and delete the “ComponentModelCache” folder, then build and test again.

    BTW, if you test other projects(generate codes) (maybe a simple one)will this issue appear too?

    Looking forward to hearing from you.

    Kind Regards,

    Tianyu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by markysdad Friday, January 31, 2020 1:29 PM
    Monday, January 27, 2020 8:05 AM

All replies

  • Hi markysdad,

    Welcome to MSDN forum.

    Could you please share us with some more detailed information about which kind of project do you use? Which version of VS do you use? And maybe you could share us with some related codes(replace your private information with XXXX). It is helpful for us to check if you could share us with a simple sample which could reproduce your issue, you could upload it to OneDrive or GitHub and post the link here, I will then go to download and test on my side.

    In addition, I consider this issue is more related to the codes from program, but maybe this issue is caused by VS, please try below steps to troubleshoot.

    #1. Disable/stop any third-party extension that may affect the test temporarily, and test again.

    #2. Please try to delete the obj and bin folder as well as the hidden .vs folder in your solution project and find the VS cache under this path -> C:\Users\username\AppData\Local\Microsoft\VisualStudio\XX.XX\ComponentModelCache and delete the “ComponentModelCache” folder, then build and test again.

    BTW, if you test other projects(generate codes) (maybe a simple one)will this issue appear too?

    Looking forward to hearing from you.

    Kind Regards,

    Tianyu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by markysdad Friday, January 31, 2020 1:29 PM
    Monday, January 27, 2020 8:05 AM
  • Hi friend,

    Sorry to bother you.

    Do you have any update? Please feel free to let us know.

    Any feedback will be expected.

    Best Regards,

    Tianyu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, January 31, 2020 11:58 AM
  • Thanks for your response.  I tried your second suggestion, and I still get the error reported above. However, it appears not to matter, as code is now being generated. Thank you for your help.

    Friday, January 31, 2020 1:29 PM