none
SQLCMD for Linux is missing in ODBC 13. RRS feed

  • Question

  • I followed the instructions to install the ODBC 13 Driver on a RHEL 7.2 machine. They are available as a downloadable PDF file here: https://www.microsoft.com/en-us/download/details.aspx?id=50420 . I also copied them below.

    sudo su
    yum-config-manager --add-repo https://apt-mo.trafficmanager.net/yumrepos/mssql-rhel7-release/
    yum-config-manager --enable mssql-rhel7-release
    wget "http://aka.ms/msodbcrhelpublickey/dpgswdist.v1.asc"
    rpm --import dpgswdist.v1.asc
    yum remove unixodbc #to avoid conflicts during installation
    yum update
    yum install msodbcsql
    #for silent install use ACCEPT_EULA=Y yum install msodbcsql
    yum install unixODBC-utf16-devel #this step is optional but recommended*

    According to the SQL Documentation available here: https://msdn.microsoft.com/en-us/library/hh568447(v=sql.110).aspx , the sqlcmd tool is available on Linux and included in the driver package. I cracked open the RPM and sqlcmd is definitely not included. How do I get sqlcmd on my RHEL 7.2 environment?

    Thursday, October 20, 2016 7:53 PM

All replies

  • Hi sz1a,

    You could have a look at following article that shows how to install the Microsoft ODBC Driver for SQL Server on Linux. Before you can begin to use the driver, install the unixODBC driver manager. See Installing the Driver Manager for more information.

    https://msdn.microsoft.com/en-us/library/hh568454%28v=sql.110%29.aspx

    Best Regards,

    Albert Zhang

    Friday, October 21, 2016 2:11 AM
  • I also tried this ODBC 13 on Ubuntu 16.04 following the instructions from the link and SQLCMD is not found after installation. I ran odbcinst -q -d -n "ODBC Driver 13 for SQL Server" and it is on my computer

    EDIT:

    https://blogs.technet.microsoft.com/dataplatforminsider/2016/10/25/odbc-driver-13-0-for-sql-server-linux-is-now-released/

    Note: Packages for SQL Server command line tools will be available soon. The above mentioned packages only install the ODBC Driver for SQL Server that enable connectivity from any C/C++ application.

    • Edited by Jay_Michael Tuesday, November 15, 2016 4:38 PM
    Tuesday, November 15, 2016 4:01 PM
  • Jay_Michael,

    I noticed someone pulled the mssql-tools rpm from https://apt-mo.trafficmanager.net/yumrepos/mssql-rhel7-release/

    Do you know if it is a matter of days/weeks before the SQL Server CLI tools are available?  Thanks

    Tuesday, November 15, 2016 7:35 PM