none
DB Backup unable to select second drive RRS feed

  • Question

  •  

    SQL 2005 Ent sp2 environment.  I recently added a second drive to deal with backups in a maintenance plan.  However, when I try to change my maintenance plan to point to the new drive, I am unable to browse to the new drive.  In fact, I can't use ANY other drive other than the installation drive.

     

    I then tried a manual backup of a database to the new drive, and receive the following message when I try to browse the new drive:

     

    X:

    Cannot access the specified path or file on the server.  Verify that you have the necessary security privileges and that the path or file exists.

     

    If you know that the service account can access a specific file, type in the full path for the file in the File Name control in the Locate dialog box.

     

    To make sure this wasn't a security issue, I temporarily granted Domain Admin rights to the account.  Still no joy.  I'm at a loss as to what could be causing the issue.  Any advise would be appriciated.

    Tuesday, September 30, 2008 9:01 PM

Answers

All replies

  • Is this a mapped drive or a physical drive in the Server?  If it is a mapped drive, then it won't exist unless the user mapping it is logged in.  You should use the UNC path instead to backup to the location that the drive was mapped to.

     

    Wednesday, October 1, 2008 1:13 AM
    Moderator
  • Physical drive.  I've tried a UNC path to another location and get the same issue as well.

     

    Wednesday, October 1, 2008 2:27 PM
  • And you are certain that the SQL Services are running under a Domain user account and not Local System or Network Service?

     

    Wednesday, October 1, 2008 2:33 PM
    Moderator
  • Yep, definately a domain account.  But, in theory, should it NEED to be a domain account for a local drive?  I can't even back something up to the C: drive, only the installation drive. 

     

    Here's another question, do I need to do something for SQL to recognize the new drive?  This is a fiberchannel install, and all I did was assign the LUN, and format the drive.  If windows sees and can access the drive, it should be good to go yes?

     

    Wednesday, October 1, 2008 3:09 PM
  • No it doesn't need to be a domain account for local drives, but the Service account does need to have access to the drive in the ACL's.  I run SQL Server under a domain user, with minimal rights, and the create a folder on any drive the SQL Service needs access to, and add the service account to that folder explicitly with full control.  Double check your permissions at the file system level.  I can't think of anything else that would cause this problem.  Making the SQL Service account a Domain Admin still wouldn't give it rights, unless the Domain Admins group was also a member of the Local Adminstrators Group on the Server.  If you still have a problem after that, you have me stumped.  I would try to restart the SQL Server afterhours and check again, but I have personally never had to do that step to make this work.

     

    Wednesday, October 1, 2008 3:15 PM
    Moderator
  •  

    Yeah, it sounds like you and I are on the same page.  The account's a domain user, added to the the local admin group.  For fun, I logged into the box with that account and created a folder and txt file on the new local backup location.  Worked like a champ. 

     

    I'm stumped too. The rebooting was my next step.  I'm not looking forward to it, but I don't know what else to do to get it working.  I'm not sure the reboot is going to do anything because I should be able to choose ANY local drive for a backup.

     

    Hang on.  Something I haven't mentioned yet is this is a cluster environment.  The new drive was added to the cluster under a new group.  Is SQL smart enough to not allow access to a physical disk that isn't part of the same group?

    Wednesday, October 1, 2008 3:36 PM
  • I have to admit I am not a clustering guru, but you have specific steps to follow to add a drive to the cluster:

     

    http://msdn.microsoft.com/en-us/library/ms177447.aspx

     

     

    Wednesday, October 1, 2008 3:51 PM
    Moderator
  •  

    ok, yeah, is sounds like the sql cluster might need to have the drive as a dependancy to function.  I'll give that a try tonight hopefully and we'll see what happens.

     

    Thanks for the link!  I was halfway there, had the resource, just not as a dependancy.

    Wednesday, October 1, 2008 4:00 PM