none
SQL Server 2005 Express Installation Failed RRS feed

  • General discussion

  • Summary
    =============================
    Problem Description
    ===================

    Customer trying to install Microsoft Office Accounting 2008, the first part of the installation is to install SQL Server 2005 Express Edition and it failed with the following errors. Microsoft SQL Server Native Client gets installed successfully and it fails while installing Support files.

    Summary.txt
    ===========
    Microsoft SQL Server 2005 9.00.3042.00
    ==============================
    OS Version      : Microsoft Windows XP Professional Service Pack 2 (Build 2600)
    Time            : Tue Dec 09 08:58:00 2008
     
    Machine         : MANAGER
    Product         : Microsoft SQL Server Setup Support Files (English)
    Product Version : 9.00.3042.00
    Install         : Failed
    Log File        : C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Files\SQLSetup0006_MANAGER_Support.log
    Error Number    : 1625
    --------------------------------------------------------------------------------
    MANAGER : There was an unexpected failure during the setup wizard. You may review the setup logs and/or click the help button for more information.


    SQL Server Setup failed. For more information, review the Setup log file in %ProgramFiles%\Microsoft SQL Server\90\Setup Bootstrap\LOG\Summary.txt.


    Core.log in the Cab files
    =========================

    SqlSetupFilesComp WNetGetUniversalName returned 2250
    Installing from: d:\a5eef0a660b515708f8c02676b64\Setup\SqlSupport.msi
    Error 1608 getting product information for package:d:\a5eef0a660b515708f8c02676b64\Setup\SqlSupport.msi
    Failed to install support files
    This installation is forbidden by system policy.  Contact your system administrator.
    This installation is forbidden by system policy.  Contact your system administrator.: (1625) {e:\sql9_sp2_t\sql\setup\sqlcu\dll\customcomps.cpp:861}
    SCU_SetupMgr::svc() caught exception: This installation is forbidden by system policy.  Contact your system administrator.: (1625) {e:\sql9_sp2_t\sql\setup\sqlcu\dll\customcomps.cpp:861}. SetupMgr: state=ERROR, cancel_state=0, is_done=0, ActionRequired=1, NeedReboot=0, custom_props={AutoStart=true
    DotNetPatch=
    HandleReboots=false
    ModuleDir=d:\a5eef0a660b515708f8c02676b64
    QuietMode=true
    SNACPatch=
    SupportPatch=
    Unattended=false
    WorkDir=d:\a5eef0a660b515708f8c02676b64
    }} {e:\sql9_sp2_t\sql\setup\sqlcu\dll\scusetupmgr.cpp:520}
    <EndFunc Name='UpdateComponents' Return='1603' GetLastError='0'>
    Component update returned a fatal error : 1625
            Error Code: 0x80070659 (1625)
    Windows Error Text: This installation is forbidden by system policy.  Contact your system administrator.


    Support.log
    ===========

    MSI (s) (F8:A8) [16:39:20:921]: Product Code passed to Engine.Initialize:           ''
    MSI (s) (F8:A8) [16:39:20:921]: Product Code from property table before transforms: '{53F5C3EE-05ED-4830-994B-50B2F0D50FCE}'
    MSI (s) (F8:A8) [16:39:20:921]: Product Code from property table after transforms:  '{53F5C3EE-05ED-4830-994B-50B2F0D50FCE}'
    MSI (s) (F8:A8) [16:39:20:921]: Product not registered: beginning first-time install
    MSI (s) (F8:A8) [16:39:20:921]: Product {53F5C3EE-05ED-4830-994B-50B2F0D50FCE} is not managed.
    MSI (s) (F8:A8) [16:39:20:921]: MSI_LUA: Credential prompt functionality not available on this operating system
    MSI (s) (F8:A8) [16:39:20:921]: PROPERTY CHANGE: Adding ProductState property. Its value is '1'.
    MSI (s) (F8:A8) [16:39:20:921]: Entering CMsiConfigurationManager::SetLastUsedSource.
    MSI (s) (F8:A8) [16:39:20:921]: Note: 1: 2720 2: 2
    MSI (s) (F8:A8) [16:39:21:390]: MainEngineThread is returning 1625
    MSI (s) (F8:78) [16:39:21:500]: No System Restore sequence number for this installation.
    This installation is forbidden by system policy.  Contact your system administrator.
    d:\a5eef0a660b515708f8c02676b64\Setup\SqlSupport.msi




    All the errors mentioned here directs us to the permission issue because of the error "This installation is forbidden by system policy".
    But interestingly none of the steps to provide proper priviledge resolves the issue. The issue was with the obfuscated product key in the registry.
    This issue might occur if the customer previously had a SQL Server installation and removed them manually.

    Steps I took to resolve the issue, for quick reference check the last point because none of these steps followed had resolved the issue.

    Resolution
    ==========

    -- It fails on checking the configuration settings before starting the setup
    -- Confirmed that the customer is a part of Local Administrator
    -- Added it explicitly to the mandatory Local Security Policies
     Act as Part of the Operating System
     A djust Memory Quota for process
     Bypass Traverse Checking
     Lock Pages In Memory 
     Log on as a Batch Job
     Log on as a Service
     Replace a Process Level Token

    -- Checked the registry for any left over, as we had SQL Server 2005 earlier and removed it manually
    -- No Left over found
    -- Checked for Software restriction Policies, none defined
     To check this Right click on Software Restriction Policies, click create new policies
     Double click on the Enforcement entry, to open Enforcement Properties dialog,

     a. Under "Apply software restriction policies to the following:" section, keep "All software files except libraries (such as DLLs)" options checked,
     b. under "Apply software restriction polices to the following users:" section, change to "All users except local administrators".

    -- Exit the Administrator Tools and restarted the machine, tried the setup it failed again
    -- Collected Process Monitor, could not see any Permission issue
    -- Checked GPedit.msc
    User Config./Admin Templates/Windows Components/Windows Installer/Search Order
    -- It was not configured, I configured it to nmu as the files were saved locally onto the disk

                 "n" represents the network;
                 "m" represents media;
                 "u" represents URL, or the Internet.

    -- Started setup again failed, removed nmu and changed it to Not configured which was by default.
    -- Checked the Registry Key HKEY_LOCAL_MACHINE\test2\HKLM\Software\Policies\Microsoft\Windows\Installer
    "EnableAdminTSRemote"=dword:00000001
    -- Changed the value to 0 and created two other dwords and set their values to 0
    "AllowLockdownMedia"
    "AllowLockdownBrowse"

    -- The setup failed again


    Step that resolved the issue
    =============================

    -- Checked the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products
    -- Found there is on key matching the product key mentioned in the above errors in an obfuscated way

    For example in my case the Product key in the errors was
    MSI (s) (F8:A8) [16:39:20:921]: Product {53F5C3EE-05ED-4830-994B-50B2F0D50FCE} is not managed.
    In the registry I found this obfuscated key EE3C5F35 DE50 0384 99 B4 05 2B 0F 5D F0 EC and it was blank in the right pane

    -- And deleted the Product Key which was the reverse of the one mentioned in the log for SQL in SQLSetup0001_MANAGER_Support.log
    MSI (s) (F8:A8) [16:39:20:921]: Product {53F5C3EE-05ED-4830-994B-50B2F0D50FCE} is not managed.

    -- Took backup of the products key and Deleted  EE3C5F35DE50038499B4052B0F5DF0EC from the Registry
    -- Ran the setup again Now the setup succeeded for SQL Server 2005, But failed while installing Microsoft Office Accounting with the same errors
    -- Now it listed only two items that failed to install

    Microsoft office accounting 2008 PayPal Add in
    Microsoft Office accounting 2008

    -- After checking the log I found that it failed with the same error  of Policy Restriction for MOA
    -- Deleted the reverse of this product key BE40D474-9F3F-4277-82CA-DE216C796DFF from the Registry
    -- Now MOA 2008 got installed successfully


    Microsoft Online Community Support
    Wednesday, March 4, 2009 11:06 AM
    Moderator