SSRS 2008 - Forcing "(Not Selected)" for SSL Certificate for Web Service URL, and no SSL for Report Manager URL RRS feed

  • Question

  • Given:

    - Installing SQL Server 2008 R2 Standard 64-bit on Windows 2008 R2 Standard.

    - Two potentially invalid certificates are present in the Personal certificate store (this is a client's machine, and I cannot remove them).

    - IIS is NOT installed on the server.

    - UAC is off, Enhanced Security is off.

    - According to all logs and messages, installation is successful.

    - SSRS is running. Under Web Service URL and Report Manager URL in Configuration tool, a http:// url is listed and an https:// url is listed, using one of the two potentially invalid certificates in the Personal store.


    - Attempt to connect to Reporting Services via SQL Management Studio results in an error, "Could not establish trust relationship for ssl/tls secure channel. Underlying connection was closed."

    - Attempting to open http:// URL for either Web Service or Report Manager in the browser results first in an invalid certificate warning, then in 404.

    - Attempting to open https:// URL for Web Service results in rsAccessDenied (error says that my logon account does not have sufficient privileges).

    - Attempting to open https:// URL for Report Manager results in 404.

    Attempted resolution 1:

    - Tried removing SSL URL options for both Web Service and Report Manager URLs.

    Result 1:

    - Both URLs stopped working altogether.

    Attempted resolution 2:

    - On a VM clone of the affected machine, displaying the same symptoms, uninstalled SSRS, removed both certificates from the store, reinstalled and reconfigured SSRS.

    Result 2:

    - (Not Selected) option appeared in the SSL drop menu under Web Service URL in Configuration Tool.

    - SSL URL did not appear in under the Report Manager in Configuration tool (only http:// url appeared).

    - SSRS started working correctly.

    Though Solution 2 worked, I would like NOT to have to remove the certificates from the store, but just specify that the SSRS not use SSL at all. How can I do this? If a certificate is present in the Personal Store, (Not Selected) option is not available under Web Service URL section, and an SSL URL is automatically generated for the Reports URL.

    All advice appreciated.

    Thursday, July 15, 2010 10:34 PM