none
I can't view my reports! RRS feed

  • Question

  • I can browse my subfolders containing reports in Home, but Internet Explorer displays error message when I press a report.

    I can use Properties, History and the other tabs, but when I press "View" tab I can only see error message.

    I have to use external IP address (217.x.x.x/Reports) so I tried to set this IP in ReportManager\RSWebAppConfig file:

    <UI> 
      <ReportServerUrl>http://217.x.x.x/ReportServer</ReportServerUrl>
    </UI>

    But when I try to use local IP address (10.x.x.x/Reports) in my local net, I can't connect to the report server.

    When I change this to <ReportServerUrl>http://10.x.x.x/ReportServer</ReportServerUrl>

    I can't view my reports from external host using external IP (217.x.x.x/Reports) because local IP is used when I press "View" tab.

    I don't know if there are other files that should be changed? Can somebody tell me how to solve this problem?

    Best regards,

    Chris

    Friday, February 2, 2007 8:59 AM

All replies

  • Rgb,

     

    Try this is the report RSWebAppConfig file:

      <ReportServerUrl>217.x.x.x</ReportServerUrl>
      <ReportServerVirtualDirectory></ReportServerVirtualDirectory>

     

    In the rsreportserver.config:

    <UrlRoot>http://217.x.x.x/reportserver</UrlRoot>

    Recycle your application pool and then stop and restart your website.

    You can also put in a host header to resolve your IP and use http://MyServer/reportserver instead of displaying your reporting IP address.

    Also, there is a catch on the server if you use host headers, then you need to do the following:

    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3. Right-click Lsa, point to New, and then click DWORD Value.
    4. Type DisableLoopbackCheck, and then press ENTER.
    5. Right-click DisableLoopbackCheck, and then click Modify.
    6. In the Value data box, type 1, and then click OK.

    Quit Registry Editor, and then restart your computer

     

    How do I know all this, trust me you don't want to know the pain it took to figure all this out.

     

    Ham

     

     

     

    Friday, February 2, 2007 8:18 PM