none
BIDS -- Cannot view processed cube in BIDS "Browser"

    Question

  • Hello

    I am getting the below mentioned error in BIDS.

    When I try to "explore data" on a Dim Table in BIDS --> Data Source View I am getting the below error. I can process/deploy  the cube but when I try to view the cube in the "Browser" Tab in BIDS I get the same error.

    Error:-

    Invalid class string (Exception from HRESULT: 0x800401F3 (CO_E_CLASSSTRING))

    Anyone knows how to resolve this problem. I could view the cube in the BIDS "browser tab" as of last week. I have not done windowsupdate or installed any new software in the last week

    OS: Win XP SP3
    MS Office Enterprise 2007 Edition
    SQL Server 2005 Developer Edition 9.00.3042.00 with BIDS

    Thanks
    Sunday, July 06, 2008 2:59 AM

Answers

  •  

    HI - you need to:

     

    • Go to control panel
    • Go to Add/Remove programs
    • Click on Microsoft Office 2003 Web Components
    • Click "Change"
    • Select Reinstall or Repair
    • Follow the wizaerds instructions

    The cube browser is an Office Web Component - this should solve your problem

     

    Bob

    Tuesday, July 29, 2008 3:54 PM

All replies

  •  

    Although I never saw that error,

     

    it looks like you have problems with grid/pivot control. And I don't know of any solution to this but to reinstall SQL components again, or repair them. Apply SP after.

     

     

    Tomislav Piasevoli

    Business Intelligence specialist

    http://www.softpro.hr

     

    Monday, July 07, 2008 7:37 AM
    Answerer
  •  

    HI - you need to:

     

    • Go to control panel
    • Go to Add/Remove programs
    • Click on Microsoft Office 2003 Web Components
    • Click "Change"
    • Select Reinstall or Repair
    • Follow the wizaerds instructions

    The cube browser is an Office Web Component - this should solve your problem

     

    Bob

    Tuesday, July 29, 2008 3:54 PM
  •  

    Thank you!!!

     

    I had the exact same error as described and this fixed it for me.

    Tuesday, December 02, 2008 9:14 PM
  • Thanks a lot!!!

    I fixed the same error as described.

    Friday, February 05, 2010 7:52 PM
  • rpress: thanks for the clear explanation on how to solve this issue!  I've referred to it in a quick blog post (http://blog.hoegaerden.be/2010/02/12/browsing-cube-in-management-studio-throws-class-string-error/).

    To the other posters who said "thanks": don't forget to click the "Vote as helpful"-button on the correct answer.

    Regards,
    Valentino.
    Friday, February 12, 2010 9:22 PM
  • Another cause for the error "Invalid class string" in the cube browser in Management Studio we found was that the MSOLAP10 (MSOLAP.4) provider had become unregistered somehow.

    Process Monitor tool (http://technet.microsoft.com/en-us/sysinternals/bb896645) showed a plethora or Not Found exceptions, but the one on MSOLAP.4 registry keys stood out near the end before the error appeared.

    We reinstalled the OLEDB Provider from here and it resolved the same error.

    SQL Server 2008 R2 SP1 feature pack
    http://www.microsoft.com/download/en/details.aspx?id=26728

    1033\x86\SQLSERVER2008_ASOLEDB10.msi 23.9 MB


    Didn't get enough help here? Submit a case with the Microsoft Customer Support team for deeper investigation - http://support.microsoft.com/select/default.aspx?target=assistance

    Tuesday, April 10, 2012 7:27 PM