none
SSRS 2017- Trying to print on IE11, asked for SSRS2014 ActiveX to be installed RRS feed

  • Question

  • We have recently upgraded from SSRS 2008 to SSRS 2017.

    When I try to print a report on IE11, I get a messeage to install toy Reporting Services 2014 ActiveX Control. Even when I do install it on my PC (I have adminstrator rights), everytime I reopen the browser and try to print, I get this message.

    Regards,

    Marios Tofarides

    Wednesday, January 30, 2019 9:58 AM

All replies

  • Hi matofarides

    You could check in the following aspect.

    • Check if the issue exists in other browser or not .
    • check if you have selected "Enable for Download signed ActiveX controls" in IE browser. Please refer to steps below:
       1.Click Tools -> Internet options.
       2.Switch to the Security tab, select the Trusted sites zone, and then click Sites.
       3.Type the URL of Report Server, click Add, and then click Close .
       4.Click the Custom level button, scroll to the ActiveX controls and plug-ins node.
       5.Click Enable for Download signed ActiveX controls, and then click OK.
    • Check if you have run the browser with the administrator permission
    • Turn down your uac setting
    • Check if you could print other webpage in current browser (not ssrs )
    • Is there only one ssrs instance in your local machine ? Try to remove other instances and only keep the ssrs 2017 and test it again.

    You could check more detailed information about this issue at :

    SSRS printing SQL server 2016

    Unable to install Client Print Control for SSRS 2014 onto a 32-bit Windows 7 PC

    Hope it can help you.

    Best Regards,

    Eric Liu


    Best Regards, Eric Liu MSDN Community Support Please remember to click Mark as Answer if the responses that resolved your issue, and to click Unmark as Answer if not. This can be beneficial to other community members reading this thread.

    Thursday, January 31, 2019 6:01 AM
  • Hi Eric,

    I've tried all of these, but they didn't work.

    The only way it worked is by enabling Download Signed ActiveX Controls AND Running as Administrator.

    This might be an option for me personally, but It might not be allowed by company policies.

    Is there any other way to do it?

    Thanks,

    Marios

    Thursday, January 31, 2019 8:54 AM