none
Generating report for 10,000 records (SSRS 2008) RRS feed

  • Question

  • Hi Experts,

    I have SQL Procedure resulting 10,000 records, which is properly indexed and working fine from db.

    Using SSRS 2008 recreated a report to print the records with some parameters.

    Problem : The SSRS Report Viewer Control and even Report Manager is loading all the records in 1 page, which is taking very long time to show and scroll.

     

    Please suggest how can improve the performance. (Creating Paging??? etc)

    I appreciate some quick solution.

    SA

    Thursday, November 25, 2010 10:38 AM

Answers

  • Hi,

    So, Its looks like your Interactive page braeks are not working.  These settings needs to be done in report defination, this is not report viewer setting.

    Can you check if you have "keep togather" property is checked in tablix property? If this option is selected then whole page might be loaded.

    Hope this helps


    -Chintak
    • Marked as answer by sa250281 Saturday, November 27, 2010 11:34 AM
    Friday, November 26, 2010 11:41 PM

All replies

  • Hi,

    If you are using HTML rendering, you can use interactive height property to specify soft page break in HTML. So only some of the records will be rendered.

    You can set interactive height from Report Properties.

     


    -Chintak
    • Proposed as answer by Karl Beran Thursday, November 25, 2010 12:14 PM
    Thursday, November 25, 2010 11:16 AM
  • I already used the Property Interactive height set to 11.27", which is working fine when printed and exported.

     

    But the problem is when report viewer outputs the result.

     

    Please suggest...
    Thursday, November 25, 2010 2:46 PM
  • Any suggestions, please...

     

    Even the report manager and report viewer control renders all records in one page. which is taking much more time.

     

    Is there way to have paging automatically like crystal report does.

     

    Thanks...

    Friday, November 26, 2010 10:33 AM
  • Hi,

    So, Its looks like your Interactive page braeks are not working.  These settings needs to be done in report defination, this is not report viewer setting.

    Can you check if you have "keep togather" property is checked in tablix property? If this option is selected then whole page might be loaded.

    Hope this helps


    -Chintak
    • Marked as answer by sa250281 Saturday, November 27, 2010 11:34 AM
    Friday, November 26, 2010 11:41 PM
  • EXCELLENT...

    Chintak,

    that was the problem.

    Thank you very much for your time..

    Saturday, November 27, 2010 11:33 AM
  • Hi, How did u resolve this? I have the keeptogether property as false in my report. but still all the records come on single page in the report viewer.

    Thanks,

    Prasad.

    Tuesday, November 30, 2010 8:12 AM
  • Hi, How did u resolve this? I have the keeptogether property as false in my report. but still all the records come on single page in the report viewer.

    Thanks,

    Prasad.

    Tuesday, November 30, 2010 8:13 AM
  • Hi Prasad,

    Have you checked your InteractiveHeight property of your report? This causes a soft pagebreaks. KeepTogether tablix property, which overwrite default behieviour.

    -Chintak


    -Chintak
    Tuesday, November 30, 2010 10:53 PM
  • Hi,

    I have rdlc file which has 20 to 25 subreports which are dynmaically loaded using streams. All the reports have tables along with details section and grouping is not in all the tables but very few sub reports. I have set the property Keep Together on single page if possible.

    When i export the data to PDF everything looks good and works as expected but when it is exported to Word document it does not behave the same way as in PDF/Reportviewer page. if my deatils has 10 rows it is showing 5 rows in one page and 5 page in the next page instead it should take all the data to the next page, which is my requirement.  In Word document 5 line items blank space is shown in word document 2010 upon exporting but not pdf or the report viewer.

    And also i am trying to set visibility expression in page footer for disclaimer text to show on the last page, it works well on PDF/Report Viwere but not on word 2010 export from report viewer.

    Please let me know if there is any way to avoid extra blank spaces which are result of page break on the detail data.

    Any help on this is greatly appreciated.

    -Suman

    Friday, August 26, 2011 9:28 AM
  • Hi Experts,

    I am facing the same problem i.e. my report shows 10000 records in one page.

    Properties i am using:

    Interective height: 8 in.

    Tablix's Keep Togeather: False

    I also used a group for Pagging set grouping expression to: =Ceiling(RowNumber(Nothing)/100)

    and set this group page break to the End.

    But i am facing problem....

    Please help me on this....


    shahsank

    Saturday, September 7, 2013 10:23 AM
  • Hi SA,

    You can use the page break feature of SSRS to solve your problem. Follow the below link to implement page break:

    http://www.sqlcircuit.com/2012/03/ssrs-implementing-page-break-while.html

    Thanks,

    Vishal

    Sunday, September 8, 2013 4:09 AM
  • Hi Team

    I have set interactive page size to maximum 455in,Over all it is fetching 1200 to 1500 records per page and binding to report.

    Here when i am scrolling report got stuck for 20 to 30 seconds and after that report  displaying records and all cell boarder displaying after 10 to 20 seconds (i.e rendering cell boarder  slow)

    please suggest me how to  avoid  lazy rendering

    Monday, November 26, 2018 7:02 PM