none
Not able to deploy report to SharePoint 2010 in integrated mode RRS feed

  • Question

  • I am running SharePoint 2010 Enterprise with 2 servers in the farm (SharePoint and db server). They are both running windows server 2008 R2 and the SQL Server is also R2. I have installed the reporting services R2 add-on on to the SharePoint server. I have configured the report server on the SQL server and also installed the sharepoint on it and added to the farm. I am pretty sure I have configured reporting services on the central admin properly.  I can browse to the reportserver fine too. The problem I have is that when I try to deploy my report developed in visual studio I get a pop up for credentials and no matter what I try for the user name and password, the pop up keeps coming back up and nothing happens.

    Thanks,

    Ali

    Friday, July 2, 2010 11:52 PM

All replies

  • Hi,

    Could you check the Deployment property of the Project? In BIDS, right click the solution, click Properties, and then check the property ‘TargetServerURL’. It should be a Report Server URL not Report Manager, and the URL should match the SharePoint Site:

    http://social.msdn.microsoft.com/Forums/en-US/sqlreportingservices/thread/86ad3a9a-1947-4fc5-ab6c-2b65de6e036b

     

    Hope this helps,

    Raymond


    Raymond Li - MSFT
    Sunday, July 4, 2010 3:09 AM
    Moderator
  • Hi

    what I have in the properties is as follows:

    TargetDataSourceFolder: http://mySiteURL/Data Connections

    TargetReportFolder: http://mySiteURL/Reports

    TargetServerURL: http://mySiteCollectionURL

    Reports and Data Connections are document libraries already created. I have added the appropriate content types for those libraries. Also, I have tried using the Report Builder just by clicking add new item in the Reports library and it works fine. I was able to create a new report and view data.

    Thanks

    Tuesday, July 6, 2010 1:31 AM
  • Try this...It should work!!!

    TargetDataSourceFolder: http://mySiteURL/Data Connections

    TargetReportFolder: http://mySiteURL/Reports

    TargetServerURL: http://mySiteURL/

    Tuesday, July 13, 2010 9:38 AM
  • Hi Guys,

    Im facing the same problem too. It is really frustrating.

    TargetDataSourceFolder: http://mysite/reporting/PatchDataSources

    TargetDataSetFolder: http://mysite/reporting/PatchDataSets

    TargetReportFolder: http://mysite/reporting/PatchReports/

    TargetServerURL: http://mysite/

    The login window pops up and when I enter my credentials with domain\username and pwd. I also tried other combinations with login. Nothing seems to work. It just doesnt accept the credentials and pops up the login window again. I'm like super administrator on sharepoint site. Any help is greatly appreciated.

    Thanks,

    Quietpoise

     

    PS: Ali, have you got any solution for this?

    Wednesday, July 14, 2010 12:41 AM
  • Im facing the same problem too. It is really frustrating.

    TargetDataSourceFolder: http://mysite/reporting/PatchDataSources

    TargetDataSetFolder: http://mysite/reporting/PatchDataSets

    TargetReportFolder: http://mysite/reporting/PatchReports/

    TargetServerURL: http://mysite/

    The login window pops up and when I enter my credentials with domain\username and pwd. I also tried other combinations with login. Nothing seems to work. It just doesnt accept the credentials and pops up the login window again. I'm like super administrator on sharepoint site. Any help is greatly appreciated.

    Thanks,

    Quietpoise

    Wednesday, July 14, 2010 12:42 AM
  • Quietpoise,

    If you are using the host header for the SharePoint site and you are trying to deploy the reports to that site then you will face such issue. The login dialog pops up indefinitely asking for the credentials. I fixed up this issue by following the steps.

    1. Set the DisableStrictNameChecking registry entry to 1. For more information about how to do this, click the following article number to view the article in the Microsoft Knowledge Base:

    281308  (http://support.microsoft.com/kb/281308/ ) Connecting to SMB share on a Windows 2000-based computer or a Windows Server 2003-based computer may not work with an alias name

    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0

    1. Right-click MSV1_0, point to New, and then click Multi-String Value.
    2. Type BackConnectionHostNames, and then press ENTER.
    3. Right-click BackConnectionHostNames, and then click Modify.
    4. In the Value data box, type the host name or the host names for the sites that are on the local computer, and then click OK.

    Reference: http://support.microsoft.com/kb/896861

    • Proposed as answer by josefelipepm Friday, August 6, 2010 3:00 PM
    Sunday, August 1, 2010 12:48 PM
  • Do I have the same problem, the settings are identical to those reported above created the registry key, but the problem persists. Had any more solution?
    Friday, August 6, 2010 3:00 PM
  • Do I have the same problem, the settings are identical to those reported above created the registry key, but the problem persists. Had any more solution?

    I am in the same situation ... no solution?
    Tuesday, January 4, 2011 12:36 PM
  • Same problem, please help
    Tuesday, January 11, 2011 12:15 PM
  • Has anyone got a solution to the problem?? The thread seems unsolved.

    • Proposed as answer by YBBEST Thursday, August 4, 2011 2:09 AM
    • Unproposed as answer by YBBEST Thursday, August 4, 2011 2:09 AM
    Monday, June 27, 2011 8:20 AM
  • You can check the fixes on my blog post here or copy the link below

    http://ybbest.wordpress.com/2011/08/04/how-to-fix-%E2%80%9Cnot-able-to-deploy-report-to-sharepoint-2010-in-integrated-mode%E2%80%9D/


    My technical blog : http://ybbest.wordpress.com/
    Thursday, August 4, 2011 2:10 AM
  • Tuesday, August 14, 2012 7:24 AM
  • Hello

    I had the same issue. And I opened the support case with Microsoft. I understand how frustating it will be..

    Two things:

    1. Go to Central Administration-->General Application settings-->Reporting services Integration-->Authentication mode should be Trusted mode if you didnt install Kerberos.

    2. Go to Security in Central Administration-->Configure service account-->Web application pool,Sharepoint web system,sharepoint web services default,Securitytokenserviceapplicationpool should be under your Farm account.

    I did these two things, and worked for me....

    Thanks

    Tuesday, November 6, 2012 3:59 PM