none
Sys.WebForms.PageRequestManagerServerErrorException 12152

    Question

  • Hello all,

    When executing a reporting services 2008 r2 report a get the following error:

    Message: Sys.WebForms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. The status code returned from the server was: 12152

    Line: 5

    Char: 62099

    This happens after 2 to 3 minutes. When I process the report locally a the server (windows server 2008 r2) it works ok.

    I have searched the internet and adjusted serveral setting in the web.config of the reportserver / manager. But no succes. Anyone ideas?

    Thanks

    Gerben

    Monday, July 04, 2011 3:38 PM

Answers

  • Hi Gerben_S,

    Thanks for your question. Based on my research and past experiences, this issue may be caused by time out.

    According to your description, this problem happens after 2 to 3 minutes, when you processed the report locally on the server, it works fine. So I can gather that there are large amount of data being queried from the Database, right? If I misunderstand your question, please don’t hesitate to let me know.

    Actually, when you viewing one report from one client rather than the local server, the data being passed from server to client, this process will occupy many network resources, the data will lost if the process is time out.

    In order to resolve this issue, please try to increase the connection time out in my source database.

    Hope it helps you. If your issue still exists, please feel free to let me know.

    Thanks,
    Sharp Wang


    Please remember to mark the replies as answers if they help you and unmark them if they provide no help.
    Wednesday, July 06, 2011 3:17 AM
    Moderator
  • Can you please me know the size of the report, meaning how large data its trying to pull from DB?

    Can you check if the data its taking is in Data retrieving, Data processing or data rendering? Refer this for more details: http://blogs.msdn.com/b/robertbruckner/archive/2009/01/05/executionlog2-view.aspx on querying execution Logs data from report server Catalog DB. (Note: Please be careful in reading the data, as this is the Catalog DB for SSRS).

    As Sharp suggested, there might be some network delays which can also cause the problem. Try to do a tracert from the remote machine and check if its taking too long.

    There is a setting in Report Manager to increase time out, under site settings, called "Limit report processing to the following number of seconds". Try increasing this value and check.

     


    Chaitanya( Twitter | Blogs )

    Any documentation bug? Tell us about it at Connect. Please feel free to add any community comments in any of the MSDN/technet articles.
    This posting is provided "AS IS" with no warranties, and confers no rights.

    The next CTP for SQL Server Code Name "Denali" is coming soon. Sign up now to be notified of the next CTP release.
    Wednesday, July 06, 2011 6:47 AM

All replies

  • Hi Gerben_S,

    Thanks for your question. Based on my research and past experiences, this issue may be caused by time out.

    According to your description, this problem happens after 2 to 3 minutes, when you processed the report locally on the server, it works fine. So I can gather that there are large amount of data being queried from the Database, right? If I misunderstand your question, please don’t hesitate to let me know.

    Actually, when you viewing one report from one client rather than the local server, the data being passed from server to client, this process will occupy many network resources, the data will lost if the process is time out.

    In order to resolve this issue, please try to increase the connection time out in my source database.

    Hope it helps you. If your issue still exists, please feel free to let me know.

    Thanks,
    Sharp Wang


    Please remember to mark the replies as answers if they help you and unmark them if they provide no help.
    Wednesday, July 06, 2011 3:17 AM
    Moderator
  • Can you please me know the size of the report, meaning how large data its trying to pull from DB?

    Can you check if the data its taking is in Data retrieving, Data processing or data rendering? Refer this for more details: http://blogs.msdn.com/b/robertbruckner/archive/2009/01/05/executionlog2-view.aspx on querying execution Logs data from report server Catalog DB. (Note: Please be careful in reading the data, as this is the Catalog DB for SSRS).

    As Sharp suggested, there might be some network delays which can also cause the problem. Try to do a tracert from the remote machine and check if its taking too long.

    There is a setting in Report Manager to increase time out, under site settings, called "Limit report processing to the following number of seconds". Try increasing this value and check.

     


    Chaitanya( Twitter | Blogs )

    Any documentation bug? Tell us about it at Connect. Please feel free to add any community comments in any of the MSDN/technet articles.
    This posting is provided "AS IS" with no warranties, and confers no rights.

    The next CTP for SQL Server Code Name "Denali" is coming soon. Sign up now to be notified of the next CTP release.
    Wednesday, July 06, 2011 6:47 AM
  • i have reporting services 2008 r2 In shared dataset which is using stored credentials to connect with data DB. i have integrated this SSrs in our application which is working fine. I just created DNS redirect http"//XXX/Report(in one of our web server where app is hosted) which actually redirects request to http://DBserver/reports we have multiple RDL files but few of them let say X.rdl or Y.rdl generates script error (resource.axd which meant some server side problem) for URL http"//XXX/Reportfor user A but same report render without any error for URL http://DBserver/reports and same user. This error don't log any record in SSRS log file. IN IE 9 Sys.WebForms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. The status code returned from the server was: 502 From fiddler <title>502 - Web server received an invalid response while acting as a gateway or proxy server.</title> body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;} fieldset{padding:0 15px 10px 15px;} h1{font-size:2.4em;margin:0;color:#FFF;} h2{font-size:1.7em;margin:0;color:#CC0000;} h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;} #header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF; background-color:#555555;} #content{margin:0 0 0 2%;position:relative;} .content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;} --> </style> </head> <body>

    Server Error

    <fieldset>

    502 - Web server received an invalid response while acting as a gateway or proxy server.

    There is a problem with the page you are looking for, and it cannot be displayed. When the Web server (while acting as a gateway or proxy) contacted the upstream content server, it received an invalid response from the content server.

    I searched on net and found two possible reasons 1: Related role management 2: Related to Query execution time #1 is irrelevant to SSRS #2 seems very close as after server tries now report X is being render for URL http"//XXX/Reportfor user A if query execution is problem why this problem dont occur for URL http://DBserver/reports and same user.
    Tuesday, January 24, 2012 12:32 PM