locked
Reports run in IE, but do not run on command line using RS.exe RRS feed

  • Question

  • I have been reading many forums and comments, but none of the recommendations in these other posts are working and we are hoping that someone on the forum can assist. The problem is that we can run reports via Internet Explorer when we go to either the Web Service or the Report Manager URL, but when we use RS.exe on the command line we receive the 'Could not connect to server' error. This is (one of)  my command line(s):

    rs.exe -i test.rss -s http:// localhost/reportserver -e Exec2005 -t

    The error:

    System.Exception: Could not connect to server: http:// localhost/reportserver/ReportExecution2005
    .asmx ---> System.NullReferenceException: Object reference not set to an instance of an object.
       at System.Web.Services.Protocols.SoapClientType..ctor(Type type)
       at System.Web.Services.Protocols.SoapHttpClientProtocol..ctor()
       at Microsoft.SqlServer.ReportingServices2005.Execution.ReportExecutionService..ctor()
       at Microsoft.ReportingServices.ScriptHost.Execution2005Endpoint.PingService(String url, Strin
    g userName, String password, String domain, Int32 timeout)
       at Microsoft.ReportingServices.ScriptHost.ScriptHost.DetermineServerUrlSecurity()
       --- End of inner exception stack trace ---
       at Microsoft.ReportingServices.ScriptHost.ScriptHost.DetermineServerUrlSecurity()
       at Microsoft.ReportingServices.ScriptHost.ScriptHost.InstanceMain()
       at Microsoft.ReportingServices.BaseCmdLine.CommandLineMain(String[] args, BaseCmdLine instanc
    e)

    Here are some of the things that have tried over the past few weeks:
    1. SSRS 2012 has been un-installed, all files and folders removed from disk, restarted, and re-installed several times
    2. The report server database has been re-created several times
    3. Our anti-virus Symantec Endpoint protection has been disabled for all tests
    4. Our firewalls for all profiles have been disabled for all tests (netsh advfirewall set allprofiles state off)
    5. We have verified that we can reach http:// localhost/reportserver/ReportExecution2005.asmx using Internet Explorer successfully (this ruled out any issue with the proxy config as well.)
    6. We have verified that we can reach the Web Service and the Report Manager URL and run the reports using IE successfully

    7. We have verified that we can reach localhost via telnet on port 80
    8. We have verified that the service account is not locked, this is what we use to RDP to the server and it is a local administrator. Using -u and -p parameters does not change anything.
    9. We have tried changing localhost to the hostname and we've confirmed that it resolves to an IP.
    10. The report server service trace log and the http log has been set up. Because rs.exe never connects, nothing is logged when the command line is run.
    11. There are no errors in the logs starting up the service and loading the config file.
    12. We have three other environments running the same software stack, configured the same way. These other three environments work, there is no issue with them.

    There are some other protracted logging and tracking we're doing with sysinternals tools but I'll skip it because it hasn't turned up anything meaningful. Can you help us explain what is going on here? Are we missing a patch? Please note that UAC is disabled on our servers (Windows 2008 R2) and all commands are run from a command prompt run as administrator. We are running SSRS 2012. The RS.exe version is: Version 11.0.2100.60 x86. In the text above, there is a space preceding all instances of 'http://' so I could submit the post.

    Thank you,

    Hans

    Thursday, November 12, 2015 2:26 AM

All replies