none
Numerous (every 10 minutes) Event log entries RRS feed

  • Question

  • Hi,

    Every 10 minutes, I get and information application event log of type

    ID:17137
    Info: Starting up database 'ReportServer$SQLExpressTempDB'

    This is a brand installation of the Express SP1 advanced package and the reporting service has not been yet used.

    Thanks

    Thursday, May 25, 2006 1:55 PM

Answers

  • Turns out this is normal behavior and the result of SQL Express + Reporting Services.

    Reporting Services automatically "wakes up" every ten minutes or so to check various things. To do this check, it has to query it's databases. When it queries the database, it has to open the database, which results in the log entry you are seeing.

    The "wake up" behavior of RS is normal behavior. The need to open the database is a result of the default settings of SQL Express that all databases have Autoclose turned on, so when there is no activity in a database, it is closed.

    As I said, this is normal behavior, if the log entries really bug you, you have two choices:

    1. Set the Autoclose property on the RS databases to False, this way they won't close, and thus not need to be opened, which causes the Log Entry.
    2. Turn off RS. (This is only valid if you're not using RS. )

    Mystery solved. Thanks for the interesting question.

    Regards,

    Mike Wachal
    SQL Express team

    Mark the best posts as Answers!

    Wednesday, June 14, 2006 5:58 AM
    Moderator

All replies

  • Am I the only one having this?

    E.

    Friday, May 26, 2006 2:22 PM
  • Hi Edmund,

    Could you copy the entire log entry into the thread so we can get all the information. From the info, it doesn't look like a log that RS is generating, so we need to know the source of this entry.

                     ..     
    Regards,

    Mike Wachal
    SQL Express team

    ----
    Mark the best posts as Answers!

    Thursday, June 1, 2006 4:44 PM
    Moderator
  • Hi Mike,

    First, I would like to mention that the installation is on a fresh Windows Server 2003 SP1.

    I also tried to reinstall the SQL, following the most standard installation options, but this still occurs.

    I then restarted the SQLEXPRESS server to dump Application EventLog entries. After some initialization message I get:

    • Information 6/2/2006 10:01:16 AM MSSQL$SQLEXPRESS (2) 17137 NETWORK SERVICE HOST
    • Information 6/2/2006 10:00:16 AM MSSQL$SQLEXPRESS (2) 17137 NETWORK SERVICE HOST
    • Information 6/2/2006 9:59:16 AM MSSQL$SQLEXPRESS (2) 17137 NETWORK SERVICE HOST
    • Error 6/2/2006 9:58:16 AM Report Server Windows Service (SQLEXPRESS) Management  107 N/A HOST

    The error details: Report Server Windows Service (SQLEXPRESS) cannot connect to the report server database.

    After that there are those numerous 17137 attemtps to connect to the reporting databases - every 10 minutes exact.

    Is there some more log info I can find to give you even more data about why this happens and the cause of not abling to connect?

    Thanks, Edmund

    Friday, June 2, 2006 3:15 PM
  • I have a new SQL Express install on a new Windows 2k server and am experiencing the same exact issue.  Was hoping to find a resolution here. 

    If anyone does have a resolution or troubleshooting tips, please post.

    Thanks,

    Joe

     

    06/13/2006 06:00:20,spid52,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 05:50:20,spid51,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 05:40:20,spid52,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 05:30:20,spid51,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 05:20:20,spid52,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 05:10:20,spid51,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 05:00:20,spid52,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 04:50:20,spid51,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 04:40:20,spid52,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 04:30:20,spid51,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 04:20:20,spid52,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 04:10:20,spid51,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 04:00:20,spid52,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 03:50:20,spid51,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 03:40:20,spid52,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 03:30:20,spid51,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 03:20:20,spid52,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 03:10:20,spid51,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 03:00:20,spid53,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 02:50:20,spid51,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 02:40:20,spid52,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 02:30:20,spid51,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 02:20:20,spid52,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.
    06/13/2006 02:10:20,spid51,Unknown,Starting up database 'ReportServer$SQLExpressTempDB'.

    Tuesday, June 13, 2006 1:19 PM
  • Turns out this is normal behavior and the result of SQL Express + Reporting Services.

    Reporting Services automatically "wakes up" every ten minutes or so to check various things. To do this check, it has to query it's databases. When it queries the database, it has to open the database, which results in the log entry you are seeing.

    The "wake up" behavior of RS is normal behavior. The need to open the database is a result of the default settings of SQL Express that all databases have Autoclose turned on, so when there is no activity in a database, it is closed.

    As I said, this is normal behavior, if the log entries really bug you, you have two choices:

    1. Set the Autoclose property on the RS databases to False, this way they won't close, and thus not need to be opened, which causes the Log Entry.
    2. Turn off RS. (This is only valid if you're not using RS. )

    Mystery solved. Thanks for the interesting question.

    Regards,

    Mike Wachal
    SQL Express team

    Mark the best posts as Answers!

    Wednesday, June 14, 2006 5:58 AM
    Moderator
  •  Mike Wachal - MSFT wrote:

    Turns out this is normal behavior and the result of SQL Express + Reporting Services.

    Reporting Services automatically "wakes up" every ten minutes or so to check various things. To do this check, it has to query it's databases. When it queries the database, it has to open the database, which results in the log entry you are seeing.

    The "wake up" behavior of RS is normal behavior. The need to open the database is a result of the default settings of SQL Express that all databases have Autoclose turned on, so when there is no activity in a database, it is closed.

    As I said, this is normal behavior, if the log entries really bug you, you have two choices:

    1. Set the Autoclose property on the RS databases to False, this way they won't close, and thus not need to be opened, which causes the Log Entry.
    2. Turn off RS. (This is only valid if you're not using RS. )

    Mystery solved. Thanks for the interesting question.

    Regards,

    Mike Wachal
    SQL Express team

    Mark the best posts as Answers!

     

    This doesn't really solve any mystery to me. I found this post because I'm trying to get RS to work, and i keep getting this message in my log. Why is report services unable to connect to the database out of the box?

    Wednesday, June 21, 2006 1:56 PM
  • If you're getting this message, then RS is working and it is able to connect out of the box. As I explained, this is a result of the Autoclose property for the database, which is True by default for Express.

    If RS is not working for you at all, then you have a different issue and you should start a new thread with your question.

    Regards,

    Mike

    Wednesday, June 21, 2006 3:03 PM
    Moderator
  • Hi Mike,

    Thanks for the detailed and informative answer.

    The RS is working well, so its merely an annoyance but not a functionality issue.

    I was confused as I do not see these messeges on non-express installations.

    Thanks,

    Edmund

     

    Thursday, June 22, 2006 2:51 PM
  • Hi Edmund,

    Express is the only Edition that sets Autoclose by default, so you wouldn't see this for other Editions unless you manually change that property on the RS databases.

    Mike

    Thursday, June 22, 2006 2:53 PM
    Moderator
  •  

    Hi Mike -

     

    Thanks for posting that information.  This was driving me nuts on a brand new install of System Center Essentials w/SQL Express + RS.  To top it off SCE has management packs which monitor SQL and consequently - every 10 min or so I would get an email stating that the ReportServer$TempDB had gone offline - but by the time you go and check they are back online as you indicated. 

     

    Thanks for brining clarity to frustrating problem.  Somewhat ironically I find your post 2 years and 3 months late...gotta love the web. 

     

    Cheers,

    Jordan

    Friday, October 3, 2008 3:17 AM
  • I certainly use SQL express but I am not aware that I am using reporting services.  can I shut off just reporting services?  and if so will this stop these logs every ten minutes?

     

     

    Saturday, November 22, 2008 10:37 AM
  • also how do I turn off the auto reply for the database?

    Saturday, November 22, 2008 10:39 AM
  • hi,

     Webmonkeymon wrote:

    I certainly use SQL express but I am not aware that I am using reporting services.  can I shut off just reporting services?  and if so will this stop these logs every ten minutes?

     

    access SQL Server Configuration Manager and set the Reporting Services service start mode to "manual" or "disabled".. at next OS boot, Reporting Services will not be start..

    regards

    Saturday, November 22, 2008 4:51 PM
    Moderator
  • hi,

     Webmonkeymon wrote:

    also how do I turn off the auto reply for the database?

     

    what do you mean by "auto reply for the database"?

    regards

    Saturday, November 22, 2008 4:52 PM
    Moderator
  • there are no "Reporting Services" service on SQL Express 2005. At least, I couldn't find any. :(
    Friday, December 19, 2008 1:36 PM