none
Cannot start Analysis Services 2012 on Windows Server 2012 after renaming instance RRS feed

  • Question

  • Hi,

    I have an SQL Management Studio 2012 installation on my VM. The default Tabular analysis service worked normally (i.e. it started) but since I couldn't make a connection to it from the host machine when creating a new Analysis Service Tabular Project, I decided to rename the instance to "Tabular" on my VM.

    Using the instance rename tool, I did, it was successful. But since then, I am unable to connect to the service with the following error:

    "A connection cannot be made. Ensure that the server is running. (Microsoft.analysisServices.AdomdClient)

    No connection could be made because the target machine actively refused it 127.0.0.1:2383"

    The SQL Configuration Manager shows two entries:

    SQL Server Analysis Services (TABULAR) - MSOLAP$TABULAR,

    SQL Server Analysis Services (MSSQLSERVER) - MSSQLServerOLAPService

    I get the following when I try to start either of them: "The request failed or the service did not respond in a timely fashion. Consult the event log..."

    The event viewer shows nothing related to the analysis services.

    I have tried everything available on the Internet until now (like granting permission to the ASConfig folder to the users group, checking if there is a login problem for the service user, or any other rights problem) and nothing has helped me solve the problem. When I try to rename the instance back to the default by leaving the new name field empty, it tells me that an instance already exists with the name "MSSQLSERVER". Firewall is completely off at the moment.

    Any help would be greatly appreciated.


    Thursday, August 21, 2014 2:19 PM

Answers

  • Hi Ammar,

    While renaming the instance, the Analysis Services Instance Rename tool runs under elevated privileges, updating the Windows service name, security accounts, and registry entries associated with that instance. To ensure that these actions are performed, be sure to run this tool as a local system administrator. Besides, the Analysis Services Instance Rename tool is not supported for use in a cluster environment.

    In your scenario, you can troubleshoot this issue by using  msmdsrv.log. The msmdsrv.log file for the SSAS instance that can be found in \log folder of the instance. (C:\Program Files\Microsoft SQL Server\MSAS10.MSSQLSERVER\OLAP\Log) Here is a blog about data collection for troubleshooting Analysis Services issues, please see:
    Data collection for troubleshooting Analysis Services issues

    Regards,


    Charlie Liao
    TechNet Community Support

    Friday, August 22, 2014 6:35 AM
    Moderator