Installing SQL express - Client-side and UI - Running entire install - Failed to connect to server - MainEngineThread 1601

    General discussion

  • Subjective:

    Installing SQL Express fails on VMWare


    === Verbose logging started: 19/01/2008 12:12:15 Build type: SHIP UNICODE 4.00.6000.00

    Calling process: C:\Windows\system32\msiexec.exe ===
    MSI (c) (00:CC) [12:12:15:644]: Resetting cached policy values
    MSI (c) (00:CC) [12:12:15:644]: Machine policy value 'Debug' is 0
    MSI (c) (00:CC) [12:12:15:644]: ******* RunEngine:
    ******* Product: c:\80a88385220a592902\setup\sqlncli.msi
    ******* Action:
    ******* CommandLine: **********
    MSI (c) (00:CC) [12:12:15:660]: Client-side and UI is none or basic: Running entire install on the server.
    MSI (c) (00:CC) [12:12:15:660]: Grabbed execution mutex.
    MSI (c) (00:CC) [12:12:15:691]: Failed to connect to server. Error: 0x8007043C

    MSI (c) (00:CC) [12:12:15:691]: Failed to connect to server.
    MSI (c) (00:CC) [12:12:15:706]: MainEngineThread is returning 1601
    === Verbose logging stopped: 19/01/2008 12:12:15 ===


    I'm installing SQL Express using VMWare. The virtual machine host OS is Vista Home ediition and its running on a Dual Xeon, 4Gig RAM, x86, Windows XP Pro SP2 box.

    Installing SQL Express fails to get past the first step (after accepting the EULA).

    I'm doing it via an unattended script via sqlcmd.exe. I get the same result manually installing.


    Found a tip that lead to the solution:


    Hmm, sounds like WMI might be corrupted, try these cmd line statements:

  • Mofcomp.exe %windir%\system32\wbem\cimwin32.mof
  • Regsvr32 wbemupgd.dll
  • regsvr32 wbemsvc.dll
  • wmiprvse /regserver

    - Rob



  • but  cant find the tool:

    In your F:\ drive will be a tool called the "build uninstall wizard" under the path:
    F:\Setup Tools\Build Uninstall Wizard\sqlbuw.exe

    Run this tool and see if it detects anything and removes the components. I really don't know exactly what you deleted in terms of random reg keys and directories, but somehow there are components left behind that setup is detecting.

    As for your most recent error you encountered, that means there was another windows installer package running at the same time and setup was in contention with that and error'd out. I bet if you run it again you won't get that error. Usually that happens if windows updates are installing.

    SQL Server Setup Team

    WISHLIST: Why cant you run the command installer in Vista, then see the comments column in order to MSIZAP stuff anymore?? That was a cool feature, especially for products like Visual Studio 2003...



    The problem was my Vista virtual pc was started in safe networking mode, when I did a:
    Start > Run > dcomcnfg

    I saw under Services.. that the Windows Installer service wasn't started and that was due to being in safe mode!!

    Problem solved before I could finish asking it!! ~ thought I'd share it..

    Saturday, January 19, 2008 1:47 AM