Can Not Connect To Analysis Services 2008


  • Hi,


    Just installed SQL2008 64bit on a Win2003 64bit OS. I can connect (via SQL Management Studio) to the instance of SQL2008 DB and Reporting Services 2008 but it will not allow me to connect to Analysis Services 2008. It says to make sure "SQL Browser is running"...and it is as a domain account having all the permissions that everything else has.  All other SQL Server related services are running. TCP/IP is enabled.

    Any ideas on what is needed a server to be able to connect to Analysis Services 2008? Anything I can look at?


    Thanks in advance!


    Wednesday, September 24, 2008 8:33 PM

All replies

  • Sarcastic reply: Well ... did you make sure that SQL Browser is running?


    A question:

    1.     Do you connect to a default instance of AS?


    I would expect that you connect to a nondefault instance of AS because otherwise SSMS would not require SqlBrowser. In this case first please make sure that SqlBrowser service is running. Also make sure Analysis Services service is running (Start> Run> services.msc, search for SqlBrowser and start it). If the SqlBrowser was running but you still cannot connect then open ProcessExplorer (use live search to find it), find “msmdsrv.exe” process, double click on it, open TCP/IP tab and see what port this process listens for incoming connections. After that in SSMS connect to the server like “localhost:[portnumber]” where [portnumber] is the port number you’ve seen in Process Explorer. Example: “localhost:2385”


    This will help you connect to AS, but it is not a good solution for your question. If it works then come back and we’ll try to think more.





    Friday, September 26, 2008 12:04 AM
  • Go to Configuration tools -->SQL Server Configuartion Manager and check the Log on as :It should be network service or a group account...Check this


    Hope this helps





















    Thursday, October 02, 2008 10:11 AM
  • Same issue, what is going on?

    Here is my environment:

    Server 2008 - Firewalls OFF

    SQL 2008, multiple instance names.

    SSAS Running as an instance name.

    SQL Browser and all services running as same Domain Account.

    SSAS Configured for Dynamic TCPIP Port Addressing.

    Unable to connect from any other domain Computer, even Run as Admin + Same Domain Account as Services.

    I MUST use ServerNameStick out tongueort to connect.

    WHY, really frustrating....

    All services are running and I can connect to Database instances, Reporting Services instances, just not Analysis Services.

    Please, any insight would be helpful...

    Tuesday, October 14, 2008 2:18 PM
  • I can't tell what is wrong but this article should be able to help you:


    Although the article is addressing AS2005, it should be applicable to AS2008 as well.
    Thursday, October 23, 2008 9:43 PM
  • Hi,

    I have 2 SQL server installation on XP 64 and Vista 64 bits environments.
     I have no issue connecting to each other.

    Just wondering, have you tried to connect to SSAS locally from the server?
    Is there any log in Event Viewer that related to connection failures?
    What sort of error messages are you getting?

    Wednesday, October 29, 2008 11:01 PM
  • Hi Max,

    If you are getting "SQL Browser is running" message, I presume that you have multiple instances running on the same server or you have used named instance instead of default instance.

    Have you tried to connect to the server locally on the server? Do you have find any log in Event viewer that related to connection failures?

    Wednesday, October 29, 2008 11:03 PM

    Go to Configuration tools -->SQL Server Configuartion Manager and check the Log on as :It should be network service or a group account...Check this
    Wednesday, November 05, 2008 4:42 PM
  • I was having a similar problem, with the error message indicating that the server "did not properly respond".
    The solution was to modify the Windows Firewall settings on the server in question. I had to add an extra rule to allow connections through the port number that Analysis Services was running under.
    Monday, May 18, 2009 2:46 PM
  • I had the same problem, but used the free tool suggested above called ProcessExplorer (search for this using your favourite search engine). On my DEV machine I am running McAfee virus protection software - so not sure if that blocked the usual port during install  however, my install ended up with port 662387!
    Tuesday, July 20, 2010 9:18 AM
  • Hello,

    I had same problem accessing SQL Analysis Services, But Changing AS Logon to network Service solved it. But How to make sure only authenticated users access this service, Not every one?

    Can group account address the above security question? How to add group account for AS logon? It doesn't have a password?




    Thursday, August 05, 2010 8:48 PM
  • I too had same problem after changing Log on AS "Network Services" it started working.

    Thanks for your help.


    • Proposed as answer by Rick Mattern Friday, February 06, 2015 4:58 PM
    Thursday, August 16, 2012 1:55 PM