none
Cube is showing empty RRS feed

  • Question

  • My cube is showing empty suddenly. Even after processing, it is not getting any data. I see while process, it is able to read data from backend. However it is showing no data suddenly. Any idea?
    Wednesday, September 21, 2011 7:07 AM

Answers

  • Go to the Calculations tab in the cube editor in BIDS, and check that the first statement in the MDX Script is:

    CALCULATE;

    If you've deleted that by accident, for example while editing other calculations, then the cube will seem as though it has no data in it. The data is there, however, but only at the very lowest level of granularity and it isn't being aggregated up.

    HTH,

    Chris


    Blog: http://cwebbbi.wordpress.com/ Consultancy: http://www.crossjoin.co.uk/
    • Marked as answer by Mani Ayyanar Wednesday, September 21, 2011 7:44 AM
    Wednesday, September 21, 2011 7:30 AM
    Moderator

All replies

  • Hi Mani,

    It's strange but you probably can see data is there in DSV, views and in the underlying tables (source to cube) or not. Try to do FULL process again and see if it works.

    Thanks,
    Santosh

    Wednesday, September 21, 2011 7:16 AM
  • Go to the Calculations tab in the cube editor in BIDS, and check that the first statement in the MDX Script is:

    CALCULATE;

    If you've deleted that by accident, for example while editing other calculations, then the cube will seem as though it has no data in it. The data is there, however, but only at the very lowest level of granularity and it isn't being aggregated up.

    HTH,

    Chris


    Blog: http://cwebbbi.wordpress.com/ Consultancy: http://www.crossjoin.co.uk/
    • Marked as answer by Mani Ayyanar Wednesday, September 21, 2011 7:44 AM
    Wednesday, September 21, 2011 7:30 AM
    Moderator
  • Thanks Chris for your help. It has fixed the issue. By mistake we have deleted the CALCULATE command.
    Wednesday, September 21, 2011 7:45 AM