none
report server model datasource interoperability RRS feed

  • Question

  • Hi,


    Thanks for sharing your knowldge. I will try to explain: my company uses a cloud application with back end access limited to report builder. I would like to get data from their Report Server Model and put it in another database so that we can interoperate with the rest of our systems. All I have is my credentials and the report server connection (e.g. Server=http://localhost/reportserver; datasource=/Samples/Adventure Works).


    Is this possible? How? I hope there is a solution other than creating a report export to excel and import it into the target database.


    Just to let you know, I have successfully created a data source in Report Server Project with these details but I haven’t been able to publish it on Report Server either. Can this be accomplished?


    Thanks in advance



    Friday, March 22, 2013 1:04 AM

All replies

  • Please help. Any helping hand?
    Wednesday, March 27, 2013 9:15 AM
  • Please help.

    I can see related topics that were never answered. Is this a forbidden topic for Microsoft? It just doesn't make sense that there is no connectivity options for Report Model Server other than in report builder/designer.

    Thanks

    Thursday, March 28, 2013 11:35 AM
  • Yes, at the beginning I doubted if this post should go in SSRS or Data forum. Thanks for the clarification. However no luck so far in finding an answer to my questions. Any suggestions?
    Tuesday, April 2, 2013 1:40 PM
  • Hi Dan,

    Thank you for your question.

    I am trying to involve someone more familiar with this topic for a further look at this issue. Sometime delay might be expected from the job transferring. Your patience is greatly appreciated.

    Thank you for your understanding and support.

    Thanks,


    Mike Yin
    TechNet Community Support

    Wednesday, April 3, 2013 8:00 AM
    Moderator
  • Hi Mike

    Many thanks for your response. I was starting to lose hope. Sorry for being a pain with my questions but this interoperability issue is crucial for my company. I will wait patiently. Please let me know if you need more details.


    Wednesday, April 3, 2013 11:07 AM
  • Hi Dan,

    I am not exactly sure if I understand correctly what you would like to do.
    Do you want to access the report model’s data directly and import it to some kind of database? I presume you do not have access to the data source itself.

    To access the data of the report model, you will need a report. The reason for this is that the SELECT statement will be created on-the-fly.
    You could use a simple dummy report and then export it to any of the available formats like Excel as you mentioned, CSV, XML, ect


    Depending on what you want to do following topics could be also interesting to you:
         Import Data from a Reporting Services Report
         http://technet.microsoft.com/en-us/library/gg413491.aspx
         Connect to a Report or Data Feed
         http://technet.microsoft.com/en-us/library/gg399140.aspx
         Import from a Data Feed (SSAS Tabular)
         http://technet.microsoft.com/en-us/library/hh230809.aspx
         Generating Data Feeds from Reports (Report Builder and SSRS)
         http://msdn.microsoft.com/en-us/library/ee240754.aspx
         Generate Data Feeds from a Report (Report Builder and SSRS)
         http://msdn.microsoft.com/en-us/library/ff519563.aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thanks,
    Orsi
    Microsoft Online Community Support

    Tuesday, April 9, 2013 11:59 AM
    Answerer
  • Hi Orsi

    Thanks for the reply. I have followed the links you provided. At the moment I am trying to connect SSAS to a report or Data feed. However when I try to connect to a published SSRS report from SSAS, it throws the following error:

    <html><head><title>Object moved</title></head><body>
    <h2>Object moved to <a href="%2fReportServer%2flogon.aspx%3fReturnUrl%3d%252fReportserver%252fReportExecution2005.asmx">here</a>.</h2>
    </body></html>

    --.

    If I try to do it by importing the atom feed file exported, the error is "The content of the data feed is not valid for an Atom feed". For testing purposes this report is just a table showing simple data.

    Also, one of my question from the original post is still unanswered: how can I publish reports in our local SSRS server that contain data sources or datasets with embedded data sources pointing at an external report server model? While the report is in Report Designer no problem, but in the moment I publish it, it will throw the following error:

    • The report server cannot process the report or shared dataset. The shared data source 'X' for the report server or SharePoint site is not valid. Browse to the server or site and select a shared data source. (rsInvalidDataSourceReference).

      Thanks

     
    Friday, April 12, 2013 1:27 AM
  • Please help. Any suggestions? I don't seem to be able to find other people reporting on these two errors. See below screenshots

    Saturday, April 20, 2013 10:09 PM
  • Any ideas please?
    Friday, April 26, 2013 2:15 PM
  • Hello? Anybody out there?
    Thursday, May 2, 2013 1:14 PM
  • Hello hello?
    Wednesday, May 8, 2013 9:09 AM
  • Hi Dan


    Which version of Reporting Services do you use?

    I just tested this with a simple report using these steps:

    http://technet.microsoft.com/en-us/library/hh230809.aspx#importreport

    The error could be due to authorization issues. If you go to the ReportServer URL, the report can be successfully displayed?



    Regarding the published report:
    Did you try to reassign the data source (Manage -> Data Sources) for the published report on the Report Manager site?



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thanks,

    Orsi

    Microsoft Online Community Support

    Wednesday, May 8, 2013 1:47 PM
    Answerer
  • Hi Orsi,

    I am using Microsoft SQL Server Reporting Services Version 11.0.3128.0. All the reports I have tested run and display successfully when you access them via the report server URL. Instead of pointing to a live report or to a data feed, why can't I point to the same .rdl file but locally in SSAS? This "Object moved" error, how can I know exactly what is producing it?

    Regarding the published reports, I cannot reassign the data source because "report server model" can be used in BIDS (SQL Server Data Tools now) but cannot in the report server (types of data sources). I have tried to embed the "report server model"data source, etc. but no luck.

    Could you please help? I am badly stuck.



    Thursday, May 23, 2013 8:23 AM
  • Hi Dan,

    You said you only have a RS model, first you have to create a report using the model which you can use later as data source.

    The specific errors would require a more in-depth level of support. 
    If you wish to look into the errors, please visit the below link to see the various paid support options that are available to better meet your needs.
    http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone 

    Thanks,
    Orsi
    Microsoft Online Community Support

    Sunday, June 2, 2013 9:50 AM
    Answerer