none
Message is Busy from SQL Server Management Studio RRS feed

  • Question

  • Hi,

    I started getting a delay when I try to connect to a SQL Server 2005 server from Management Studio. I get a little pop-up from the quick launch telling me : Is Busy. SQL Server Management is waiting for an internal operation to complete. If you encounter this problem... report it to Microsoft.

    Has anybody experienced anything similar? If so, have you been able to fix it and how?

    Thanks in advance

     

    Farid

    • Moved by Olaf HelperMVP Friday, March 31, 2017 12:48 PM Moved from "Database Engine" to a more related forum
    Thursday, January 24, 2008 3:33 PM

Answers

  • I usually get this when using the designers in SSMS.  Things like the database diagrams, saving tables, index changes, and other items that take time to process.  There is nothing you can do to my best knowledge when it happens except wait, and or open another instance of SSMS.  I generally have 2 or 3 open at a time depending on what I am doing anyway.  I keep DEV in one SSMS instance, QA in another, and Production in another, so I minimize my chances of making mistakes in the wrong place.

     

    Thursday, January 24, 2008 5:04 PM
    Moderator
  • While I might agree with you to a degree, it really isn't much different than when the old enterprise manager would get busy, on this one tells you it is busy so you don't just kill the task.  If it really concerns you, you can open a ticket with microsoft support, and put the time and cost of the call into trying to get it fixed.  It is generally not a problem since I don't use the GUI that much for doing things.  I generally use scripts.

    Thursday, January 24, 2008 7:01 PM
    Moderator

All replies

  • I usually get this when using the designers in SSMS.  Things like the database diagrams, saving tables, index changes, and other items that take time to process.  There is nothing you can do to my best knowledge when it happens except wait, and or open another instance of SSMS.  I generally have 2 or 3 open at a time depending on what I am doing anyway.  I keep DEV in one SSMS instance, QA in another, and Production in another, so I minimize my chances of making mistakes in the wrong place.

     

    Thursday, January 24, 2008 5:04 PM
    Moderator
  • Thanks. But maybe Microsoft shoud do something about it.

    Farid

    Thursday, January 24, 2008 6:11 PM
  • While I might agree with you to a degree, it really isn't much different than when the old enterprise manager would get busy, on this one tells you it is busy so you don't just kill the task.  If it really concerns you, you can open a ticket with microsoft support, and put the time and cost of the call into trying to get it fixed.  It is generally not a problem since I don't use the GUI that much for doing things.  I generally use scripts.

    Thursday, January 24, 2008 7:01 PM
    Moderator
  •  

    I am getting the same message.  I am running Vista Business (32-bit), with SQL Server 2005 SP2 (9.0.3054).

    Twice in the last 30 minutes, SSMS (Sql Server Management Studio) hung after I saved a Database Diagram. SSMS sits there and eventually Vista provides a message in the toolbox titled "is Busy" that says "Microsoft SQL Server Management Studio is waiting for an internal operation to complete.  If you regularly encounter this delay during normal usage, please report this problem to Microsoft".

     

    The database that I am in was created 60 minutes ago, and I was using the Database Diagrams to create new tables.  I have only four so far.  I would have many more by now, if only SSMS would stop hanging.  The last time it hung (15 minutes ago) I just let it go.  It still has the animated "saving" icon going as I type this message.  So the statement from Jonathan that it "takes time to process", is not a helpful answer.  (20 minutes now of SSMS still trying to save)

     

    So, I'm wondering who else has this problem.  I never had this problem running SSMS on Windows XP, except when I forgot to install SP2.  Once I installed SP2, that problem went away.

     

    However, my current instance (like I said above) is Vista Business (32-bit), with SQL Server 2005 SP2 (9.0.3054), so it should not be having this problem.

     

    (25 minutes into SSMS trying to save).

     

    Any ideas out there?

     

    The first time this happened, I killed the SqlWb.exe process, and restarted SSMS.  I found that the diagram had not saved, but the tables that were new had been created.  So I created the diagram again, and put the tables into it.  The problem re-occured when I created a new diagram and created a new table again and tried to save (which would create two SQL Server objects objects - table and a diagram).  So, my best guess is that when you create Diagrams, save them prior to creating new tables on the diagram.

     

    (30 minutes into SSMS trying to save).

     

    I just took a dump of the SqlWb.exe process, and killed it, again.

     

    Any ideas?

    Friday, June 20, 2008 9:28 PM
  • I have a similar problem and for me it was because of having SQL management studio running inside the cluster i-e on teh cluster node.

     

    Having Management Studio outside and accessing the fail over cluster from there, worked for me perfect fine.

     

    jobs also fail beside getting unresponsive. That's SQL 2005 ENT SP2 with 2 node fail over cluster.

     

    Let's wait for SP3 

     

    Monday, June 23, 2008 7:04 AM
  • For the people that have this problem and dont want to lose their changes a really simple solution:

    - Right click the Sql server management studio in the Windows Task Bar. Thats it...  It works for me when Sql server says its busy while editing a Diagram.

    • Proposed as answer by Jaysen Marais Tuesday, October 6, 2009 2:11 PM
    Saturday, March 7, 2009 2:26 AM
  • Super Big Thank You!

    I have struggled with this on many occasions. 

    Thanks again for taking the time to post the solution.

    Mike


    n/a
    Thursday, April 16, 2009 1:43 AM
  • Right click the Sql server management studio in the Windows Task Bar. Thats it...


    Yep. Works every time
    Tuesday, October 6, 2009 2:12 PM
  • Jaysen,

     

    Where is the Windows Task Bar? Is it at the bottom? I clicked everywhere in the SSMS but it still froze.  

    Wednesday, February 17, 2010 8:30 PM
  • Hi,

    Where is the Windows Task Bar? Is it at the bottom? I clicked everywhere in the SSMS but it still froze.  

    thank you

    Wednesday, February 17, 2010 8:31 PM
  • Sans,

    Where is the Windows Task Bar? Is it at the bottom? I clicked everywhere in the SSMS but it still froze.  

    Thank you,

    Wednesday, February 17, 2010 8:31 PM
  • I kept right clicking on SSMS task bar. But still it hangs when I click  on 'alertalises'.
    Wednesday, February 17, 2010 8:43 PM
  • Thanks for this tip. Works great. I've been seeing this problem recently when using diagrams.
    Monday, May 17, 2010 10:27 PM
  • In using SSMS with SS2008 RTM, I also experience this insane behavior when I try to save a maintence plan with 3 subplans using the mp wizard.

    Right clicking the SSMS label on task bar did the magic here also. 

     

    Thanks !

    Tuesday, November 2, 2010 8:35 PM
  • For the people that have this problem and dont want to lose their changes a really simple solution:

    - Right click the Sql server management studio in the Windows Task Bar. Thats it...  It works for me when Sql server says its busy while editing a Diagram.

    For example: If your diagram creating 3 new table, 3 times click right button on SSMS caption. Sometimes click once. 
    Thursday, March 17, 2011 7:46 AM
  • We had the same problem.  It turned out to be Windows Firewall on the server.  Ports 135 and 49154.  Turning off the firewall, unblocking these 2 ports, or enabling the WMI rules seemed to solve this problem for us.  I think 49154 is a dynamically assigned port, so it is probably better to just enable the built-in WMI exclusions in Windows Firewall.  hope this helps...
    • Proposed as answer by Bernardo999 Tuesday, April 5, 2011 6:36 PM
    • Unproposed as answer by Bernardo999 Tuesday, April 5, 2011 6:36 PM
    • Proposed as answer by Bernardo999 Tuesday, April 5, 2011 6:36 PM
    Tuesday, April 5, 2011 6:36 PM
  • I'll be darned; that actually works :) I'm not doing anything with diagrams or saving tables; I normally work in script. But I am working remotely today and have a lot of windows open in SSMS.

    Ken

    Friday, March 2, 2012 4:58 PM
  •  I have the same problem. The thing is that it mostly happens when SSMS is idle. It happens at least once a day when I am out for lunch and my computer is locked. There is nothing I can do but go to task manager and end task. I am running SSMS 2012 on Windows 7 Professional.  I also tried to right click SSMS on Windows task bar and it did not help. I appreciate if anyone can help.
    • Edited by Bahareh D Wednesday, September 19, 2012 9:14 PM
    Wednesday, September 19, 2012 9:12 PM
  • Jaysen, Thank you very much! This has been an on going issue and has cost me hours in terms of productivity.  This is a bug in SSMS and Microsoft needs to correct it, businesses cannot afford to be losing production due to a bug!

    Just an FYI - this issue has occured frequently , despite the fact that I am working with a 2012 database and all systems involved are patched to the most current versions.


    Mindy Robinson

    Tuesday, October 23, 2012 12:26 AM
  • With SQL Server 2012 and Windows 8, this problem occurs multiple times a day.  The only way to solve it is to end the process in Task Manager.  Right clicking in the windows Task bar does not work in the newer version.  This has become very frustrating - not because I have to end a process a couple times a day, but because I lose all my windows.  It doesn't act like a typical crash where the windows recover when SQL is reopened, everything is simply lost.  I feel like I'm back in the early Windows 95 days where I have to save my documents every 5 minutes in case the application crashes.

    Thursday, January 10, 2013 10:28 PM
  • Jason 

    Did you find any fix for this issue? I am getting the message and as you said it's very frustrating

    Friday, September 11, 2015 2:45 PM
  • Hi All,

    I used to get that same issue when writing queries using SSMS 2012 then 2016. And as many said it is kind of annoying to always have to kill the process and restart your work if it freezes before saving.

    But I've manage to get over it with this tip: Elevate the priority of the SSMS process from "Normal" to "Above Normal" in the windows task manager.

    Hope this will help.


    • Edited by m.sadio Friday, March 24, 2017 9:13 AM
    Friday, March 24, 2017 9:11 AM
  • Still happens on my dev pc.

    Now using SSMS 17.9

    I think my issue is related to using azure sql and not inhouse!

    Friday, September 14, 2018 11:25 AM
  • No, still happening even when running SSMS v17.9.1 on a laptop (16Gb RAM, 12 core i9 processor!) on a small database.

    SSMS using 1.5% of available CPU and a fraction of the available memory but still this is happening once every few days.

    I don't know whether there is any contention with Redgate's SQL Prompt which I am also using as it starts to hang when I'm just using it write a simple stored proc and half way through the table name being selected it stops dead.

    Just posting this to let future users searching for the problem know that it was present in Windows 10 Pro 64 bit (fully updated to build 17134 ) running SQL Server 2016 developer edition (fully updated to 13.0.4224.16) accessed via SSMS version 17.9.1.

    Good luck if you have the problem too. Any solution other than killing the process would be useful if anyone finds it.

    Tuesday, January 15, 2019 3:26 PM