none
Create failed for Login ''SERVER_NAME/LOCAL_GROUP". (Microsoft.SqlServer.Smo)

    Question

  • Hello,

    I just installed SQL Server 2008 and here's the story: When I tried to create a SQL SEQURITY LOGIN of windows account it always failed to ADD with any local groups. Meanwhile I could create SQL SEQURITY LOGIN for windows domain users and local users.

    Any suggestions on what could be wrong here.

    SQL Server collation is SQL_Latin1_General_CP1_CI_AS

    Thanks.
    Thursday, January 28, 2010 7:33 PM

Answers

  •  

    1. If you are trying to add the login from GUI , Make sure you have ticked the groups option in search button when you are browsing for a login from windows/domain , by default only users and builtin administrators are ticked.

    2. You cannot add any of the default windows group like administrators , power users , remote desktop users , backup operators, guest and etc in to SQL server. Try creating a new role at the windows level and you will be add the newly created role.

     


    Thanks, Leks

    Thursday, January 28, 2010 8:14 PM
  • What is the exact error message ? you should find in the same window

    Also , login syntax is written with a backslash , i.e ''SERVER_NAME\LOCAL_GROUP"

    THX

    Please mark as answer if you think this answers your questions
    Saturday, January 30, 2010 1:41 PM
  • Try this with a group you know exists:
    CREATE LOGIN 'DOMAIN\GROUP_NAME' FROM WINDOWS;

    It should create the login without error. If it does throw an error please post it.
    Tuesday, February 02, 2010 1:08 AM

All replies

  •  

    1. If you are trying to add the login from GUI , Make sure you have ticked the groups option in search button when you are browsing for a login from windows/domain , by default only users and builtin administrators are ticked.

    2. You cannot add any of the default windows group like administrators , power users , remote desktop users , backup operators, guest and etc in to SQL server. Try creating a new role at the windows level and you will be add the newly created role.

     


    Thanks, Leks

    Thursday, January 28, 2010 8:14 PM
  • What is the exact error message ? you should find in the same window

    Also , login syntax is written with a backslash , i.e ''SERVER_NAME\LOCAL_GROUP"

    THX

    Please mark as answer if you think this answers your questions
    Saturday, January 30, 2010 1:41 PM
  • Try this with a group you know exists:
    CREATE LOGIN 'DOMAIN\GROUP_NAME' FROM WINDOWS;

    It should create the login without error. If it does throw an error please post it.
    Tuesday, February 02, 2010 1:08 AM
  •  

    1. If you are trying to add the login from GUI , Make sure you have ticked the groups option in search button when you are browsing for a login from windows/domain , by default only users and builtin administrators are ticked.

    2. You cannot add any of the default windows group like administrators , power users , remote desktop users , backup operators, guest and etc   in to SQL server. Try creating a new role at the windows level and you will be add the newly created role.

    3. For example, you will be able to add user created groups like this

    CREATE LOGIN [Machinename\SQLServerReportServerUser$ Machinename$MSRS10.MSSQLSERVER] FROM WINDOWS WITH DEFAULT_DATABASE = [master]

    GO


    Thanks, Leks

    Leks , NO offensive but I wonder why you edit much of your initial posts after other posts. usually members will add what are missed in previous posts so when you come later and add what you have missed then it will make next posts look weird as they repeat what is said in your post.

    You can add an new content in a new comment

    Again , no offensive

    Thanks for your help

    Please mark as answer if you think this answers your questions
    Tuesday, February 02, 2010 9:04 AM
  • Hi Moham,

    The several edits for the above post has occured due to application slowness or some other network issues.

    Though i have edited my post , the point i am sticking on is still the same.

    - As per my point , i have said we can add any user defined groups and not the default ones - i dont think i am deviating from my thoughts and bringing any opposite idea conflicting to my previous post.

    I just added one more example of adding a user created group belonging to reporting services.

    Thanks for your attention on this , i will take this in a right way . I am removing my last updated content from the above post.
    Thanks, Leks
    • Proposed as answer by Izhar Azati Sunday, May 13, 2012 4:19 AM
    • Unproposed as answer by Izhar Azati Sunday, May 13, 2012 4:19 AM
    Tuesday, February 02, 2010 9:14 AM
  • Hello

    Try use the name in Bracket: [My-Computer\MyName]

    Izhar Azati


    Izhar Azati

    • Proposed as answer by Izhar Azati Sunday, May 13, 2012 4:25 AM
    Sunday, May 13, 2012 4:24 AM
  • Have you tried using BUILTIN\Local Group eg BUILTIN\Power Users instead of HOSTNAME\Power Users 
    Friday, February 06, 2015 2:03 PM