none
Error 17058 Unable to start a service account on MSSQLServer and SQL Agent RRS feed

  • Question

  • hi

    I am intalling SQL 2008 standard with SP1 on a Windows Server 2003 R2 SP2.

    I installed as  "local service account" for MSSQLServer (SQL database engine) and SQL agent.

    But I want to change to "service account" as [domain\svc_XXX] for MSSQLserver and SQL agent.

    I add the [domain\svc_XXX]  in local security policy - "Log as a service"

    and also add in SSMS - Security - New Login (windows authentication.

    When I started the MSSQLserver and SQL agent using the [domain\svc_XXX], I got an error 17058.  Initerrlog: could not open error log file."  Operating system error=3 (The system cannot find the path specified).

    I don't know where else to look at..

    Also, how do I find the cumulative service pack for SQL server 2008 standard?

    thanks

    Irene

     

    Tuesday, August 17, 2010 9:13 PM

All replies

  • When changing the Service account where did you change it?

    If you used the Windows Service console, you made an error.  In SQL Server when changing service accounts (from 2005+) you HAVE to use SQL Server Configuration Manager, because there are permissions that are missed.  Like indicated by your errors, give that a try.

    Tuesday, August 17, 2010 10:03 PM
  • Going by the error message, it states that the service account does not have access to the SQL Server folders. Please check the permissions and as suggested by Mohit use Configuration Manager to make the changes to Service Account



    Pradeep Adiga
    My blog: http://www.sqldbadiaries.com
    Recent posts on my blog
    Wednesday, August 18, 2010 5:21 AM
  • Pradeep is right. SQL Service account doesnt have necessary permission in folders and registry keys. I hope you have provided permission only in SQL and not in windows. Since you are in SQL2K8 you have default groups in windows, just add the service account to these SQL default groups and then give a try. Make sure you change the service account through SQL Server Configuration manager.
    Vidhya Sagar. Mark as Answer if it helps!
    Wednesday, August 18, 2010 6:45 AM
    Moderator
  • I have faced this issue today.Give the startup parameters continuosly without spaces between data path and log path and error file path in the SQL server service properties..

    Wrong:

    -dG:\Microsoft SQL Server\MSSQL.INST01\Data\master.mdf;

    -eH:\Microsoft SQL Server\MSSQL.INST01\Data\LOG\ERRORLOG;
    -lH:\Microsoft SQL Server\MSSQL.INST01\Data\mastlog.ldf

    Right entry:

    -dG:\Microsoft SQL Server\MSSQL.INST01\Data\master.mdf;-eH:\Microsoft SQL Server\MSSQL.INST01\Data\LOG\ERRORLOG;-lH:\Microsoft SQL Server\MSSQL.INST01\Data\mastlog.ldf

    Hope someone will help from this solution!!!


    Regards http:\\sqldbatask.blogspot.com MCTS Please mark answered if I've answered your question and vote for it as helpful to help other user's find a solution quicker

    Thursday, April 11, 2013 10:10 AM
  • I faced the same error and the reason was bad password provided to the service account .

    The services came up online after providing the right password and restarted the services .

    Sunday, May 4, 2014 9:36 AM
  • Chek the service accout is having LOG on as Service permission in Local Security Policy
    Thursday, December 18, 2014 2:52 PM
  • Hi Irene:

    By seeing your error message "When I started the MSSQLserver and SQL agent using the [domain\svc_XXX], I got an error 17058.  Initerrlog: could not open error log file."  Operating system error=3 (The system cannot find the path specified)."

    Please provide access to domain\svc_XXX on log file directory.

    Thanks,

    Satish Kumar.


    Thanks, Satish Kumar. Please mark as this post as answered if my anser helps you to resolves your issue :)

    Tuesday, December 23, 2014 2:25 PM