Execution 'wccc0s552po43i45n10vgmrq' cannot be found


  • have developed a couple of simple parameterised reports in SQL Server 2005 Enterprise Reporting Services for my current project. I am now trying to use Visual Studio 2005 and the ReportView control to hook into these remote reports from an application. I have run into an error and am unable to resolve it:


    ·  Execution 'wccc0s552po43i45n10vgmrq' cannot be found    

    I have trawled the Internet and a chapter in "Microsoft SQL Server 2005 Reporting Services" with no joy. Has anyone seen this before. I'm sure it will be something simple that I have overlooked.? 

    Wednesday, October 25, 2006 4:49 AM

All replies

  • Try refreshing the report.

    In SQL server Management Studio, connect to the reporting services. Find the report, rigth click and select refresh.


    Thursday, November 02, 2006 10:52 PM
  • Still raises the exception in the web form.

    When I select "view report" in the report list in SQL Server Management Studio it works fine.  When I run it from the a web browser it works fine. When I use the ReportViewer in my application pointed at the same report in remote mode it loads ok, which indicates to me that I have set up the ReportPath and ReportServerURL values correctly, but it still raises an exception as I indicated above.  The error looks related to viewstate. I'm totally lost.

    Tuesday, November 07, 2006 1:58 AM
  • Hi,

    I am having the same issue. Did you ever solve it?

    Tuesday, February 27, 2007 2:06 AM
  • I too have experianced this problem and cannot figure out what the problem is.  I have found in another post the following:

    When you execte a report against the server, a "session" is created for that user.  These sessions eventually timeout and are cleaned up.  Generally, the sessions are managed by the viewer control, so it is somewhat odd that you are seeing this error.

    And on another site:
    The execution state is stored in the table SessionData. Loss of the execution state results in an error: "Execution 'j4j3vfblcanzv3qzcqhvml55' cannot be found (rsExecutionNotFound)."

    I am receiving this error consistantly through the report viewer on SEVERAL reports, while they all work fine directly on the RS.

    I would love to hear an answer to this one...
    Rick Seeders
    Tuesday, April 17, 2007 8:06 PM
  • Anyone have an update on this one... I am having the same issue but it's deifnitely not a timeout issue. 


    I have a Main report that has a "Jump To Report" link for one of the fields.  In ReportManager, it works fine.  The Main report renders and the 'jump to" report works fine when you click the link.


    However, if I embed a reportviewer control in an (2.0) web app, the Main report renders fine but when I click on the "jump to" report, I get the "Execution <guid> cannot be found error".  


    On some other posts, people have noted that Reporting Services calls a SP (GetSessionData) that clears out the session.  From running a trace, this looks to be the case but I have no idea how to stop it.



    Monday, June 11, 2007 2:00 PM
  • I have never resolved the problem when viewing the report from the IDE.  However if I deploy the report and the app, run it from the server, all is well.  It appears to be a problem when you are trying to debug or simply run the app from the IDE.

    Try deploying both and running from the server and I will bet your problem will resolve itself.  Not a desirable "feature" from Microsoft, but it just doesn't work from the IDE.

    Tuesday, June 12, 2007 5:25 PM
  • I finally resolved it on my end.  I had to install the following:


    1. Reportviewer Control Redistributable   (Server and development machine)
    2. Reportviewer Control Redistributable SP 1  (Server and development machine....there's a .net 2.0 fix you may need to install first)


    Since then, I have not encountered this error.  Should have looked into that aspect sooner.  Not sure if that helps anyone else out but it seemed to have fixed my issue.

    Wednesday, June 13, 2007 5:47 PM
  • Rick's solution is what worked for me. If anyone knows how to get this to work from the IDE too, that would still be helpful.
    Tuesday, June 19, 2007 5:17 PM
  • I'm posting a little 'thanx' to Timk74.

    I also had this problem. It worked fine in my development environment, but in production, my report viewer (web) gave the Execution not found exception pretty often.


    After installing Reportviewer Control Redistributable SP 1 the problem was gone!
    So, I guess the new version of Microsoft.ReportViewer.WebForms.dll was what I needed.

    For me, it was upgraded from version 8.0.50727.762 to 8.0.50727.817.


    Regards Andreas Brosten

    Wednesday, June 20, 2007 9:07 AM
  • Hi,


    I have the same error message while viewing reports in my browser. It works fine for several days and then none of my reports run, all coming up with this message.


    I checked the server and the file Microsoft.ReportViewer.WebForms.dll is not there so not sure if the suggested fix will work for me. In most of the forums this problem seems to occur for people using the web control, but I'm getting the problem in IE 7.


    In the Report Server logs I see the following entries from the time the error occurred:


    w3wp!library!1!12/14/2007-08:49:32:: Call to GetPermissionsAction(/).
    w3wp!library!1!12/14/2007-08:49:32:: Call to GetPropertiesAction(/, PathBased).
    w3wp!library!1!12/14/2007-08:49:32:: Call to GetSystemPermissionsAction().
    w3wp!library!1!12/14/2007-08:49:32:: Call to ListChildrenAction(/, False).
    w3wp!library!1!12/14/2007-08:49:32:: Call to GetSystemPropertiesAction().
    w3wp!library!1!12/14/2007-08:49:35:: Call to GetPermissionsAction(/CSR List).
    w3wp!library!1!12/14/2007-08:49:35:: Call to GetSystemPropertiesAction().
    w3wp!library!1!12/14/2007-08:49:35:: Call to GetPropertiesAction(/CSR List, PathBased).
    w3wp!library!1!12/14/2007-08:49:35:: Call to GetSystemPermissionsAction().
    w3wp!library!1!12/14/2007-08:49:35:: Call to GetPropertiesAction(/CSR List, PathBased).
    w3wp!library!1!12/14/2007-08:49:35:: Call to ListEventsAction().
    w3wp!library!1!12/14/2007-08:49:35:: Call to GetSystemPropertiesAction().
    w3wp!session!6!12/14/2007-08:49:37:: i INFO: LoadSnapshot: Item with session: dvfkuceztad1h1erimdxcnb3, reportPath: /CSR List, userName: NT AUTHORITY\NETWORK SERVICE not found in the database
    w3wp!library!6!12/14/2007-08:49:37:: e ERROR: Throwing Microsoft.ReportingServices.Diagnostics.Utilities.ExecutionNotFoundException: Execution 'dvfkuceztad1h1erimdxcnb3' cannot be found, ;
     Info: Microsoft.ReportingServices.Diagnostics.Utilities.ExecutionNotFoundException: Execution 'dvfkuceztad1h1erimdxcnb3' cannot be found
    w3wp!webserver!6!12/14/2007-08:49:37:: e ERROR: Reporting Services error Microsoft.ReportingServices.Diagnostics.Utilities.ExecutionNotFoundException: Execution 'dvfkuceztad1h1erimdxcnb3' cannot be found


    Does anyone have any idea what might be causing this? The only way I've been able to get it to work it running iisreset on the server but this is not a practical long-term solution.





    Thursday, December 13, 2007 8:36 PM
  • I downloaded the redistributable from the link that was posted.


    But after the installation was complete, when I looked under C:\Program Files\Microsoft Visual Studio 8\ReportViewer

    the dll's were not upgraded, mine stayed at Fileversion 8.0.50727.762 where as it should have been updated to 8.0.50727.817. Any ideas why?


    I already had the .NET 2.0 framework on my machine.

    Thursday, December 13, 2007 10:12 PM

    Hi Gregmackers,


    Did you ever solve your instance of this execution not found issue?

    We have exactly the same issue. Our servers work for X amount of time and then something happens and all requests then pass userName = NT AUTHORITY\NETWORK SERVICE instead of the actual user.

    IIS reset does fix the issue, but I agree that it is not a long term solution.




    Tuesday, April 22, 2008 1:40 AM
  • Create a site.

    Go to the project property page and in the server section point to your site.

    You will resove this error.

    Wednesday, March 16, 2011 2:39 PM