none
Logic App with Event Hub Connection is showing inconsistent latency RRS feed

  • Question

  • I have an Azure SQL Database which is storing real-time data that it is receiving. This data consists of a time stamp, and 2 spontaneous random integer columns which are constantly producing random integers.

    I am using a logic app that I have created, which basically checks to see if there has been new data in my Azure SQL Database and then send this new data into an event hub. 

    Event Hub then receives this data, while Stream Analytics  streams this data from the Event Hub. Thus, in stream analytics my input is Event Hub. My output in Stream Analytics is Power BI. Essentially I am taking this data to create a realtime dashboard in Power BI. 

    ERROR:

    Stream Analytics streams my data from event hub, just fine, however once Stream Analytics streams this data into Power BI, the latency times are completely random. In Power BI a random integer will appear, and then 5 seconds later produce the next random integer, and then in the next 3 seconds it will show 3 more random integers.....then wait 5 seconds for the next random integer and then produce the next 3 in 3 seconds. The latency is time is quite random and has no pattern whatsoever. After multiple tests I know that Logic Apps might be delaying the data streaming. Is there any fix to this problem? 

    Moreover, the line graph with an axis of timestamp and y axis of (random integer) is incredibly crazy and is all over  the place. 


    What can I change in Logic Apps or event hub to help fix this issue and have a consistent speed of a new integer every second or so? 

    Thursday, July 25, 2019 10:19 PM