locked
SSRS 2016 Configuration Manager : SSL certificate is not bindiing but PORT 80 works just fine. RRS feed

  • Question

  • I am trying to bind my SSL cert to my SSRS 2016.  Each time I try to bind the cert it fails.  I search for any existing certificates bound to SSRS but it comes back with nothing using the following command:

     

                    netsh> http show sslcert

     

    I try to bind the cert using the following command example:

     

                    netsh> http add sslcert hostnameport=myworkhostname.site.kev:443 certhash=0000000000003ed9cd0c315bbb6dc1c08da5e6 appid={00112233-4455-6677-8899-AABBCCDDEEFF} clientcertnegotiation=enable  

     

     

    Error message:  SSL Certificate add failed, Error: 87

    The parameter is incorrect.

     

    The SSRS Log file directory shows the initial connection workflow but it never makes it to verifying RSPortal for the SSL Report Server portal.

    The Windows Application, System and Security show no sign of a failure occurring.  I used the following references to troubleshoot.

     

     

     

    Reference:

    What to do when you get errors binding SSL Certificates to Reporting Services.

    http://sqlvandalism.com/2017/03/13/what-to-do-when-you-get-errors-binding-ssl-certificates-to-reporting-services/

    How to: Configure a Port with an SSL Certificate

    https://docs.microsoft.com/en-us/dotnet/framework/wcf/feature-details/how-to-configure-a-port-with-an-ssl-certificate


    Very Kind Regards, Kevin Scott

    Wednesday, August 5, 2020 3:21 PM

All replies

  • Hi,

    What you mean by "but PORT 80 works just fine.", you haven't describe this in your post?


    In you netsh command try using ip address instead of hostname.

    It seems like a netsh issue, If you insist use hostname, you could try, 

        netsh> http add sslcert hostnameport=myworkhostname.site.kev:443 certhash=0000000000003ed9cd0c315bbb6dc1c08da5e6 appid={00112233-4455-6677-8899-AABBCCDDEEFF} certstorename=MY clientcertnegotiation=enable

    see reference : 

    netsh “Error: 87 The parameter is incorrect” when using hostnameport

    Regards,

    Joy


    ""SQL Server related"" forum will be migrated to a new home on Microsoft Q&A SQL Server!
    We invite you to post new questions in the "SQL Server related" forum’s new home on Microsoft Q&A SQL Server !
    For more information, please refer to the sticky post.

    • Proposed as answer by Joy_Zhao Friday, August 7, 2020 7:14 AM
    Thursday, August 6, 2020 3:15 AM
  • I resolved my issue with binding the SSL certificate

    (NOTE: Images shown are not actual screenshots, they are examples from elsewhere) 

    1. Uninstall/re-install SSRS 2017
    2. Deleted the ReportServer / ReportServerTempDB databases
    3. Delete ReportServer and ReportServerTempDB
    4. Re-imported the SSL:443 certificates in the Personal and Enterprise Trust certificate stores
    5. Personal and Enterprise Trust Certificate Stores
    6. During the SSRS configuration, assigned the SSL:443 to the Web Service URL and Web Portal URL-it took few minute or 2 longer but it has been assigned now. 
    7. Asign SSL:443
    8. In SSRS Configuration Manager, assigned a new ReportServer / ReportServerTempDB databases.
    9. SSRS 2016 Change Database
    10. The ReportServer and ReportServerTempDB databases are recreated.
    11. SSRS Database Creation completed
    12. Reboot the SQL server
    13. Tested the site by going to the assigned SSL:443 address
    14. SSRS Report Portal loads
    15. !Viola!, everything seems to be working fine now, using my SSL:443 web address.

    REFERENCES:

    • How to Install and Configure SQL Server Reporting Services SSRS - SQL Server Tutorial
    • https://youtu.be/DvW9rbGBHPE

    • https://docs.microsoft.com/en-us/sql/reporting-services/install-windows/configure-report-server-urls-ssrs-configuration-manager?view=sql-server-ver15


    Very Kind Regards, Kevin Scott

    • Proposed as answer by DBAItTechPro Friday, August 7, 2020 2:58 PM
    Friday, August 7, 2020 2:51 PM
  • That's really great! I am glad that your problem has been resolved, and you can always consult us if you have any questions.

    ""SQL Server related"" forum will be migrated to a new home on Microsoft Q&A SQL Server!
    We invite you to post new questions in the "SQL Server related" forum’s new home on Microsoft Q&A SQL Server !
    For more information, please refer to the sticky post.

    Monday, August 10, 2020 6:47 AM