locked
Microsoft.ACE.OLEDB.12.0 provider is not registered on local machine RRS feed

  • Question

  • How to solve the error "The Microsoft.ACE.OLEDB.12.0 provider is not registered on local machine" . i have tried options given in some discussions , but could not fix it.

    I have been using windows 8.1,Visual Studio 2012, Access 2013.. please help..


    • Edited by Lagnajit Friday, May 9, 2014 5:06 PM
    Friday, May 9, 2014 4:56 PM

Answers

  • Hi Lagnajit,

    The issue should occur because the you only have 32-bit Microsoft ACE OLE DB 12.0 provider installed, however, the package runs in 64-bit runtime mode. To avoid this issue, if you run the package in BIDS/SSDT, you can set the Run64BitRuntime property of the IS project from True to False; if you run the pacakge in a SQL Server Agent job, check the “User 32 bit runtime” option on the “Execution options” tab of the job step. Fore more information, please see:
    http://www.bidn.com/blogs/ShawnHarrison/ssis/2362/ssis-basics-running-a-package-in-32-bit-mode

    Another approach is to install the 64-bit Microsoft ACE OLE DB 12.0 provider by installing the 64-bit Microsoft Access Database Engine 2010 Redistributable. In this way, the package can run in 64-bit runtime mode properly. One consideration is that the 32-bit Microsoft Access Database Engine 2010 Redistributable and 64-bit Microsoft Access Database Engine 2010 Redistributable cannot be installed side by side. So, if the current 32-bit Microsoft ACE OLE DB 12.0 provider is installed by the 32-bit Microsoft Access Database Engine 2010 Redistributable, you have to install 64-bit Microsoft Office suit to obtain the 64-bit Microsoft ACE OLE DB 12.0 provider.

    Regards,


    Mike Yin
    TechNet Community Support

    • Marked as answer by Mike Yin Sunday, May 18, 2014 4:58 PM
    Thursday, May 15, 2014 8:28 AM

All replies

  • Hi Lagnajit,

          You need to download the new provider so that SSIS can talk to Access 2013. It has to do with the internal engines that communicate to each other. Download the Microsoft Access database drivers located here:

    http://www.microsoft.com/en-us/download/details.aspx?id=13255

    And install it on the machine, and you should then be able to connect.

    ~Chris


    Friday, May 9, 2014 6:29 PM
  • Download and install the 32bit version of the Microsoft Access Database Engine 2010 Redistributable for use in Visual Studio, more info.

    Please mark the post as answered if it answers your question | My SSIS Blog: http://microsoft-ssis.blogspot.com | Twitter

    Sunday, May 11, 2014 8:15 PM
  • Hi Lagnajit,

    The issue should occur because the you only have 32-bit Microsoft ACE OLE DB 12.0 provider installed, however, the package runs in 64-bit runtime mode. To avoid this issue, if you run the package in BIDS/SSDT, you can set the Run64BitRuntime property of the IS project from True to False; if you run the pacakge in a SQL Server Agent job, check the “User 32 bit runtime” option on the “Execution options” tab of the job step. Fore more information, please see:
    http://www.bidn.com/blogs/ShawnHarrison/ssis/2362/ssis-basics-running-a-package-in-32-bit-mode

    Another approach is to install the 64-bit Microsoft ACE OLE DB 12.0 provider by installing the 64-bit Microsoft Access Database Engine 2010 Redistributable. In this way, the package can run in 64-bit runtime mode properly. One consideration is that the 32-bit Microsoft Access Database Engine 2010 Redistributable and 64-bit Microsoft Access Database Engine 2010 Redistributable cannot be installed side by side. So, if the current 32-bit Microsoft ACE OLE DB 12.0 provider is installed by the 32-bit Microsoft Access Database Engine 2010 Redistributable, you have to install 64-bit Microsoft Office suit to obtain the 64-bit Microsoft ACE OLE DB 12.0 provider.

    Regards,


    Mike Yin
    TechNet Community Support

    • Marked as answer by Mike Yin Sunday, May 18, 2014 4:58 PM
    Thursday, May 15, 2014 8:28 AM
  • Many thanks for this ! Really helped me out!
    Friday, November 20, 2015 9:29 AM