none
Script task drops code in SSIS package RRS feed

  • Question

  • I have a problem executing with SSIS packages which contain Script Tasks. The execution is performed in debugging mode on local machine (not deployed). I am using SSDT tools only (only light version of VS2015, but I tried and experienced the same issues using full community versions of VS2015 and VS2017). Target SQL Server is 2016 version.

    Problem:

    After opening a solution, selecting and opening package, and executing it – the Script Task runs, and the code is executed, which I know using breakpoint and a watch, which shows the change of default variable value that code assigns.

    In subsequent execution, the Script Task appears as successfully executed, but the code is ignored. The only way to make the code run is to close and reopen the solution. Closing doesn’t prompt saving changes. But after reopening, the script tasks “drops” read-only and read-write variables, it replaces the code with the default code, and it forgets all added references – basically the task becomes an empty shell, but it retains name, description, and the expressions.

    Mitigation tried:

    I have significantly simplified the code. I tried VB script and C# - nothing has changed the behaviour. And it only happens to the Script tasks.

    Unfortunately, I cannot avoid using Script tasks, because there is no prebuild object for getting data from a POSTMAN API. The code does MD5 hashing of the secret, and then makes API request and catches the response.  

    As of now, the environment is unworkable. Could you please assist to resolve the issue.

    William

    Sunday, March 4, 2018 9:28 PM

All replies