0xC0010014 (Microsoft.SqlServer.DTSRuntimeWrap)


  • 64 bit Server 2003 with Sql 2005 64-bit

    I can't seem to do a lot of things.  Like... backup the database through the SQL agent.

    I'm catching flak from the client who was told by a microsoft rep that SQL 2005 works like a charm....

    It's too late to move away from SQL 2005, we've already migrated systems over to it, and now I'm stuck.

    This error happens when trying to export to a flat file using Export Wizard(right click database and choose export):


    An error occurred which the SQL Server Integration Services Wizard was not prepared to handle. (SQL Server Import and Export Wizard)


    Exception has been thrown by the target of an invocation. (mscorlib)

    Program Location:

       at System.RuntimeMethodHandle._InvokeConstructor(Object[] args, SignatureStruct& signature, IntPtr declaringType)
       at System.RuntimeMethodHandle.InvokeConstructor(Object[] args, SignatureStruct signature, RuntimeTypeHandle declaringType)
       at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
       at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
       at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
       at Microsoft.SqlServer.Dts.DtsWizard.Step2.DataSourceComboBox_SelectedIndexChanged(Object sender, EventArgs e)
       at System.Windows.Forms.ComboBox.OnSelectedIndexChanged(EventArgs e)
       at System.Windows.Forms.ComboBox.WmReflectCommand(Message& m)
       at System.Windows.Forms.ComboBox.WndProc(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


    Exception from HRESULT: 0xC0010014 (Microsoft.SqlServer.DTSRuntimeWrap)

    Program Location:

       at Microsoft.SqlServer.Dts.Runtime.ConnectionManager.get_Properties()
       at Microsoft.DataTransformationServices.Controls.FlatFileConnectionManagerUtils.GetLocaleID(ConnectionManager connectionManager)
       at Microsoft.DataTransformationServices.Controls.FlatFileManagerGeneralPage.LoadState(ConnectionManager connManager)
       at Microsoft.DataTransformationServices.Controls.FlatFileManagerGeneralPage.set_ConnectionManager(ConnectionManager value)
       at Microsoft.SqlServer.Dts.DtsWizard.FlatFileDestForm..ctor(DataSourceInfo info, Boolean bDest, WizardInputs inputs, WizardPage page)


    Exception from HRESULT: 0xC0010014 (Microsoft.SqlServer.DTSRuntimeWrap)

    Program Location:

       at Microsoft.SqlServer.Dts.Runtime.Wrapper.IDTSPropertiesProvider90.get_Properties()
       at Microsoft.SqlServer.Dts.Runtime.ConnectionManager.get_Properties()

    Monday, February 6, 2006 1:51 PM


All replies

  • This has something to do with not being able to determine the sql server name... not sure why.

    Doesn't localhost work anymore?

    I've tried creating aliases, combinations of localhost and  Checked firewall settings.  I even reinstalled SQL 2005 hoping that would solve it (no luck).  I'm sure I've set something up wrong, but have no idea what that could be.

    Very frustrating.
    Monday, February 6, 2006 3:06 PM
  • Have you allowed remote connections for TCP in the Surface Area Config tool? Check the network library as well.
    Monday, February 6, 2006 3:52 PM

  • Remote connections are enabled for tcp/ip, and the network library is definitely working in the surface scan config (queries to the database definitely work).

    I don't see a remote connection setting for Intergration services... should there be one?

    I see Integration services under the SURFACE AREA CONFIGURATION FOR SERVICES AND CONNECTIONS, but I don't see Integration services when I click on SURFACE AREA CONFIGURATION FOR FEATURES...  Is that supposed to be there?

    I'm not a dba,  and I'm a real newbie to sql2005, although I've administered several sql 7 and sql 2000 servers over the years.

    Anybody got any notes on registering the server, so it can see itself? 

    Maybe its a closed port?  Is there a specific port for Integration services?


    Monday, February 6, 2006 4:22 PM
  • I figured out a work-around for the export to flat file problem.

    First register your sql server in SQL 2000,  it won't let you put it in the EM, but you can register the server alias.

    From the SQL 2000 EM, right click any database, and choose export.

    If you click on the down arrow on server, you should be able to choose your SQL2005 box you registered, and make sure to connect as OLE DB PROVIDER FOR SQL SERVER.

    Set the login info, then next choose the export output like normal.

    The only thing left is to make sure to save the DTS job on the local server (the 2000sql box, not the 2005sql box).

    The question is why can sql 2000 see the sql 2005 box, but sql 2005 can't see itself....?

    Monday, February 6, 2006 5:40 PM
  • Here's the error message when trying to run a Maintenance plan: (all I do is right click Maintenance plan under Management, and choose 'New maintenance plan':

    This makes it a real pain to schedule backup jobs. I've put my workaround at the bottom.


    Exception has been thrown by the target of an invocation. (mscorlib)

    Program Location:

       at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck)
       at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache)
       at System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache)
       at System.Activator.CreateInstance(Type type, Boolean nonPublic)
       at Microsoft.SqlServer.Management.DatabaseMaintenance.MaintDesignerMenuHandler.Invoke()


    Creating an instance of the COM component with CLSID {E80FE1DB-D1AA-4D6B-BA7E-040D424A925C} from the IClassFactory failed due to the following error: c001f011. (Microsoft.SqlServer.ManagedDTS)

    Program Location:

       at Microsoft.SqlServer.Dts.Runtime.Package..ctor()


    Creating an instance of the COM component with CLSID {E80FE1DB-D1AA-4D6B-BA7E-040D424A925C} from the IClassFactory failed due to the following error: c001f011. (Microsoft.SqlServer.ManagedDTS)

    Program Location:

       at Microsoft.SqlServer.Dts.Runtime.Package..ctor()



    Right click the database that you want to back up, and choose TASKS-BACKUP.
    Set up the Backup job the way you want it.  Once you are ready, click the down arrow next to the script icon (scroll of paper) and choose SCRIPT ACTION TO JOB.  This will bring up the new job.  Set up the schedule and save.  It seems to work, but if you try to click on the EDIT button in STEPS on the Job Properties, the same error as above appears.

    Monday, February 6, 2006 6:22 PM
  • We're running the same setup (Win03 64 / SQL 64) - only clustered. I'm seeing the same annoying error.  I can't edit backup scripts.  I can't even create them using SQL Mgmt Studio. 

    We recently implimented a third-party backup tool and it works perfectly - which solves the above issue.  It compresses and encryptes what we backup so its a better choice for us anyway.  Still, we always want to tweek scripts and it would be helpful if we could do it in Mgmt Studio.

    The above fix is helpful.  Using SCRIPT ACTION TO JOB, we're able to make necessary edits.  Still, I'd love to see a fix vs a workaround.


    Wednesday, March 21, 2007 1:35 PM
  • I seem to be having the same problem as well.  I'm supprised it's not fixed by now.

    Tuesday, April 24, 2007 7:02 PM
  • Uninstalling and reinstalling the tools fixed it for me.
    Wednesday, April 25, 2007 9:09 PM
  • I was able to get rid of this error by disconnecting my object explorer connection and reconnecting.
    Monday, April 30, 2007 2:53 PM
  • This didnt work for me ;(


    I am trying to create SSIS package (Bulk Insert), when i try to set Destination Connection, it failed and gives me the same error.


    Any luck to others?

    Tuesday, May 15, 2007 8:07 PM
  • Hi....

    read this kb...


    Make sure you are installing the hotfix in the right order.



    Monday, June 11, 2007 8:10 PM

    do i need to install this hotfix even if I am already using SP2?

    Monday, June 11, 2007 10:01 PM

    It is 06/2008, and this problem still is not fixed for x64 editions.  We have SP2 and all hotfixes to build 9.0.3228, and this error is still happening.  Until now, the only way to work around it is to DTS using SQL 2000 hooked into 2005.


    Microsoft, can you please fix this x64 bug???

    Monday, June 23, 2008 8:14 PM

    Aha, I found the fix.


      regsvr32 "\Program Files (x86)\Microsoft SQL Server\90\DTS\Binn\DTS.dll"


    We just installed this cluster about 2 weeks ago, so this problem still exists in the x64 installer.  This problem does not exist on the x86 installer.


    Thank u drive thru.

    • Proposed as answer by thoff Wednesday, January 6, 2010 12:52 AM
    Monday, June 23, 2008 8:28 PM
  • hi dear,

    i just tried yr fix on my 64 bit server but it says that dll cant be registered; i tired this when sql service was active; do i need to run this command when server is not accessed by anyone?


    please provide some helping hand





    Friday, July 4, 2008 12:08 PM
  • COM DLL registration such as regsvr32.exe is independent of the service, it is a basic windows function.


    It often helps if you post details of any error you’d like help with.


    Monday, July 7, 2008 12:44 PM
  • ThX Brain2000!


    x64 Windows Server 2003 R2 / x64 SQL 2005 SP2 3228



    Trying to run export/import wizard in "SSMS",

    Exception from HRESULT: 0xC0010014 (Microsoft.SqlServer.DTSRuntimeWrap)


    Trying to create new connection manager/SMOServer in "Microsoft Visual Studio",

    Exception from HRESULT: 0xC0010014 (Microsoft.SqlServer.DTSRuntimeWrap)


    Trying to create Maintenance Plans,

    Exception from HRESULT: 0xC0010014 (Microsoft.SqlServer.DTSRuntimeWrap)



    regsvr32 "\Program Files (x86)\Microsoft SQL Server\90\DTS\Binn\DTS.dll"



    Best Regards,


    Tuesday, July 8, 2008 8:57 AM
  • On a x64 Server take care do:


    %windir%\syswow64\regsvr32 "%ProgramFiles(x86)%\Microsoft SQL Server\90\dts\binn\dts.dll"


    otherwise it won't work :-)




    • Proposed as answer by Tico99 Monday, March 2, 2009 5:19 PM
    Wednesday, July 16, 2008 10:44 AM
  • Brain2000,


    SSIS packages developed at virtual server and when I deployed at production its does't worked but after executing your script its worked for me.


    Thank you So much. Its worked for me.




    Friday, August 22, 2008 7:36 AM
  • This worked for me as well. Thanks for the help!



    Tuesday, October 7, 2008 5:14 PM

    Thanks Brain2000.  I've been running into this problem for a while.  I had set up the jobs with scripts.  Registering the file fixed it for me!
    Sunday, October 19, 2008 7:29 AM
  • I was having a similar problem, and it is now fixed using the command line registration suggested by Acki above.  Here was my scenario:

    1.  We installed SQL Server 2005 64-bit on our 64-bit Windows Server 2003 R2.  We did not install Integration Services (SSIS) at this time.
    2.  When we discovered we needed SSIS, we went to Add/Remove Programs, selected Microsoft SQL Server, and chose "Change"
    3.  We added the Integration Services component.

    Next, we tried to import a Flat File into an existing database.

    1.  We opened SQL Management Studio.
    2.  We right-clicked our database, chose all tasks, and then chose Import.
    3.  When the Import/Export wizard opened, we chose Flat File from the Data Source popup menu.

    At this point, we would get an error saying that various DLLs were not found, including (Microsoft.SQLServer.DTSRuntimeWrap).

    To fix this, following Acki's suggestion above, I opened the command line and ran the following command:
    %windir%\syswow64\regsvr32 "%ProgramFiles(x86)%\Microsoft SQL Server\90\dts\binn\dts.dll"

    Thanks for a quick and easy solution.
    Monday, November 17, 2008 6:24 PM
  • Brain2000, you are a genius! Thanks!


    Monday, November 17, 2008 7:33 PM
  • It fixes the problem.  Thank you.

    Monday, March 2, 2009 5:19 PM
  • I had the same problem and you resolve it with your solution !!!!  Thanks.

    Thursday, April 2, 2009 3:47 PM
  • Thanks acki4711, that worked on 64 bit server.
    Tuesday, July 21, 2009 7:13 PM
  • 64 bit Server 2003r2 SP2 with Sql 2005 64-bit 9.0.3077

    I could not delete the maintenance plans or edit them as this post is about.
    Here comes my solution to delete the maintenance plans by T-SQL and finally edit new ones.

    Step 1: 
    Execute the below query to obtain the Maintenance plan name and Id

    Step 2:
    Replace the Id obtained from Step 1 into the below query and delete the entry from log table

    Step 3:
    Replace the Id obtained from Step 1 into the below query and delete the entry from subplans table as shown below,

    Step 4:
    Finally delete the maintenance plan using the below query where ID is obtained from Step1

    Step 5:
    Delete SQL Server Agent / Jobs

    Step 6:
    I made new maintenance jobs, but could not edit them afterwords??

    Step 7:
    Finally I uses the regsvr32 and now I can edit the maintenance plans again!
    regsvr32 "\Program Files (x86)\Microsoft SQL Server\90\DTS\Binn\DTS.dll"

    Thanks and hope my post helps someone out there:) !!

    Wednesday, July 22, 2009 12:44 PM
  • %windir%\syswow64\regsvr32 "%ProgramFiles(x86)%\Microsoft SQL Server\90\dts\binn\dts.dll"

    Worked great just exit SQL and reopen and maintenance plans work. just in time, thanks!!

    Monday, January 25, 2010 12:05 AM
  • Dear all,

    mine is on cluster enviroment, is it the same? any impact if i just run the command?

    %windir%\syswow64\regsvr32 "%ProgramFiles(x86)%\Microsoft SQL Server\90\dts\binn\dts.dll"



    Monday, July 5, 2010 1:00 AM
  • How about the cluster server? Should we stop clustering and run the command on each node?


    Wednesday, July 28, 2010 4:07 PM
  • How about the cluster server? Should we stop clustering and run the command on each node?


    I just ran the command on each node without stopping clustering and it worked. Please note that there is a space between "ProgramFiles" and "(x86)".
    Wednesday, July 28, 2010 6:51 PM
  • Hmm... now I get

    "The DDS Layout contains an invalid control progid. The layout will be regenerated."

    Wednesday, August 25, 2010 11:59 AM
  • on windows 2008 os and sql server 2008 r2 64 bit it works like this too



    \WINDOWS\SysWOW64\regsvr32 "C:\Program Files\Microsoft SQL Server\100\DTS\Binn\dts.dll"

    Friday, September 3, 2010 5:38 PM
  • On Windows 7 with SQL Server 2008 the resolution is the same.

    Remember to open a command prompt has administrator. Rigth click on the Command Prompt and select "Run as Administrator".

    regsvr32 "C:\Program Files\Microsoft SQL Server\100\DTS\Binn\dts.dll"


    Thanks to you all!

    Wednesday, September 8, 2010 10:04 AM
  • I am using SQL Server 2005. The above one fixed the problem. Thanks a lot...
    Thursday, December 2, 2010 1:33 PM
  • Could this type of behavior also show up when you are using SQL 2008 R2 client tools to connect to supported servers?
    Wednesday, December 8, 2010 5:42 PM
  • Yes, this is happening on all of our Windows 2008 R2 with SQL 2008 R2 servers in SSMS.  You may be able to open the sql server agent job, but you cannot edit a step.


    Clifton G. Collins III
    Wednesday, February 23, 2011 3:26 PM
  • %windir%\syswow64\regsvr32 "%ProgramFiles(x86)%\Microsoft SQL Server\90\dts\binn\dts.dll"

    worked for me in a SQL2005 64 bit Cluster setup. Thanks a lot for sharing. Saved hours of my time.

    Sunday, October 23, 2011 11:28 AM
  • i have this error, then i edit my plan in Managment Studio 2008, and after it, open plan in Managment Studop 2005

    SQL 2005, Server 2003 R2 x64

    Monday, September 9, 2013 9:49 AM