none
SSRS 2008 (not R2) rendering PDF differently on servers RRS feed

  • Question

  • I have a QA and a production server that have SSRS 2008 installed on them (not R2).

    On the production server, I have a report A.

    From my workstation, I open a browser and run the report on the production server, and I export it to PDF format.

    I deploy this same report to the QA server, accessing the same database.

    From my workstation, I open a browser and run the report on the QA server, and I export it to PDF format.

    The PDF from the QA server has page breaks at different places.

    I tried deleting the reports from the QA Server and re-deploying them, restarting the server, and I even downloaded the RDL file from the Production Server through the browser, and deploying that, but the page breaks still are different.

    I looked at the installed fonts, I made sure that the database

    The only difference I can see, is that the QA Server has Microsoft SQL Server SP3 and the production server has Microsoft SQL Server SP1 installed.

    Any ideas?


    Rick

    Tuesday, March 19, 2013 8:28 PM

All replies

  • Hi,

    Do you the same font installed on both, Server and local ?

    Regards

    simplesqlserver.wordpress.com


    Dj's | Please mark as answered or vote helpful if this post help resolved your issue. Thanks!

    Tuesday, March 19, 2013 8:36 PM
  • Yes, same fonts server and local

    Rick


    • Edited by Rick Hodder Tuesday, March 19, 2013 8:50 PM
    Tuesday, March 19, 2013 8:49 PM
  • Report only uses Arial

    Rick

    Tuesday, March 19, 2013 8:52 PM
  • Do you have the same regional settings on both machines?

    Printer settings?

    Wednesday, March 20, 2013 4:44 AM
  • Hello,

    I am trying to involve someone more familiar with this topic for a further look at this issue. Sometime delay might be expected from the job transferring. Your patience is greatly appreciated.
    Thank you for your understanding and support.

    Regards,
    Fanny Liu

    If you have any feedback on our support, please click here.


    Fanny Liu
    TechNet Community Support

    Friday, March 29, 2013 5:25 AM
    Moderator
  • Hi,

    Perhaps SP1 and SP3 really make differences.

    You can try to install another instance of SSRS in QA server but upgrade only until SP1 to see if the result is same with production server. 


    Regards,
    Christian HL
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, March 29, 2013 6:33 AM