Data Mining Wizard (Not Responding)


  • I am trying to create a new mining structure, but when launching the wizard the "Data Mining Wizard" stops responding where the dropdownlist with the algorithms should appear.

    The bizarre thing is that I can access the cube and the datawarehouse just fine using the same setup, it's just the mining wizard that doesn't work.

    I am using SQL 2005 standard & Visual Studio 2005 Team Suite (and yes I have reinstalled SQL 2005) - no change.

    Are there any logs that might shed some light on this strange behavior, or is this a known issue?

    Saturday, September 16, 2006 6:15 AM


  • If possible, please work with tech support - we haven't seen these issues outside of what we've already commented on, and it's difficult to debug through the forum.



    Monday, October 09, 2006 9:56 PM

All replies

  • The main difference with the DM wizard is that, unlike other wizards, it actually connects to the server to determine the list of available algorithms.  However, it is supposed to provide a default list of algorithms if it cannot connect. 

    You might try looking at the project settings to make sure that the deployment server is set up correctly.

    Have you succesfully deployed any AS projects to an AS server?

    Tuesday, September 19, 2006 4:11 PM
  • Hi Chris

    The behavior of the algorithm selection wizard page is to retrieve the list of algorithm from the deployment server. If the query times out, it reverts to a list of cached algorithms. The value of the timeout depends on whether:

    1. The server is a nonexistent machine (in this case, the timeout is equal to the time it takes to determine from DNS that the machine name is nonexistent and is usually fast)

    2. The server is offline. In this case, the timeout is longer (usually 30 seconds, but can be configured under network settings).

    3. The server is online, but Analysis Service is not started. This timeout is the TCP timeout, usually 30 seconds.

    The first step is to determine your deployment server. For that, right click on the project select properties and look under Configuration Properties -> Deployment. The server name is available in the property grid. Next, please ensure that the server is reachable and is running Analysis Services. If it's an offline server, that you should get a list of default algorithms after 30 seconds or the timeout configured for your machine

    Let me know if you have any further questions



    Wednesday, September 20, 2006 9:53 PM
  • I have the exact same issue, I have deleted and removed every thing and reinstalled SQl 2005 standard and Visual Studio 2005 and every time I get an unresposive screen when trying to pick a mining model.

    I had created a mining model before and worked fine but know just stops responding.


    Friday, October 06, 2006 8:06 PM
  • If possible, please work with tech support - we haven't seen these issues outside of what we've already commented on, and it's difficult to debug through the forum.



    Monday, October 09, 2006 9:56 PM
  • It happened to me with VS2005 and AS2005 and now with VS2008 and AS2008 (Feb CTP). The dialog hangs when trying to retrieve the list of algorithms. The server is running on the same machine as the VS2008 runs (my laptop). The deployment machine is set as "localhost" (changing it to my actual machine name does not work either).


    I am able to connect to the AS service by using the Management Studio. Any ideas?


    Thanks a lot.

    Sunday, February 24, 2008 4:08 PM
  • This problem (not responding ) occurs to meine SQL Server 2005 today. too.

    After google all internet site und try all the way. It all don't work.


    UNTIL..... I come to a idea......


    I turned off my FIREWALL (Check point Integrity) know what? works!!

  easy...after half day wasted.


    You can try my way. Just turn off your Firewall, maybe this works for you, too.

    Wednesday, April 16, 2008 6:23 PM
  • It worked! I have just turned my ZoneAlarm firewall off and the algorithms were successfully retrieved! Thanks a lot!


    At first, with the firewall running, I tried to retrieve the algorithms but the dialog hanged. I then turned the firewall off but the dialog remained hanged. Then, I killed the BIDS process and started it again - after that I tried to retrieve the algorithms and this time it worked.


    Considering that my AS is running on my laptop, along with BIDS, I never thought that having a firewall could be a problem.


    Thanks again.




    Thursday, April 17, 2008 12:58 PM