none
Linked server error 7303 RRS feed

  • Frage

  • Good morning,

    I created a linked server to access sql server 2008.

    At first everything worked properly, now returns the error 7303.

    I have already shared the folder with all of the database permits users full control of sql server users , users of the system, etc..

     

    Does anyone know how can you fix?

    I found a solution on the Internet, says to create an Admin user on the machine, and as a path to a temporary folder on your hard disk different from the profile, by entering the required permissions to SQL Server, but not seems to work after a while let us start, however, to return the error 7303.

    i found if i drop linked server , restart pc and reacreate it , it work , but when i restard pc all return error 7303.

    SQL Version : 10.0.2573

     

     

    Thanking you in advance,

    GR

    Montag, 7. November 2011 11:33

Antworten

  • Hi ,

    I fix the issue by myself.

     

    I Change the SQL Server's service Log On to "Local System account" AND

    I Provide full access to Windows 7 folder C:\Windows\ServiceProfiles\LocalService\AppData\Local\Temp

    to USERS who starts SQL SERVER ANd SQL AGENT (in my case localservice and netowrk service) and to SQLSERVER$... user type

    In  SQL Server under Provider Microsoft.Jet.OLEDB.4.0 i Disabled "Allow inprocess "

     

    Thank's 4 all ,

    Giuseppe R.

     

    Update : Before do all I update SQL Server to SP3


    Montag, 7. November 2011 14:37

Alle Antworten

  • Hello,

    Please, could you provide the full error message you are getting when your error is occuring ? And could you tell us the version of your Access ( 2003;2007,2010...) and the provider ( and its version ) used for your linked server ?

    Maybe http://social.msdn.microsoft.com/Forums/en-US/sqltools/thread/5d53eb0c-bb02-4c85-bc65-b492ee83c7c0 could help you?

    We are waiting for your feedback to to try to help you more efficiently;

    Have a nice day


    Mark Post as helpful if it provides any help.Otherwise,leave it as it is.
    Montag, 7. November 2011 12:28
    Moderator
  • Hi Normand!,

     

    Access db its a 97 version converted into 2000.

     

    If i run a select statement(select * from TEST...TAB_EAN from SSMS error is(italian version):

    Il provider OLE DB "Microsoft.Jet.OLEDB.4.0" per il server collegato "TEST" ha restituito il messaggio "Errore non specificato.".
    Messaggio 7303, livello 16, stato 1, riga 1
    Impossibile inizializzare l'oggetto origine dei dati del provider OLE DB "Microsoft.Jet.OLEDB.4.0" per il server collegato "TEST".

     

    I've read the link you provide but without success.

    The linked server use the provider: Microsoft.Jet.OLEDB.4.0

    GR

     

    update:

    I tryed to use sql server with user Local System , i can create the linked server  and use it, but if i restart the pc and restart the sql server service, i have the the same error (7303)

     

     

     

     

     


    Montag, 7. November 2011 13:15
  • Hi ,

    I fix the issue by myself.

     

    I Change the SQL Server's service Log On to "Local System account" AND

    I Provide full access to Windows 7 folder C:\Windows\ServiceProfiles\LocalService\AppData\Local\Temp

    to USERS who starts SQL SERVER ANd SQL AGENT (in my case localservice and netowrk service) and to SQLSERVER$... user type

    In  SQL Server under Provider Microsoft.Jet.OLEDB.4.0 i Disabled "Allow inprocess "

     

    Thank's 4 all ,

    Giuseppe R.

     

    Update : Before do all I update SQL Server to SP3


    Montag, 7. November 2011 14:37
  • Hi,

    i had the same problem when i got the error message 7303.

    I realized that it couldn't be that the linked server is not set up correctly because i copied the script from an other functional linked server from an other computer.

    so i just ran management studio as administrator an it worked!!!

    Donnerstag, 12. April 2012 02:08
  • Hi Eliezer,

    the issue is about security permission.

    My problem was to launch sql procedure with external program, at the moment i think my resolution its still correct, and it works with user with low securty permission.

    Donnerstag, 12. April 2012 09:46
  • Thank you!!!! This was my solution: In  SQL Server under Provider Microsoft.Jet.OLEDB.4.0 i Disabled "Allow inprocess "
    Donnerstag, 25. Juli 2013 12:59
  • I have had this error multiple times. Not even sure how it gets resolved. But just wanted to note that the answer above actually seems to have fixed it this time.

    To reiterate: In SQL, expand Server Objects : Linked Servers : Providers. Right-click Microsoft.Jet.OLDDB.4.0 and uncheck "Allow inprocess."

    
    Mittwoch, 30. April 2014 19:02