locked
Exception has been thrown by the target of an invocation RRS feed

  • Question

  • I get this error (Exception has been thrown by the target of an invocation) every time in try to record a web test...once the web test has been recorded i get this error, i tried finding a soluiton for this in the earlier threads but it did not help. Can somebody please help me to solve this issue.
    Monday, October 18, 2010 9:04 AM

Answers

  • Hello,

    You may tri the following steps to see if they help:

    a)     Try to run devenv /ResetSettings (in command prompt) to eliminate the related potential settings problem.

    b)     Try disabling Add-ins (e.g. “Tools” | “Add-in Manager”) or run “devenv.exe /SafeMode”.This can eliminate the possibility that third party Add-ins or packages are causing problems. (For more detailed VS command line switches information, see: http://msdn2.microsoft.com/en-us/library/xee0c8y7.aspx )

    c)     Try creating a new project. Sometimes corrupted project settings can cause problems. These are project specific.

    d)     Make sure that we have the latest service pack applied. Apply VS2008 SP1.

    e)     Try to reboot the operating system to safe mode. This can help to isolate whether any other applications are interfering with Visual Studio. Note that some features (like IIS) are not available under safe mode. Please check whether this can be applied or not. In addition to safe mode, we can also try “clean boot”: How to configure Windows XP to start in a "clean boot" state http://support.microsoft.com/kb/310353 .

    f)      Try to create a new user account. This can help isolate user profile corruption related causes.

    Thanks.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Thursday, October 21, 2010 5:00 AM
    Moderator

All replies

  • Hi,

    What browser are you using - can you pl. share the version details? I haven't heard of such an error before.

    Thanks!

    Neelesh

     

    Tuesday, October 19, 2010 7:55 AM
    Moderator
  • What's your environment?

    1. IE 8 or IE7?

    2. What OS?

    3. VSTS 2010 or VSTS 2008?


    Ray
    Tuesday, October 19, 2010 9:10 PM
  • Hello,

    You may tri the following steps to see if they help:

    a)     Try to run devenv /ResetSettings (in command prompt) to eliminate the related potential settings problem.

    b)     Try disabling Add-ins (e.g. “Tools” | “Add-in Manager”) or run “devenv.exe /SafeMode”.This can eliminate the possibility that third party Add-ins or packages are causing problems. (For more detailed VS command line switches information, see: http://msdn2.microsoft.com/en-us/library/xee0c8y7.aspx )

    c)     Try creating a new project. Sometimes corrupted project settings can cause problems. These are project specific.

    d)     Make sure that we have the latest service pack applied. Apply VS2008 SP1.

    e)     Try to reboot the operating system to safe mode. This can help to isolate whether any other applications are interfering with Visual Studio. Note that some features (like IIS) are not available under safe mode. Please check whether this can be applied or not. In addition to safe mode, we can also try “clean boot”: How to configure Windows XP to start in a "clean boot" state http://support.microsoft.com/kb/310353 .

    f)      Try to create a new user account. This can help isolate user profile corruption related causes.

    Thanks.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Thursday, October 21, 2010 5:00 AM
    Moderator