none
Problem Installing September Preview (Paul) - 12/4/2007 8:23 AM PST RRS feed

  • Question

  • By: Paul


    Install for September Preview fails with message ".NET version 3.0 or 3.5 
    run-time components must be installed before installing Microsoft Expressing 
    Blend 2 September Preview.".  I'm trying to install on Vista with 3.0 and 3.5 
    frameworks, as well as VS2008, already installed.  The Blend 2 August Preview 
    was previously installed successfully and uninstalled in order to install the 
    September preview.  I've already tried uninstalling and re-installing the 
    .net framework.
    
    Thanks for any suggestions.
    Thursday, February 21, 2008 8:57 PM

Answers

  • By: Annie


    Hi Paul,

    I found where this problem has been reported but I haven't yet found a
    solution. Would you please try this: Uninstall the September Preview and
    then re-install by right clicking on the installation file and choosing "Run
    As Administrator" from the context menu. Please let me know if this works.

    Thank you,

    --
    Annie
    design(at)studioe3(dot)com
    This posting is provided "AS IS" with no warranties, and confers no
    rights.



    "Paul" <Paul@discussions.microsoft.com> wrote in message
    news:ABDFE169-4240-4B2C-9CB7-82AB1F2EE6FA@microsoft.com...
    > Install for September Preview fails with message ".NET version 3.0 or 3.5
    > run-time components must be installed before installing Microsoft
    > Expressing
    > Blend 2 September Preview.". I'm trying to install on Vista with 3.0 and
    > 3.5
    > frameworks, as well as VS2008, already installed. The Blend 2 August
    > Preview
    > was previously installed successfully and uninstalled in order to install
    > the
    > September preview. I've already tried uninstalling and re-installing the
    > .net framework.
    >
    > Thanks for any suggestions.
    Friday, February 22, 2008 8:21 PM

All replies

  • By: Unni Ravindranathan (MS)


    We do not guarantee what will happen when you move from a Beta of VS 2008 to 
    the RTM version - we do test VS 2008 on new installs of XP and Vista (with 
    and without a prior installation of VS 2005 and Expression Blend).
    
    Is that the case?
    
    What is the value of the following registry key?
    Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5
    Value of Version
    
    Thanks,
    Unni
    
    "Paul" <Paul@discussions.microsoft.com> wrote in message 
    news:ABDFE169-4240-4B2C-9CB7-82AB1F2EE6FA@microsoft.com...
    > Install for September Preview fails with message ".NET version 3.0 or 3.5
    > run-time components must be installed before installing Microsoft 
    > Expressing
    > Blend 2 September Preview.".  I'm trying to install on Vista with 3.0 and 
    > 3.5
    > frameworks, as well as VS2008, already installed.  The Blend 2 August 
    > Preview
    > was previously installed successfully and uninstalled in order to install 
    > the
    > September preview.  I've already tried uninstalling and re-installing the
    > .net framework.
    >
    > Thanks for any suggestions. 
    
    Friday, February 22, 2008 8:18 PM
  • By: Paul


    Thanks Unni,
    
    The VS2008 beta was never installed on this machine.  Rather, the sequence 
    of installs was this:  1) VS2005; 2) Expression Blend August Preview;  3) 
    VS2008 RTM (90-day trial);  4) Expression Blend September Preview.  To be 
    honest, I'm not sure at what point the 3.5 framework was installed, but it is 
    there now.  Also to be clear, it's the Expression Blend install that gives 
    the error, not VS2008.
    
    Value of registry key HKLM\SOFTWARE\Microsoft\NET Framework 
    Setup\NDP\v3.5\Version:  3.5.21022.08
    
    Thanks again for the help.
    
    -Paul
    
    
    "Unni Ravindranathan (MS)" wrote:
    
    > We do not guarantee what will happen when you move from a Beta of VS 2008 to 
    > the RTM version - we do test VS 2008 on new installs of XP and Vista (with 
    > and without a prior installation of VS 2005 and Expression Blend).
    > 
    > Is that the case?
    > 
    > What is the value of the following registry key?
    > Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5
    > Value of Version
    > 
    > Thanks,
    > Unni
    > 
    > "Paul" <Paul@discussions.microsoft.com> wrote in message 
    > news:ABDFE169-4240-4B2C-9CB7-82AB1F2EE6FA@microsoft.com...
    > > Install for September Preview fails with message ".NET version 3.0 or 3.5
    > > run-time components must be installed before installing Microsoft 
    > > Expressing
    > > Blend 2 September Preview.".  I'm trying to install on Vista with 3.0 and 
    > > 3.5
    > > frameworks, as well as VS2008, already installed.  The Blend 2 August 
    > > Preview
    > > was previously installed successfully and uninstalled in order to install 
    > > the
    > > September preview.  I've already tried uninstalling and re-installing the
    > > .net framework.
    > >
    > > Thanks for any suggestions. 
    > 
    Friday, February 22, 2008 8:19 PM
  • By: Annie


    Hi Paul,
    
    I found where this problem has been reported but I haven't yet found a 
    solution. Would you please try this: Uninstall the September Preview and 
    then re-install by right clicking on the installation file and choosing "Run 
    As Administrator" from the context menu. Please let me know if this works.
    
    Thank you,
    
    -- 
    Annie
    design(at)studioe3(dot)com
    This posting is provided "AS IS" with no warranties, and confers no
    rights.
    
    
    
    "Paul" <Paul@discussions.microsoft.com> wrote in message 
    news:ABDFE169-4240-4B2C-9CB7-82AB1F2EE6FA@microsoft.com...
    > Install for September Preview fails with message ".NET version 3.0 or 3.5
    > run-time components must be installed before installing Microsoft 
    > Expressing
    > Blend 2 September Preview.".  I'm trying to install on Vista with 3.0 and 
    > 3.5
    > frameworks, as well as VS2008, already installed.  The Blend 2 August 
    > Preview
    > was previously installed successfully and uninstalled in order to install 
    > the
    > September preview.  I've already tried uninstalling and re-installing the
    > .net framework.
    >
    > Thanks for any suggestions. 
    
    
    Friday, February 22, 2008 8:19 PM
  • By: Annie


    Hi Paul,

    I found where this problem has been reported but I haven't yet found a
    solution. Would you please try this: Uninstall the September Preview and
    then re-install by right clicking on the installation file and choosing "Run
    As Administrator" from the context menu. Please let me know if this works.

    Thank you,

    --
    Annie
    design(at)studioe3(dot)com
    This posting is provided "AS IS" with no warranties, and confers no
    rights.



    "Paul" <Paul@discussions.microsoft.com> wrote in message
    news:ABDFE169-4240-4B2C-9CB7-82AB1F2EE6FA@microsoft.com...
    > Install for September Preview fails with message ".NET version 3.0 or 3.5
    > run-time components must be installed before installing Microsoft
    > Expressing
    > Blend 2 September Preview.". I'm trying to install on Vista with 3.0 and
    > 3.5
    > frameworks, as well as VS2008, already installed. The Blend 2 August
    > Preview
    > was previously installed successfully and uninstalled in order to install
    > the
    > September preview. I've already tried uninstalling and re-installing the
    > .net framework.
    >
    > Thanks for any suggestions.
    Friday, February 22, 2008 8:21 PM
  • By: Paul


    Hi Annie,
    
    Running it "as Administrator" worked.  Thanks a ton!
    
    Paul
    
    
    "Annie" wrote:
    
    > Hi Paul,
    > 
    > I found where this problem has been reported but I haven't yet found a 
    > solution. Would you please try this: Uninstall the September Preview and 
    > then re-install by right clicking on the installation file and choosing "Run 
    > As Administrator" from the context menu. Please let me know if this works.
    > 
    > Thank you,
    > 
    > -- 
    > Annie
    > design(at)studioe3(dot)com
    > This posting is provided "AS IS" with no warranties, and confers no
    > rights.
    > 
    > 
    > 
    > "Paul" <Paul@discussions.microsoft.com> wrote in message 
    > news:ABDFE169-4240-4B2C-9CB7-82AB1F2EE6FA@microsoft.com...
    > > Install for September Preview fails with message ".NET version 3.0 or 3.5
    > > run-time components must be installed before installing Microsoft 
    > > Expressing
    > > Blend 2 September Preview.".  I'm trying to install on Vista with 3.0 and 
    > > 3.5
    > > frameworks, as well as VS2008, already installed.  The Blend 2 August 
    > > Preview
    > > was previously installed successfully and uninstalled in order to install 
    > > the
    > > September preview.  I've already tried uninstalling and re-installing the
    > > .net framework.
    > >
    > > Thanks for any suggestions. 
    > 
    > 
    Friday, February 22, 2008 8:22 PM
  • By: Annie


    Wonderful! You're welcome!
    
    -- 
    Annie
    design(at)studioe3(dot)com
    This posting is provided "AS IS" with no warranties, and confers no
    rights.
    
    
    
    "Paul" <Paul@discussions.microsoft.com> wrote in message 
    news:1835CBF9-CB16-403D-AABF-0E423385152C@microsoft.com...
    > Hi Annie,
    >
    > Running it "as Administrator" worked.  Thanks a ton!
    >
    > Paul
    >
    >
    > "Annie" wrote:
    >
    >> Hi Paul,
    >>
    >> I found where this problem has been reported but I haven't yet found a
    >> solution. Would you please try this: Uninstall the September Preview and
    >> then re-install by right clicking on the installation file and choosing 
    >> "Run
    >> As Administrator" from the context menu. Please let me know if this 
    >> works.
    >>
    >> Thank you,
    >>
    >> -- 
    >> Annie
    >> design(at)studioe3(dot)com
    >> This posting is provided "AS IS" with no warranties, and confers no
    >> rights.
    >>
    >>
    >>
    >> "Paul" <Paul@discussions.microsoft.com> wrote in message
    >> news:ABDFE169-4240-4B2C-9CB7-82AB1F2EE6FA@microsoft.com...
    >> > Install for September Preview fails with message ".NET version 3.0 or 
    >> > 3.5
    >> > run-time components must be installed before installing Microsoft
    >> > Expressing
    >> > Blend 2 September Preview.".  I'm trying to install on Vista with 3.0 
    >> > and
    >> > 3.5
    >> > frameworks, as well as VS2008, already installed.  The Blend 2 August
    >> > Preview
    >> > was previously installed successfully and uninstalled in order to 
    >> > install
    >> > the
    >> > September preview.  I've already tried uninstalling and re-installing 
    >> > the
    >> > .net framework.
    >> >
    >> > Thanks for any suggestions.
    >>
    >> 
    
    
    Friday, February 22, 2008 8:22 PM
  • By: Steve White (MS)


    Paul, can you let me know whether the user account you were running under to 
    begin with is in the local administrators group on your machine, and whether 
    you saw any security dialogs during the install. THanks, you can write me 
    direct at steve dot white at microsoft dot com.
    
    Steve
    
    "Paul" wrote:
    
    > Hi Annie,
    > 
    > Running it "as Administrator" worked.  Thanks a ton!
    > 
    > Paul
    > 
    > 
    > "Annie" wrote:
    > 
    > > Hi Paul,
    > > 
    > > I found where this problem has been reported but I haven't yet found a 
    > > solution. Would you please try this: Uninstall the September Preview and 
    > > then re-install by right clicking on the installation file and choosing "Run 
    > > As Administrator" from the context menu. Please let me know if this works.
    > > 
    > > Thank you,
    > > 
    > > -- 
    > > Annie
    > > design(at)studioe3(dot)com
    > > This posting is provided "AS IS" with no warranties, and confers no
    > > rights.
    > > 
    > > 
    > > 
    > > "Paul" <Paul@discussions.microsoft.com> wrote in message 
    > > news:ABDFE169-4240-4B2C-9CB7-82AB1F2EE6FA@microsoft.com...
    > > > Install for September Preview fails with message ".NET version 3.0 or 3.5
    > > > run-time components must be installed before installing Microsoft 
    > > > Expressing
    > > > Blend 2 September Preview.".  I'm trying to install on Vista with 3.0 and 
    > > > 3.5
    > > > frameworks, as well as VS2008, already installed.  The Blend 2 August 
    > > > Preview
    > > > was previously installed successfully and uninstalled in order to install 
    > > > the
    > > > September preview.  I've already tried uninstalling and re-installing the
    > > > .net framework.
    > > >
    > > > Thanks for any suggestions. 
    > > 
    > > 
    Friday, February 22, 2008 8:23 PM