Visual Studio 2010 Intellisense not working


  • Hi,

    I am working on Silverlight. Xaml intellisense is  not working in visual studio 2010.

     When I checked in the tools-->Text Editot---> XAML  -- > Auto List memeber is unchecked and it is disabled. I am not able to check it.


    Please help me  in solving this issue.

    Thanks in advance.


    Wednesday, June 09, 2010 6:42 PM

All replies

  • Hi,

    I checked my visual studio 2010, the Auto List member is also unchecked and disabled, but I have xaml intellisense, so I guess it doesn't matter.

    May I ask which version of vs2010 are you using? Is the xaml intellisense not working for only silverlight or for both silverlight and wpf? Have you tried to reset visual studio settings?

    Friday, June 11, 2010 3:59 AM
  • Verison: VS 2010 Ultimate

    Intellisense is working for WPF.

     I followed the link which you gave to reset the VS setting .Still I am facing the same issue.




    Saturday, June 12, 2010 10:28 PM
  • Hi,

    If you're using RC version, please check below post:

    Thursday, June 17, 2010 2:36 AM
  • I have had a similar issue with intellisense working in some XAML files and not working in other XAML files and solved it this way:

    1) right click on your not working XAML file in Solution Explorer

    2) choose "Open with..."

    3) Select Automatic Editor Selector (XML) and set it as default


    I guess somehow IDE didn't recognize that file as XAML file and treated it as a general XML file

    Monday, September 06, 2010 6:48 AM
  • Uninstalled and made clean install.Its working

    Monday, November 01, 2010 7:25 PM
  • I tired all of the above.  None worked.  I created a new xaml page (intellisense worked here) and decided to systematically recreate the bad xaml page with the new one by copy/pasting of code.  As Irish luck would have it, the very first thing I added was the problem:


    Thursday, December 02, 2010 11:28 AM
  • This worked for me!!


    Tuesday, September 06, 2011 4:55 AM
  • Sometimes this is caused just by adding some reference.

    For example Telerik.Windows.Controls.DataVisualisation.dll breakes intellisnse in vs 2012 RC.

    another examle:
    1 .create wpf control library and use XmlnsDefinitionAttribute is assemblyingo.cs
    2. in any project that references this library is xaml intellisense broken in VS 2012 RC


    Wednesday, June 06, 2012 9:55 AM
  • "For example Telerik.Windows.Controls.DataVisualisation.dll breakes intellisnse in vs 2012 RC."

    That did it for me.  Removed the reference in the project and I got my Intellisense back in Xaml.

    Tuesday, September 11, 2012 1:41 PM