locked
Not working with Chrome RRS feed

  • Question

  • Web site I use for work needs Silverlight to function. I use Google Chrome for internet browser. Keeps telling me I need to install Silverlight to open page wont let me go any further, however I can open work program with internet explorer with no problem. 

    What can I do??

    Tuesday, May 26, 2015 12:46 PM

Answers

  • Google have set the npapi plugin to disabled by default since April.

    There's a work round:

    http://social.technet.microsoft.com/wiki/contents/articles/30387.silverlight-trouble-shooting-installs.aspx#Chrome

    But note that you will find in September even that doesn't work,

    I therefore suggest you use a different browser.

    Since it works in internet explorer, what is the issue with using IE?

    Bearing in mind that Chrome will not be an option in a few months.


    Hope that helps.

    Technet articles: WPF: Change Tracking; All my Technet Articles

    Tuesday, May 26, 2015 1:11 PM
    Moderator
  • Hi runtime2020,

    >>I use Google Chrome for internet browser. Keeps telling me I need to install Silverlight to open page wont let me go any further
    In April 2015 NPAPI support is disabled by default in Chrome and in September 2015, NPAPI support will be permanently removed from Chrome, which you could read from this article. So I suggest you exchange your browser for others, such as IE or Firefox.

    >>What can I do??
    Please set your Google Chrome as below steps before this September:
     1. Go to chrome://flags/#enable-npapi
     2. Turn on npapi plugin
     3. Restart Chrome
     4. Go to chrome://plugins/ and enable Microsoft Silverlight (optional)

    Best Regards,
    Vegetable Wendy

    Wednesday, May 27, 2015 8:37 AM
  • When Chrome made this switch, we encouraged our users to install out of browser.  That however turned into another headache recently.  See this post.

    For now we have been telling our users this:

    If Chrome is your favorite browser you can still keep it as your favorite browser but create a shortcut to the application by:

    - Open IE and enter the URL to the application
    - Drag the URL icon from IE down to the Windows Task Bar.  A tool top appears that says "Pin to Task Bar"
    - Drop the URL icon ontop the task bar
    - Now whenever you wish to launch the application, click the pinned task bar icon and the application will open in IE


    Tim H


    Wednesday, May 27, 2015 6:49 PM

All replies

  • Google have set the npapi plugin to disabled by default since April.

    There's a work round:

    http://social.technet.microsoft.com/wiki/contents/articles/30387.silverlight-trouble-shooting-installs.aspx#Chrome

    But note that you will find in September even that doesn't work,

    I therefore suggest you use a different browser.

    Since it works in internet explorer, what is the issue with using IE?

    Bearing in mind that Chrome will not be an option in a few months.


    Hope that helps.

    Technet articles: WPF: Change Tracking; All my Technet Articles

    Tuesday, May 26, 2015 1:11 PM
    Moderator
  • Hi runtime2020,

    >>I use Google Chrome for internet browser. Keeps telling me I need to install Silverlight to open page wont let me go any further
    In April 2015 NPAPI support is disabled by default in Chrome and in September 2015, NPAPI support will be permanently removed from Chrome, which you could read from this article. So I suggest you exchange your browser for others, such as IE or Firefox.

    >>What can I do??
    Please set your Google Chrome as below steps before this September:
     1. Go to chrome://flags/#enable-npapi
     2. Turn on npapi plugin
     3. Restart Chrome
     4. Go to chrome://plugins/ and enable Microsoft Silverlight (optional)

    Best Regards,
    Vegetable Wendy

    Wednesday, May 27, 2015 8:37 AM
  • When Chrome made this switch, we encouraged our users to install out of browser.  That however turned into another headache recently.  See this post.

    For now we have been telling our users this:

    If Chrome is your favorite browser you can still keep it as your favorite browser but create a shortcut to the application by:

    - Open IE and enter the URL to the application
    - Drag the URL icon from IE down to the Windows Task Bar.  A tool top appears that says "Pin to Task Bar"
    - Drop the URL icon ontop the task bar
    - Now whenever you wish to launch the application, click the pinned task bar icon and the application will open in IE


    Tim H


    Wednesday, May 27, 2015 6:49 PM
  • see some screenshots on what to do till Chrome phase-out NPAPI plugins completely

    https://zoomicon.wordpress.com/2015/05/26/fix-enable-silverlight-other-npapi-plugins-at-chrome-web-browser/


    Microsoft MVP J# 2004-2010, Borland Spirit of Delphi 2001

    Sunday, June 14, 2015 5:28 PM