locked
Intelligent Performance - Performance Recomendations not showing RRS feed

  • Question

  • MySQL 8.0

    performance_schema = on

    query_store = on

    Not seing the intelligent performance section or recommendations. On the manage MySQL section of Azure. 

    Saturday, April 25, 2020 5:20 PM

Answers

  • Hi WestWes,

    Did you just enable this functionality or have you had query store enabled for a period of time to allow for data to be collected? The recommendations are based upon a history of transactions so a period of time must elapse between enabling the feature and recommendations to be made. 

    In the portal you should see a section on the left-side navigation entitled Intelligent Performance with a menu option for Query Performance Insight. Do you not see this? Below is the document that explains this feature. 

    Query Performance Insight in Azure Database for MySQL

    Regards,

    Mike

    • Marked as answer by WestWes Monday, May 4, 2020 1:51 PM
    Monday, April 27, 2020 9:56 PM

All replies

  • Hi WestWes,

    Did you just enable this functionality or have you had query store enabled for a period of time to allow for data to be collected? The recommendations are based upon a history of transactions so a period of time must elapse between enabling the feature and recommendations to be made. 

    In the portal you should see a section on the left-side navigation entitled Intelligent Performance with a menu option for Query Performance Insight. Do you not see this? Below is the document that explains this feature. 

    Query Performance Insight in Azure Database for MySQL

    Regards,

    Mike

    • Marked as answer by WestWes Monday, May 4, 2020 1:51 PM
    Monday, April 27, 2020 9:56 PM
  • Thank you Mike for the reply. I do have it enabled, when you say period of time, how long are we talking? Hours or days?
    Monday, April 27, 2020 10:14 PM
  • Hi West,

    Has any of the query store information been made available? If it has not been made available, can you have a support request created to investigate this? If you don't have an Azure Support Plan, can you send me your Azure Subscription GUID to AzCommunity and I will return instructions to engage support to have this investigated.

    Regards,

    Mike

    Thursday, April 30, 2020 10:07 PM
  • We ended up disabling. Memory usage was increasing hour over hour up to 30%. Were still going to evaluate it but over the weekend and slow days. 
    Friday, May 1, 2020 2:21 PM
  • Thanks for the update. This is potentially a bug so, if you don't have a support plan I can enable a one-time support request to have this investigated. If this is the case, please send me your Azure Subscription GUID to AzCommunity and I will return steps to have this issue investigated.

    If the issue resolved itself or you find a solution, that will be helpful to detail so as to understand what was occurring. 

    Regards,

    Mike

     
    Friday, May 1, 2020 5:06 PM
  • HI Mike, 

    After letting it be over the last 3 days, all is well now. The CPU performance is back to normal and the performance section is viewable. Thanks again!

    Monday, May 4, 2020 1:51 PM
  • Great, thank you for the update. I like these types of resolutions. 

    Regards,

    Mike

    Monday, May 4, 2020 4:18 PM