Error: Unhandled Error in Silverlight 2 Application [Async_ExceptionOccurred]

    General discussion

  •  I've chasing my tail on this issue for a couple days now and figured it's time to toss it out to the forums for help.

     I have a Silverlight 2.0 charting app that calls a Web Service to obtain it's data.  The App and Service are deployed on a VM Server.  App loads great for my machine AND another person.  Third person, running XP and Firefox 3.0 does not get the correct load and gets a page error.   Using Fiddler, I don't see any errors coming back, but I do see that it's hanging/stopping on the HTTP result that happens right before the xap file is loaded.  I have a clientaccesspolicy in place, am using basicHttpBinding and can browse the service manually from the machine that can't load the Silverlight page.

     Any thoughts?  (error that's on the page is listed below).

     Error: Unhandled Error in Silverlight 2 Application [Async_ExceptionOccurred]
        Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See at System.ComponentModel.AsyncCompletedEventArgs.RaiseExceptionIfNecessary ()
    BudgetTracker.BudgetTrackerService.GetAllActiveProjectsCompletedEventArgs.get_Result ()
    BudgetTracker.Page.bsc_GetAllActiveProjectsCompleted(Object sender, GetAllActiveProjectsCompletedEventArgs e)
    BudgetTracker.BudgetTrackerService.BudgetServiceClient.OnGetAllActiveProjectsCompleted (Object state)
    Code: 0
    URL: http://xx.xx.xx.xx:8040/BudgetTrackerTestPage.aspx

    Thursday, July 23, 2009 3:46 PM

All replies

  • Hi Status,

    Maybe a proxy cache or Firefox Cache ?

    Did you clear the cache of Firefox ?

    Are you using asmx web services or WCF web services ?

    and old xap cached by Firefox can contains old references to the service.

    Thursday, July 23, 2009 4:48 PM
  •  Already tried the FF cache.  Happens with IE and FF on this person's machine.


    I'm using a WCF service.



    Monday, July 27, 2009 10:51 AM
  • Hi,

    Some strange issues happens in Firefox3 is caused by old versions of silverlight.js file. Try updating silverlight.js.

    Please check Tim Heuer's blog


    Thursday, July 30, 2009 4:16 AM
  •  Another good suggestion.  Tried it this morning with no effect.  Where it's failing is the Async call to the WCF Service that returns a simple list of active projects in the database.  This call works on four other machines (and users), but for this one user, who has ActiveDirectory access and can browse the WebService manually can't load the Silverlight page.



    Thursday, July 30, 2009 10:45 AM
  • Hi,

    Check Firefox's scurity setting, see this thread



    Friday, July 31, 2009 6:40 AM
  •  Checked the security settings and content exceptions.  Nothing there is different from my machine. 


    Problem:   Error: Unhandled Error in Silverlight 2 Application [Async_ExceptionOccurred] Arguments:

          It's failing on an Async call to the WCF Service that returns a simple list of active projects in the database.

    1. It works on six other machines, but not on the project manager's machine.
    2. The machine that it's failing on, it's failing in Firefox, IE6 and IE8, running WindowsXP
    3. The problem user can browse the WCF service by manually navigating to it.
    4. Silverlight.js is updated and correct.
    5. I have a crossdomain.xml and clientaccesspolicy.xml policy in place (yes, I know I don't need both and have tried each individually).
    Friday, July 31, 2009 1:09 PM
  •  Problem is somewhat resolved.  Never found out the issue or really fixed the problem.  User ended up installing Windows7 and it went away.




    Thanks all for your help.

    Monday, August 03, 2009 7:06 PM
  • Late but thought this might help someone else. I was getting the same exception and noticed that it was always the same users. Others would not get this exception. I used fiddler and the web service request was getting stuck at status code 302 (Found). I put a try catch block in the web service code and trapped the error which mentioned a permissions error on one of the stored procedures I was using. I granted permissions to all users and this solved it! If you are seeing this error with certain users only, check to see that your sql permissions are correct (if the web service calls stored procedures).

    Wednesday, January 12, 2011 2:34 PM