New Netflix Error


  • Silverlight Installation Problem

    Error Code: 2103

    You have encountered an issue specific to Microsoft Silverlight, the software used to watch movies on the Netflix website. This issue is often resolved by uninstalling and then reinstalling Microsoft Silverlight on your computer.

    To uninstall Microsoft Silverlight on your Windows computer, please follow these steps:

    1. Close any currently open internet browser windows
    2. Click on the Start button.
    3. Select Control Panel.
    4. In Windows XP, select Add or Remove Programs. In Windows Vista/Windows 7, select Programs & Features.
    5. Locate and click on Microsoft Silverlight
    6. Choose Remove in Windows XP or Uninstall in Windows Vista/Windows 7.

    After completing the above steps, attempting to Watch Instantly on will prompt you to reinstall Microsoft Silverlight.

    I have been using netflix for months without any problems. I had not upgraded my brower or silverlight when this occured. I tried uninstalling and installing again and it give me the same message.

    This is only happening with mozilla firefox browser. It works in IE. I run on XP. The problem is just with firefox. And that stinks because I cannot go back to using Internet Explorer. Please help.

    Any ideas on how to fix this?

    • Moved by mbanavige Sunday, May 06, 2012 10:02 PM Migration data
    Sunday, May 06, 2012 6:43 PM


All replies

  • Hi authorgirl,

    The link in last reply of below discussion gave three possible solution for this error.

    Please have a try.


    Best Regards,

    Tuesday, May 08, 2012 12:01 AM
  • Just for every ones basic information about certain Netflix/Silverlight error pertaining to not able to stream Netflix. I searched for many of hours trying to fix my issue. I did the reinstall Silverlight thing, two times, once with Mr Fixit, and once  with a total manual clean uninstall. Then I did the Play ready pc clean uninstall then reinstall.

     So, If anyone has a 64 bit PC, like I  do, Running Windows (I have 7, but I don't think it makes a difference), Windows/Microsoft download center will give you the 64 bit Play Ready. And for some reason unless you search for Play Readyx86, they don't show the option. I found that when I did do all my research on this issue,  at one point some where I saw use internet explorer x86, not the 64 bit, when resolving the Netflix streaming issue, (sorry Msoft, but I use  chrome as default).

     So I fixed My issue, I needed the play ready x86!! When I saw somewhere to use IEX86, I thought Hey, lets try Play Ready x86! I downloaded it, hit install, waited for the error message saying it don't work on my 64 bit sys, and it never came up!  Sweet!

     Lo and behold, my Netflix streams fine now. With both Chrome and IEX.

    In the end, if you have a 64 bit OS, Make sure you download both 64 and x86 Play Ready. MS update and the website wont give you that option. It sees  you have the 64 bit OS, and it gives you only the 64 bit play ready option. WHATS UP WITH THAT Microsoft??

    Wednesday, April 24, 2013 1:31 AM